Jump to content

Problema con flash player


 Share

Recommended Posts

Hola a todos, necesito ayuda con una pagina hecha en flash, bueno, solo a medias...

En la página cuando entras a la primera página, la principal, sale una página en html, con una breve introduccion y un botón para entrar a la página del menu principal. Entre estas dos páginas, o sea, cuando picas al botón entrar, salta una presentación en flash, y cuando acaba la presentación, directamente se abre la página del menu principal, la cual tambien está también hecha en flash. Pues bien, mi problema es que en mis ordenadores y en el de mis amigos se ve todo correctamente, pero en ordenadores "poco cuidados" vamos, que solo lo utilizan para el mesenger y poco mas, que no se descargan los ultimos plugins, no ven la presentación ni la página indice.... Al principio me di cuenta que sería por la version en la que publicaba los archivos, que eran en flash player 8, asi que lo cambie y los publique en flash player 5, pero el problema persiste y ya empiezo a subirme por las paredes, porque además, en los ordenadores que no se carga la página, les sale una pantallita de adobe como descargando el shockwave, pero enseguida se va la barra de carga y se queda la página en blanco. He probado con explorer y con firefox...

 

Espero haberme explicado y tambien espero que alguien me de una solución porfavor.... (es mi primera página en flash... supongo que los entendidos lo notareis por el problema...)

 

Bueno, muchas gracias por adelantado!!!

Link to comment
Share on other sites

Así en principio no parece que el problema sea de tu trabajo, más bien parece de esos ordenadores "poco cuidados"- Me parece mala opción que publique tu trabajo en Flash 5, perderás algunas de las opciones que te ofrecen las últimas versiones e incluso puede que varíen partes de la película.

 

Por defecto en los códigos que genera el Flash a la hora de publicar tus trabajos para html o incluso cuando insertas un elemento Flash con alguno de los editores de html más conocidos (GoLive o Dreamweaver) se incluyen accesos a la página de descarga de la última versión del plugin del FlashPlayer, si esta página no funciona en esos ordenadores puede ser por problemas en la página de Adobe (cosa poco probable pero que puede pasar) o por problemas en esos ordenadores.

 

En cualquier caso si nos pones el enlace a la página en cuestión podremos analizar mejor el problema.

 

Un saludo.

Link to comment
Share on other sites

Hola a_martin01, siento decirte que he tratado de ver tu pagina y no la puedo ver, solo veo la pagina principal pero cuando le doy a entrar se queda en blanco con el logo de macromedia shockwave.

 

Mi ordenador no es de los "poco cuidados", mas bien yo diria que es de los muy cuidados, yo utilizo bastante flash y nunca he tenido problema para ver las paginas.

 

Espero que lo soluciones. ;)

Link to comment
Share on other sites

Creo que tienes problemas en el código de embebido de la peli de flash, la tag object, cambialo por este otro código:

 

 
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,5,0,0" width="800" height="600" id="principal.swf" align="middle">
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="principal.swf" />
<param name="quality" value="high" />
<param name="bgcolor" value="#ffffff" />
<embed src="http://www.electrainst.com/docflash/principal.swf" quality="high" bgcolor="#ffffff" width="550" height="400" name="principal.swf" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>

 

A mi me funciona. Un saludo. ;)

Link to comment
Share on other sites

joer... pos he preguntado a tres amigos mios y a ellos no se les carga. dicen que la pagina en la que antes se cargaba el shockwave, ahora solo se les queda la pagina en blanco,pero que sigue sin cargarsela...

 

A mi no me carga en el internet explorer, solo me carga en el firefox 2.0...

Edited by a_martin01
Link to comment
Share on other sites

Pues ciertamente no veo nada extraño. He testado la web en Safari, Explores Mac y Explores PC y me funciona bien en todos los casos. Bueno e el caso de los PC ya sabes que ahora con los jaleos de las actualizaciones nuevas te aparecen alertas de seguridad en las barras de navegación y la coña esa de activar el control pinchando sobre la peli de flash, pero funcionar funciona. Eso si no pusiste un precargador y si la línea de acceso no es rapidilla (ADSL vamos) la pantalla se queda en blanco asta que se ejecuta la animación inicial, el tiempo de esta pantalla en blanco dependerá de la velocidad de conexión de cada usuario.

 

He testado también la dirección de Adobe donde te redirecciona para conseguir el plugin y funciona correctamente.

 

Así que no se que más decirte, lo siento

Link to comment
Share on other sites

no hombre, muchas gracias por todo, gracias a ti me funciona. Ire probando en diferentes ordenadores y si veo que no me carga en unos cuantos quitare el flash y listo. la web es para un amigo y quiso el que lo pusiera, lo convenceré y ya está... mucahs gracias a todos

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.