Jump to content

Presentacion y duda sobre manejo de particiones ext3 y fat32 en Mac OS


Recommended Posts

Hola a todos:

 

hace un par de meses me compre un macbook intel y empece el proceso de instalar el 3 boot en el. Tras varios intentos consegui instalarlo y todo va bien, solo tengo un problemilla y es que cuando arranco el ordenador con refit y intento cargar linux o windows se carga el grub de linux pero solamente 1 vez de cada 20 puedo usar las teclas para moverme en el menu del grub y escoger linux o windows para arrancar.

Mi duda es si el fallo estara en refit o esque no hice algo bien. Cuando hago diskutil de la particion de linux me sale que no tiene nombre ni sistema de archivos y no se si eso puede ser la causa de que no arranque bien el grub.

 

Este el estado de mi disco, en el que disk0s3 es la particion de linux y disk0s4 es la de windows

 

/dev/disk0

#: type name size identifier

0: GUID_partition_scheme *74.5 GB disk0

1: EFI 200.0 MB disk0s1

2: Apple_HFS Macintosh HD 47.2 GB disk0s2

3: Microsoft Basic Data 12.0 GB disk0s3

4: Microsoft Basic Data WINDOWS XP 15.0 GB disk0s4

 

l$ diskutil info disk0s3

Device Node: /dev/disk0s3

Device Identifier: disk0s3

Mount Point:

Volume Name:

 

Partition Type: Microsoft Basic Data

Bootable: Is bootable

Media Type: Generic

Protocol: SATA

SMART Status: Verified

 

Total Size: 12.0 GB

Free Space: 0.0 B

 

Read Only: No

Ejectable: No

 

Mikel$ diskutil info disk0s4

Device Node: /dev/disk0s4

Device Identifier: disk0s4

Mount Point: /Volumes/WINDOWS XP

Volume Name: WINDOWS XP

 

File System: MS-DOS FAT32

Partition Type: Microsoft Basic Data

Bootable: Is bootable

Media Type: Generic

Protocol: SATA

SMART Status: Verified

 

Total Size: 15.0 GB

Free Space: 10.3 GB

 

Read Only: No

Ejectable: No

 

 

Un saludo

Link to post
Share on other sites

creo recordar que hay un Bug en alguna versión del rEFIt para Mac y petaba de vez en cuando, que versión pusiste ?

 

que distribución de Linux tienes instalado, lo mismo para Windows XP. Vista ...etc.

 

Yo creo que podría ser por ahí la historia, algún tipo de bug en algo, porque no recuerdo nadie con ese problema, por lo menos en este foro.

 

saludos

Link to post
Share on other sites

Holas:

 

puse la version de ubuntu 6.10 (edgy creo que es) y windows XP profesional SP2 todos ellos utilizando la version 0.9 de refit.

Me gustaria saber tambien si puedo eliminar las particiones que cree para windows y linux desde uan terminal y dejar el disco duro entero para Mac OS para asi empezar la instalacion desde 0 haber si esque hice algun paso mal.

 

saludos y gracias

Link to post
Share on other sites

a mi me paso lo mismo es debido a que el ultimo ubuntu 7.04 te obliga a instalar la grub, si instalas el 6.10 como dice en los tutoriales que hay por ahi, te da un error al instalar la grub (no te la instala) y te arranca todo desde refit correctamente, no se mete en la grub, por que no la necesas para nada

 

recomendacion: instala 6.10 y upgradea

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.