Jump to content

Problemas con iWeb y otros servidores


Recommended Posts

Hola foreros. Estoy haciendo una web en iweb para subirla a un servidor distinto de .mac y estoy teniendo problemas que no sé de donde vienen, pues soy un auténtico novato en esto de hacer webs. Os mando dos imágenes: la primera como se ve en iweb y .mac y la segunda cómo se ve en el servidor, que es el siguiente: centros3.pntic.mec.es

 

iwebscreensnapz001ge9.jpg

 

Esta es la imagen desde iweb o desde .mac

 

 

 

 

 

safariscreensnapz001un5.jpg

esta es la imagen desde el servidor antes mentado vista en safari.

 

Como podéis ver, tildes y otros caracteres raros no salen bien. Así que la página queda hecha un churro.

 

Por supuesto que esta no es la página, es sólo un ejemplo para que veáis lo que ocurre.

 

La verdad es que no tengo ni idea de qué hacer o cómo hacerlo.

 

¿Alguna idea?

Edited by dabenza
Link to post
Share on other sites

que cosa mas rara... yo trabajo con 1and1

y todas las paginas que hago se ven perfectamente......

mira las de mi firma estan echas con iWeb06 y no dan prooblemas.....

 

pruebaa cambiar la fuente de la leyta a ver si se ve algo

Link to post
Share on other sites

Az lo siguiente, antes de publicar en una carpeta borra todos los archivos que tengas de antes y prueba la pagina con una fuente Arial.

En ciertos casos cuando la tipo no corresponde a ninguna del catalogo web el iWeb rasteriza los textos conviertiendolos en imagenes, es podible que te pase eso.........

 

 

seguire investigando :D corto y cambio

Link to post
Share on other sites

Parece ser que tengo la raiz del problema localizada. Iweb publica las páginas en UTF-8 un estandar web que presenta problemas en escritura hispanoparlante. El estandar que más se ajusta al castellano es el ISO-8859-1, pero iWeb no te permite guardar en ese estandar.

 

La solución se me complica ¿alguna idea?

 

Es un servidor gratuito?

A mi con Licos me hacia lo mismo :(

 

 

No es un servidor gratuito, es el servidor de la consejería de educación de la región de murcia.

Link to post
Share on other sites

Efectivamente dabenza tiene razón, el problema, este en concreto ya que iWeb da algún otro problema de compatibilidad al sacarlo de servidores .mac, es la codificación de las páginas. Y si, ciertamente tenéis abrir los archivos html con un editor de texto y cambiar esa parte del código, que está en la parte inicial.

 

Pero puede que esto no solucione del todo el problema, ya que iWeb guarda en codificación UTF-8 pero genera por defecto algunos textos en otro formato.

 

La codificación UTF-8 permite escribir los acentos sin código añadido, así se puede poner "camión" y la palabra se interpretará correctamente pero en ISO-8859-1 al escribir "camión", el código lo interpreta como "camió".

 

Podéis verificar previamente el funcionamiento ya que si el archivo html tiene codificación UTF-8 y dentro existe algún testo con caracteres ń estos se verán mal.

 

En conclusión tendréis que reescribir algunos textos de nuevo. Hacer alguna prueba manteniendo la codificación y variando el texto y cambiando la codificación y manteniendo el texto ya que algunos servidores tienen opciones de forzar la codificación de las páginas a un formato determinado independientemente de lo que ponga en el código de las mismas.

 

Es un poco lioso este tema y alguna vez se ha tratado ya por aquí. Espero haber ayudado en algo y no haberos liado más.

 

Un saludo.

Link to post
Share on other sites

Gracias Rafamaldo. He contactado con el creador del programa y parece que no es de gran utilidad, pero ha entendido mi problema y me ha mandado a un par de sitios donde aclaran ciertas cosas, aunque, después de toda la tarde intentando aplicar las soluciones que aquí proponen, aun no he conseguido nada de nada. En fin, seguiremos intentándolo. Dejo estos enlaces por si hay alguien con el mismo problema y les pueden servir de algo.

 

http://homepage.mac.com/thgewecke/iwebchars.html

Link to post
Share on other sites

Tienes que hablar con tu proveedor de internet y decirle que quieres que la codificación de tu site sea por defecto UTF-8...

 

Parece ser que tengo la raiz del problema localizada. Iweb publica las páginas en UTF-8 un estandar web que presenta problemas en escritura hispanoparlante. El estandar que más se ajusta al castellano es el ISO-8859-1, pero iWeb no te permite guardar en ese estandar.

 

La solución se me complica ¿alguna idea?

(...)

UTF-8 es un tipo de codificación que va bien con cualquier lengua que se pueda escribir (o que quepa, para decirlo a lo bruto) en 8 bits, no presenta en absoluto ningún problema con la "escritura hispanoparlante", no veo por que alguien pueda decir eso. Es más, se debería ir abandonando ISO-8859-1 por UTF-8...

Link to post
Share on other sites

Después de una lucha sin cuartel con los del servidor, se niegan (aunque no sé las razones) a cambiar la codificación del servidor. Por si no lo había dicho, es el servidor que la consejería de educación ofrece gratuitamente a los centros docentes de la Región de Murcia. No pagamos nada por alojar la web del colegio, pero no podemos, al parecer, exigir que se muestre nuestra página en un código determinado. ¿Qué os parece todo esto?

 

Por cierto, busco host de pago, barato... ¿alguien se ofrece? :ph34r:

Link to post
Share on other sites
Después de una lucha sin cuartel con los del servidor, se niegan (aunque no sé las razones) a cambiar la codificación del servidor. Por si no lo había dicho, es el servidor que la consejería de educación ofrece gratuitamente a los centros docentes de la Región de Murcia. No pagamos nada por alojar la web del colegio, pero no podemos, al parecer, exigir que se muestre nuestra página en un código determinado. ¿Qué os parece todo esto?

 

Por cierto, busco host de pago, barato... ¿alguien se ofrece? :ph34r:

 

Te comento, hoy mismo me he puesto con el iWeb, he puesto texto con tildes y no me ha dado ningun problema.

El teclado en el macpro lo tengo en Español-ISO y al crear el texto en el IWeb , he seleccionado una fuente Española.

En la aplicacion te da la opcion de seleccionar fuentes de otros Idiomas, formatos Web, Favoritos , Divertida, PDF y como dije antes, en otros idiomas.

 

En Menu Formato, seleccionas tipo de letra y despues Mostrar tipos de letra, en la ventana que sale (en la parte izquierda) tienes Colecciones y debajo puedes seleccionar.. yo tengo español y al marcarlo seguidamente a la derecha tienes los tipos de letra y la seleccionas. Haz la prueba, no se si esto te ayudara a corregir tu problema, pero a mi no me ha dado ningun tipo de problema.

 

La he colgado en mi hosting (de pago) y la he abierto desde el Internet Explorer en windows desde un pc y en Safari desde el Macpro y se ve con las tildes. No hice ningun cambio ni nada por el estilo.

Link to post
Share on other sites
  • 8 months later...

Hola a todos, yo tengo el mismo problema.

Hemos hecho un par de páginas con Iweb, una para nosotros (www.huertaderiofrio.com) y otra para una amiga (www.mpa-traducciones.com) y en unos equipos se ven bien y en otros no. En diferentes máquinas con Internet Explorer y el mismo nivel de actualización, se ven unas bien y otras no, lo mismo pasa con los firefox y los safari (tenemos varios mac y varios pc's).

Las páginas están subidas en diferentes alojamientos, la nuestra está en virtualpyme y la de mi amiga está en arsys, ambos de pago.

Ya no se lo que hacer.

Agradecería alguna ayuda.

Un saludo a todos y Feliz Año

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.