Jump to content
Lillibit

[Temas unidos] DNI electrónico en OS X

Recommended Posts

Hola snieto2001,

 

Lo primero, gracias por la ayuda. Si no fuera por ti, ya lo habría dejado por imposible.

De nada y no te preocupes a todos les ha pasado que al principio no había forma de que funcionara, pero una vez entiendes la guía es muy fácil. Sólo hay que tener paciencia.

 

 

[Aplicación JavaScript]

Falló el inicio de sesión

 

Tengo el javascript activado, y creo no haber tocado nada raro. Aunque ya lo había dicho en otro post, las opensc que uso son las últimas, del 1 de agosto.

He desinstalado TODO incluyendo Firefox 6 y he vuelto a instalar todo otra vez instalado Firefox 3.6.19. Funciona sin problemas, de todas formas yo te recomendaría que te actualizaras a la última versión de Firefox.

 

Actualiza también, si no lo has hecho, la última versión de Java desde aquí.

 

 

Esta noche cuando vuelva a casa, le echo un vistazo a la nueva versión de la guía.

Lo importante es que actualices Java y Firefox y sigas la guía desde el anexo, es decir, desinstalando TODO y volviendolo a instalar tal y como te indico en la guía.

 

Saludos.

Share this post


Link to post
Share on other sites

Hola snieto2001,

 

De nada y no te preocupes a todos les ha pasado que al principio no había forma de que funcionara, pero una vez entiendes la guía es muy fácil. Sólo hay que tener paciencia.

 

He desinstalado TODO incluyendo Firefox 6 y he vuelto a instalar todo otra vez instalado Firefox 3.6.19. Funciona sin problemas, de todas formas yo te recomendaría que te actualizaras a la última versión de Firefox.

 

Actualiza también, si no lo has hecho, la última versión de Java desde aquí.

 

Lo importante es que actualices Java y Firefox y sigas la guía desde el anexo, es decir, desinstalando TODO y volviendolo a instalar tal y como te indico en la guía.

 

Saludos.

 

En cuanto al java, ya lo había actualizado (una de las 2 razones por las que actualice el SL fue por el java; la otra por esto del DNIe); ahora tengo la 1.6.0_26-b03-384 (sin que tenga que ver con esto: en la otra versión tenía 2 webs que tenían permiso (dado por mí) para ejecutar java sin preguntar: la AEAT y la junta de Castilla y León. Veía las direcciones. Ahora con el nuevo java no).

 

A lo que voy, lo que he hecho ha sido:

 

-Instalar el firefox 6, y con el cerrado:

-Anexo A1: con el primer comando se ha desinstalado el opensc, saliendo el mensaje de confirmación; borro los .bom y .plist (1 de cada) y compruebo que no están.

-Anexo A2: según el fabricante (c3po) valen los drivers genéricos, por tanto no puedo desinstalar nada aquí.

-Aunque no lo indicas: borro el certificado de la DGP y el módulo criptográfico.

-Reinicio el mac.

-Drivers del lector: genéricos y bla, bla, bla.

-NO reinicio (para qué si todavía no he instalado nada)

-Instalo el último opensc, del 1 de agosto.

-Reinicio el mac.

-Ejecuto los comandos del punto 5, y lo vuelve a reconocer bien (no lo he comentado, pero el lector va directo al mac, no a través de un hub; esto ha sido así siempre)

-Instalo el módulo criptográfico

-Y aquí vuelven los problemas: no me pide la contraseña, vuelve al rollo del token, y mirando, la línea AC RAIZ 003 (en mi caso 001) sale en ¡MIS CERTIFICADOS!, no en autoridades. Haciendo un log in con el módulo criptográfico, ahora me sale:

 

Alerta

Falló el inicio de sesión.

 

Y ahora que CREO recordar, me parece que tras una de las primeras desinstalaciones parciales, y siguiendo lo que antes seguía (la guía del soporte del DNIe) CREO recordar que me pidió el PIN, y caso de que así fuera, lo metí bien (puedo confundirme con win, ojo). ¿Qué pude haber hecho en su caso? Ni idea.

 

Sergio.

Share this post


Link to post
Share on other sites

Hola snieto2001,

 

-Instalo el módulo criptográfico

-Y aquí vuelven los problemas: no me pide la contraseña, vuelve al rollo del token, y mirando, la línea AC RAIZ 003 (en mi caso 001) sale en ¡MIS CERTIFICADOS!, no en autoridades. Haciendo un log in con el módulo criptográfico, ahora me sale:

 

Alerta

Falló el inicio de sesión.

Si no puedes iniciar no te va a funcionar el DNIe, hay algo que falla.

 

 

Y ahora que CREO recordar, me parece que tras una de las primeras desinstalaciones parciales, y siguiendo lo que antes seguía (la guía del soporte del DNIe) CREO recordar que me pidió el PIN, y caso de que así fuera, lo metí bien (puedo confundirme con win, ojo).

¿Creo entender que es posible que hayas superado el máximo de veces de introducción del PIN?. En ese caso tienes el DNIE bloqueado y debes ir a una Comisaría de Policía a un PAD (Punto de Actualización del DNIe) y desbloquearlo.

 

Saludos.

Share this post


Link to post
Share on other sites

Hola, xund. No, no he superado el número de intentos, ya que con el paralels y el internet explorer sí puedo meter bien el pin, y veo todo donde lo debo ver (lo acabo de comprobar). El problema es lo que tú comentas, que si no puedo iniciar sesión, algo falla, pero... ¿qué puede fallar? Ni idea.

 

Ya digo, creo que una vez sí me salió para meter el pin en firefix, pero no sé qué hice, ni como (puede que instalase alguna versión más antigua del opensc, o alguna otra cosa).

 

Sergio.

Share this post


Link to post
Share on other sites

Hola, xund. No, no he superado el número de intentos, ya que con el paralels y el internet explorer sí puedo meter bien el pin, y veo todo donde lo debo ver (lo acabo de comprobar). El problema es lo que tú comentas, que si no puedo iniciar sesión, algo falla, pero... ¿qué puede fallar? Ni idea.

 

Ya digo, creo que una vez sí me salió para meter el pin en firefix, pero no sé qué hice, ni como (puede que instalase alguna versión más antigua del opensc, o alguna otra cosa).

 

Sergio.

Hola snieto2001,

 

Puuuf... Está claro que lo que falla es el OpenSC.

 

Prueba ésto: Desinstala OpenSC como está en la guía, con todos los comandos de desinstalación y asegúrate que la carpeta OpenSC se borra del todo, si no, borrála tú a mano. Desinstala los dos certificados. Reinicia. Vuelve a instalar todo y a ver que pasa.

 

Perdona por no ser más preciso pero ésto del DNIe en Mac es una pu... Cada uno tenemos un equipo distinto y nos dan errores distintos. No te preocupes que, a base de perseverar, te funcionará.

 

Saludos.

Edited by xund

Share this post


Link to post
Share on other sites

No te preocupes por lo de no extenderte más. Ya sé que cada uno tenemos un lector (y macs distintos, algunos ya con Lion y otros con SL, etc), y con el poco sopoorte OFICIAL que hay (apple, bancos, la DGP...), hay que agradeceros a gente en proyectos o en foros la ayuda que buenamente dais.

 

A lo que voy: como al principio seguía el manual dela DGP, instalé tanto el opensc de opensc-project.org como el de la página del DNIe (el 1.4.8.1). Siguiendo los pasos de la guía sé que lo primero lo desinstalo, pero lo segundo... ¿también?

 

Otra cosa: con el terminal, ¿como busco todos los ficheros que se llamen openscXXXXXXX (donde obviamente XXXXXXX es "lo que sea")? Sí, con el "ls" en el raíz, pero no sé con qué opciones., Así, borro todo bien.

 

Y ahora que echo un vistazo (por mirar, nada más) a la guía del soporte del DNIe, lo que veo es lo de la última página, que dicen que el pin está bloqueado. Como te he dicho, en windows funciona bien, así que no está bloqueado, pero... si lo llegué a meter en algñun momento, y lo metí mal, ¿cabe la posibilidad de que haya almacenado esa clave "mala" en algún sitio, y por eso no vaya?

 

Sergio.

Share this post


Link to post
Share on other sites

Otra cosa: con el terminal, ¿como busco todos los ficheros que se llamen openscXXXXXXX (donde obviamente XXXXXXX es "lo que sea")? Sí, con el "ls" en el raíz, pero no sé con qué opciones.

 

Nope.

 

sudo find / -name "opensc*"

 

find es sensible a mayúsculas (por si hubiese un "Opensc", digo)

Share this post


Link to post
Share on other sites

No te preocupes por lo de no extenderte más. Ya sé que cada uno tenemos un lector (y macs distintos, algunos ya con Lion y otros con SL, etc), y con el poco sopoorte OFICIAL que hay (apple, bancos, la DGP...), hay que agradeceros a gente en proyectos o en foros la ayuda que buenamente dais.

 

A lo que voy: como al principio seguía el manual dela DGP, instalé tanto el opensc de opensc-project.org como el de la página del DNIe (el 1.4.8.1). Siguiendo los pasos de la guía sé que lo primero lo desinstalo, pero lo segundo... ¿también?

 

Otra cosa: con el terminal, ¿como busco todos los ficheros que se llamen openscXXXXXXX (donde obviamente XXXXXXX es "lo que sea")? Sí, con el "ls" en el raíz, pero no sé con qué opciones., Así, borro todo bien.

 

Y ahora que echo un vistazo (por mirar, nada más) a la guía del soporte del DNIe, lo que veo es lo de la última página, que dicen que el pin está bloqueado. Como te he dicho, en windows funciona bien, así que no está bloqueado, pero... si lo llegué a meter en algñun momento, y lo metí mal, ¿cabe la posibilidad de que haya almacenado esa clave "mala" en algún sitio, y por eso no vaya?

 

Sergio.

Hola snieto2001,

 

En principio solamente con el primer comando de desinstalación de mi guía sería suficiente para desinstalar todo. El problema es que habéis seguido la instalación de dnielectrónico.es (que no funciona) y habéis instalado varios programas. Además como no os ha funcionado habéis instalado diferentes versiones, hay tal "cacao" de software instalado que si no se quita y se borra todo rastro de él, no funcionará nunca el DNIe.

 

Lo mejor es que mires directamente con el finder dónde está instalado todo y si todavía hay rastro de algún archivo o carpeta lo borres a mano.

 

En el tema del PIN si pierdes un poco de tiempo mirando este hilo, verás que a gente que hacía todo lo que ponía en mi guía y no funcionaba, el problema era que tenía el DNIe bloqueado. Si tienes Windows puedes comprobar si lo tienes bloqueado y cuántos intentos le quedan para bloquearse.

 

Otro problema es que tengas los certificados caducados (tienen una duración de 30 meses). Comprueba en Windows que no los tengas caducados. Para todas estas cosas puedes leer las ayudas de la web dnielectronico.es.

Saludos.

Edited by xund

Share this post


Link to post
Share on other sites

 

Nope.

 

sudo find / -name "opensc*"

 

find es sensible a mayúsculas (por si hubiese un "Opensc", digo)

 

Gracias, mock. Pues he visto algo muy interesante: teniendo instalado el opensc, no me aparecen los ficheros .bom y .plist en /private/var/db/receipts. ¿podría estar aquí el problema? También veo que aparecen 5 ficheros en /System/Library/Security/tokend/Opensc.tokend/ContentsResources

 

Xund, con el finder no me muestra nada más que los dmg (si busco no por nombre, sino también por contenido, también salen las guías, pero no los directorios donde está todo instalado).

 

Y comprobado que me quedan los 3 intentos para que se bloquee y que NO tengo los certificados caducados (por una vez, windows vale para algo).

 

Sergio.

Share this post


Link to post
Share on other sites

También veo que aparecen 5 ficheros en /System/Library/Security/tokend/Opensc.tokend/ContentsResources

 

Xund, con el finder no me muestra nada más que los dmg (si busco no por nombre, sino también por contenido, también salen las guías, pero no los directorios donde está todo instalado).

 

Y comprobado que me quedan los 3 intentos para que se bloquee y que NO tengo los certificados caducados (por una vez, windows vale para algo).

 

Sergio.

Hola snieto2001,

 

A través del Finder puedes encontrar casi cualquier cosa en el Mac. Para todo lo demás, Spotlight.

 

Mueve todos los archivos OpenSC.tokend a unas carpetas en el escritorio acordándote dónde iba cada uno. Reinicia e inicia sesión con el DNIe.

 

Saludos.

Edited by xund

Share this post


Link to post
Share on other sites

Hola, xund. Perdona por la tardanza en contestar. A lo que voy: hice lo que decías de mover los archivos opensc.tokend (en realidad es un contenedor, como un app o un pkg) al escritorio, borrarlos de /System/Library/Security/tokend, reiniciar el mac e iniciar el firefox. Pues vuelve a salir el mensaje del tokend ya comentado. ¿Qué más puedo hacer? (he re-comprobado en windows si tengo el pin bloqueado y NO, no lo tengo bloqueado).

 

Otra cosa, como te comentaba, en /private/var/db/receipts, no tengo los opensc.bom y .plist ¿es normal?

 

Y en cuanto al uso del finder, está claro que no lo sé usar bien para buscar cosas. Ya miro en los foros o abro un hilo en el foro que corresponda.

 

Sergio.

Share this post


Link to post
Share on other sites

Hola, xund. Perdona por la tardanza en contestar. A lo que voy: hice lo que decías de mover los archivos opensc.tokend (en realidad es un contenedor, como un app o un pkg) al escritorio, borrarlos de /System/Library/Security/tokend, reiniciar el mac e iniciar el firefox. Pues vuelve a salir el mensaje del tokend ya comentado. ¿Qué más puedo hacer? (he re-comprobado en windows si tengo el pin bloqueado y NO, no lo tengo bloqueado).

 

Otra cosa, como te comentaba, en /private/var/db/receipts, no tengo los opensc.bom y .plist ¿es normal?

 

Y en cuanto al uso del finder, está claro que no lo sé usar bien para buscar cosas. Ya miro en los foros o abro un hilo en el foro que corresponda.

 

Sergio.

Hola snieto2001,

 

Tranquilo, a ver si conseguimos que te funcione el DNIe.

 

Es un problema de tokend, está claro. Firefox da problemas de tokend, incluso a mí que me funciona perfectamente el DNIe, Firefox de vez en cuando me tira error de tokend. En mi caso simplemente con reinicar Firefox se soluciona.

 

De los dos archivos OpenSC.tokend vuelve a poner el que estaba en la carpeta /System/Library/Security/. El que estaba en la carpeta /System/Library/Security/tokend no lo restaures.

 

La mayoría de los errores, si te lees el hilo, los tenemos localizados y haciendo "x" se soluciona. Pero hay alguno como el tuyo que no hay forma de arregrarlo, por eso estoy diciéndote cosas que puedes hacer: Prueba-fallo.

 

Hay algo que se me escapa...

 

Saludos.

Share this post


Link to post
Share on other sites

Xund, ¿archivoS opensc.tokend? ¿en plural?, Yo sólo tenía uno en /system/library/security/tokend, que lo he puesto como me dijiste en el escritorio para tenerlo controlado (el supuesto otro, el de /system/library/security, no existía... ni existe, al igual que los .plist y .bom).

 

Sergio.

Share this post


Link to post
Share on other sites

Xund, ¿archivoS opensc.tokend? ¿en plural?, Yo sólo tenía uno en /system/library/security/tokend, que lo he puesto como me dijiste en el escritorio para tenerlo controlado (el supuesto otro, el de /system/library/security, no existía... ni existe, al igual que los .plist y .bom).

 

Sergio.

Hola snieto2001,

 

Si, yo tengo varios archivos en la carpeta /Security y cuando borro el archivo OpenSC.tokend, me pasa lo mismo que a tí: No puedo cargar el módulo PKCS11 y no puedo usar el DNIe (me aparece error de token).

 

De todas maneras, he borrado esa carpeta y he vuelto a instalar todo de nuevo, y me funciona sin problemas.

 

Saludos.

Share this post


Link to post
Share on other sites

Hola, xund. Nada, He desinstalado todo, he comprobado con el comando find que no quedara nada, he reinstalado y vuelve a no fncionar.

 

Con el find he mirado que hay instalado, y sigo sin ver los archivos opensc.dnie.driver.bom y opensc.dnie.driver.plist, y tampoco veo el opensc.tokend en security, pero sí en security/tokend.

 

También me dice que un par de archivos (/dev/fd/3 y /dev/fd/4) no son directorios.

 

¿Por qué me faltan esos archivos? Sobre todo los drivers del dnie. No lo entiendo.

 

Sergio.

Share this post


Link to post
Share on other sites

Hola snieto2001.

 

Con el find he mirado que hay instalado, y sigo sin ver los archivos opensc.dnie.driver.bom y opensc.dnie.driver.plist

Si te fijas en el anexo de la guía dice: "Además tenemos que borrar los siguientes archivos o nos dará problemas de que hay versiones nuevas instaladas ya". Es decir, que estos archivos son restos que quedan de instalar los archivos de la web dnielectronico.es. Para que te funcione el DNIe estos archivos no los debes tener.

 

y tampoco veo el opensc.tokend en security, pero sí en security/tokend.

Yo los tenía de instalaciones anteriores. De todas maneras, como te he puesto en el post anterior, yo los borré TODOS y volví a instalar OpenSC y funciona.

 

Ahora, a excepción del lector, debemos tener la misma configuración. Por lo que el problema creo que puede estar en Firefox o incluso en SL. Prueba con diferentes versiones, no instales add-ons o plugins, repasa tus conexiones a internet, firewall,...

 

Saludos.

Edited by xund

Share this post


Link to post
Share on other sites

Hola de nuevo,

 

Hoy, probando el nuevo sistema de notificaciones Lexnet por primera vez en Mac, he tenido este fallo:

 

 

Conexión segura fallida

Ha ocurrido un error durante una conexión a lexnet.justicia.es.

El otro extremo de la conexión SSL no ha podido negociar un conjunto aceptable de parámetros de seguridad.

(Código de error: ssl_error_handshake_failure_alert)

Creo recordar que este error era solucionable ¿verdad?

 

Gracias

Share this post


Link to post
Share on other sites

Hola a todos.

Simplemente comentar que soy Juan Antonio (jonsito), el padre de la criatura (OpenDNIe)

y que tenéis versiones actualizadas permanentemente del driver en:

 

Página web del proyecto OpenSC y OpenDNIe:

......

Un saludo

Juan Antonio

 

Gracias Juan Antonio por el trabajo que estás haciendo. Logré hacer funcionar mi lector DNIe en SL pero al instalar lion (instalación nueva) no puedo pasar de intentar instalar el openSC, me sale un errorscreen-capture.png como bien podeis ver ahí y lo he intentado con varias versiones pero con todas da ese mismo error.

 

¿Alguna sugerencia?

 

¡Gracias por cualquier ayuda!

Share this post


Link to post
Share on other sites

Hola miansancor,

 

Te debería contestar jonsito, pero te voy a contestar yo. Como bien dices has instalado Lion mediante una instalación nueva. Lion (10.7) es un sistema operativo diferente a Snow Leopard (10.6.8) y el proyecto OpenDNIe al igual que algunos fabricantes de lectores, de momento, sólo han sacado versiones para SL.

 

En este hilo se da soporte a SL, no a Lion. Si hay gente que le funciona (más o menos) en Lion es porque no han hecho una instalación nueva sino que han actualizado desde SL.

 

De todas maneras te invito a que sigas visitando el foro que iremos actualizando según vayan saliendo drivers, versiones y updates nuevos para Lion.

 

Saludos.

Share this post


Link to post
Share on other sites

Hola muy buenas, paso a explicar como me ha funcionado el dichoso DNI electrónico de Plan Avanza 2.

 

Sistema: Mac Os X Lion v10.7.1 (Instalación limpia desde 0)

Firefox: v.6.0.2 en modo 32bits.

OpenSC: 0.2.8

 

1º He seguido el tutorial http://nauj27.com/blog/2009/11/19/dnie-en-mac-os-x-snow-leopard/ cambiando o modificando algunos pasos, el primer paso es que en el tutorial te dicen que instales el software OpenSC 0.2.3pre2 hoy dia existe una version mas actualizada y que no genera problemas, la 0.2.8 descargarla de aquí http://www.opensc-project.org/files/sca/sca-0.2.8.dmg

 

2º Seguimos el tutorial referenciado en el primer paso hasta llegar al punto "Instalación del dispositivo de seguridad" donde pararemos y lo que haremos será abrir firefox en modo 32bits

 

aplicaciones-firefox1.png

,

una vez abierto firefox en modo 32bits seguir el tutorial y ya no debería generar el problema de "No es posible añadir modulo".

 

3º Podemos completar el tutorial con esas pequeñas modificaciones anteriormente dichas y al menos en mi caso esta funcionando todo sin problema, acabo de descargar la vida laboral y todo OK.

 

Saludos y espero haber ayudado.

Edited by notariorojo

Share this post


Link to post
Share on other sites

Hola notariorojo,

 

En este foro casi todos sabemos el "truco" de Firefox en modo 32 bits pero si has seguido el hilo y has visto mi guía te habrás dado cuenta que a nuestra manera nosotros no tenemos que modificar nada. Tanto el sistema operativo como el navegador funcionan en modo 64 bits.

 

El proyecto OpenDNIe, gracias a jonsito, está en constante desarrollo y saca versiones cada poco tiempo introduciendo nuevas características, como la firma digital, y arregla bugs.

 

De todas formas gracias por tu aporte. Si alguien que no le funciona en Lion quiere probar a tu manera que lo haga, pero si tiene dudas se las tendrás que solventar tú.;)

 

Saludos.

Share this post


Link to post
Share on other sites

 

En este hilo se da soporte a SL, no a Lion. Si hay gente que le funciona (más o menos) en Lion es porque no han hecho una instalación nueva sino que han actualizado desde SL.

 

 

No he seguido el hilo completamente, solo quería corregir esto que tu mismo escribiste y que desmiento totalmente en mi caso.

 

De todas formas si alguien quiere preguntar aquí estoy para lo que pueda ayudar.

 

Saludos

Share this post


Link to post
Share on other sites

No he seguido el hilo completamente, solo quería corregir esto que tu mismo escribiste y que desmiento totalmente en mi caso.

 

De todas formas si alguien quiere preguntar aquí estoy para lo que pueda ayudar.

 

Saludos

Hola notariorojo,

 

Si no hay nada que desmentir, si sigues el hilo desde mi guía te darás cuenta que no usamos el "truco" de los 32 bits, siempre hablamos de Firefox en 64 bits. Si tengo un sistema operativo de 64 bits y un navegador de 64 bits, ¿por qué lo tengo que poner en 32 bits?. Desde mi punto de vista es un atraso (seguridad, add-ons, plugins,...).

 

Yo hice ese comentario en función de lo que están contando en el hilo los demás foreros. Yo no tengo Lion y no lo tendré hasta febrero así que no puedo contar mi experiencia con Lion.

 

Muchos en este foro usábamos ese truco con SL pero aquí intentamos hacer que funcione todo en 64 bits. Si de tu manera se puede entrar en los bancos, hacer la declaración de la renta, las del IVA, firmar digitalmente,... y a alguien le sirve, adelante. El problema es que es volver un paso a atrás. Yo personalmente me fío más del desarrollo de OpenDNIe que de la web dnielectronico.es y ésa es mi experiencia.

 

Lo de responder preguntas que pueden surgir con tu método te lo comento porque, de momento, el único que tiene esa configuración eres tú. Con el otro método somos más los que podemos ayudar.

 

Saludos.

Edited by xund

Share this post


Link to post
Share on other sites
Gracias Juan Antonio por el trabajo que estás haciendo. Logré hacer funcionar mi lector DNIe en SL pero al instalar lion (instalación nueva) no puedo pasar de intentar instalar el openSC, me sale un errorscreen-capture.png como bien podeis ver ahí y lo he intentado con varias versiones pero con todas da ese mismo error.

 

¿Alguna sugerencia?

 

¡Gracias por cualquier ayuda!

Hola

como comentan más arriba, las últimas versiones de OpenSC-OpenDNIe no se dejan instalar (aún) en las últimas versiones de OS X (por ej. la versión 0.12.3 svn 412 sí se deja instalar en la 10.7.0 pero no en 10.7.1). Mientras lo arreglan, puedes probar (bajo tu propio riesgo, eso sí ;) ) la última versión de las que compilo yo, que está editada para poder instalarse en 10.7.0 o 10.7.1. Es la que yo estoy utilizando y, por el momento, no me ha dado problemas. La descarga seria desde aquí: http://www.kounch.com/download/opendnie/

 

Para quien esté interesado, he actualizado las notas con información sobre compilación explicando dónde se debe hacer el cambio, aquí: http://kounch-mac.blogspot.com/2011/02/compilacion-de-opendnie-para-mac-os-x.html

 

Un saludo

kounch

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.