Jump to content
Lillibit

[Temas unidos] DNI electrónico en OS X

Recommended Posts

Xund, gracias por tu colaboración pero en mi primer post ya se indica claramente que estoy trabajando en un iBook. No obstante, ¿se te ocurre algo?

Perdona por no conocer todos los modelos habidos y por haber de Apple pero yo me introduje en el mundo Mac con un MacPro Intel. Si hubieras puesto que era un equipo con arquitectura PowerPC y modo 32 bits...

 

No sé que guía tendrás pero el proceso de desinstalación es el mismo que aparece en la que hice yo. Creía que estabas siguiendo la mía,... Por curiosidad, ¿me puedes poner el enlace a la guía que has seguido?.

 

En arquitectura PowerPC ni tan siquiera jonsito y OpenDNIe dan soporte, lo deberías haber leído en un post anterior. Vamos, que te tienes que fiar de dnielectronico.es (lo tienes crudo...).

Tranquilo, no pasa nada. Sencillamente pensé que indicar iBook queda claro que no es Macbook y por lo tanto se presuponía...

 

Las guías que estoy usando son las que tu mismo has publicado aquí, así como otros (la que más esta), pues el proceso de desinstalación son idénticos (cambiando los elementos a instalar, eso sí). De ahí mi sorpresa cuando me topo con el problema de hacer la desinstalación. Toda la información que he recopilado indica exactamente lo mismo que indicas tu en la guía (independientemente de aquello que se instala como digo). Esta claro que en PowerPC y Leopard los instaladores añaden "algo" que no se menciona en las guías PowerPC.

 

Y por lo que veo, tendré que hacerlo "a las bravas", es decir copia de seguridad de lo que tengo, borrado y reinstalación; pero no quería perder la esperanza. Seguiré investigando.

 

Un saludo y gracias.

Share this post


Link to post
Share on other sites

Tranquilo, no pasa nada. Sencillamente pensé que indicar iBook queda claro que no es Macbook y por lo tanto se presuponía...

 

Las guías que estoy usando son las que tu mismo has publicado aquí, así como otros (la que más esta), pues el proceso de desinstalación son idénticos (cambiando los elementos a instalar, eso sí). De ahí mi sorpresa cuando me topo con el problema de hacer la desinstalación. Toda la información que he recopilado indica exactamente lo mismo que indicas tu en la guía (independientemente de aquello que se instala como digo). Esta claro que en PowerPC y Leopard los instaladores añaden "algo" que no se menciona en las guías PowerPC.

 

Y por lo que veo, tendré que hacerlo "a las bravas", es decir copia de seguridad de lo que tengo, borrado y reinstalación; pero no quería perder la esperanza. Seguiré investigando.

 

Un saludo y gracias.

Ok, aclarado.

 

Aunque los dos procesos de desinstalación son casi iguales te recomiendo que, para tu caso, no uses mi guía. No debería ser yo el que te contestara porque no tengo un PowerPC, pero antes que tengas que volver a instalar Leopard, prueba a hacer lo siguiente:

 

  • No lo aseguro pero al ser arquitecturas distintas es posible que haya archivos que en PowerPC los deje en otros lugares. Busca en carpetas (ocultas y no ocultas) todo rastro de OpenSC y bórralo.
  • Te hablo de una instalación que hice el año pasado con Leopard e Intel. El problema es acertar con la combinación de archivos a instalar. Creo que era sca-0.2.8 y opensc.dnie-1.4.8.1 pero no te lo puedo asegurar. Haz pruebas con sca-0.2.8 y opensc.dnie-1.4.4.4, sca-0.2.3pre2.dmg y opensc.dnie-1.4.8.1,... Cada prueba que hagas tendrás que desinstalar los dos archivos y reiniciar.

Saludos.

Edited by xund

Share this post


Link to post
Share on other sites

Hola gente,

 

Veo mucha letra respecto a este tema del DNI electrónico...

 

Tan complicado es hacer que funcione con Mac? No es tan sencillo como cualquier lector de tarjetas SD o un disco duro externo? :S

 

Como veo que pinta mal... me decantaré por comprar cualquier lector por eBay

 

http://www.ebay.es/itm/LECTOR-DNI-ELECTRoNICO-SIM-Y-TARJETAS-CHIP-/320714913242?pt=LH_DefaultDomain_186&hash=item4aac1935da

 

Y cuando tenga que usarlo trabajaré con la partición de W7 (que no he usado en la vida), sería la primera vez en 7 años con Mac que uso Windows para algo jejeje

 

Saludos !

Share this post


Link to post
Share on other sites

Os pongo este link que aparece en el Pais.

 

Resurrección del DNI

 

y extraigo este parrafo

 

"El Instituto Nacional de las Tecnologías de la Comunicación (Inteco) ha presentado esta semana un "sencillo programa" de instalación en ordenadores para facilitar el uso del carné electrónico."

 

Yo no uso ese DNI entre otras cosas porque tengo todavía en viejo :lol: , no se si habrá versión para Mac.

Share this post


Link to post
Share on other sites

Gracias por la información, voy a ver si encuentro "sencillo programa", pero dudo que sea mejor que lo que hay en el foro.

Share this post


Link to post
Share on other sites

Os pongo este link que aparece en el Pais.

 

Resurrección del DNI

 

y extraigo este parrafo

 

"El Instituto Nacional de las Tecnologías de la Comunicación (Inteco) ha presentado esta semana un "sencillo programa" de instalación en ordenadores para facilitar el uso del carné electrónico."

 

Yo no uso ese DNI entre otras cosas porque tengo todavía en viejo :lol: , no se si habrá versión para Mac.

Nada, sólo Windows y Linux (Ubuntu) :

 

https://zonatic.usatudni.es/aplicaciones/asistente-dnie

Share this post


Link to post
Share on other sites

Hola,

 

Actualizado a Firefox 8 y funciona todo perfecto en Snow Leopard 10.6.8

 

Saludos

Share this post


Link to post
Share on other sites

Hola,

 

Actualizado a Firefox 8 y funciona todo perfecto en Snow Leopard 10.6.8

 

Saludos

Como a Firefox 8 ¿Cuando a salido?

Share this post


Link to post
Share on other sites

Hola,

 

Apple acaba de sacar versión nueva de Java para Snow Leopard y Lion.

 

Los que tengáis Lion, actualizaros a ver si solventa los problemas que os daban algunas webs.

 

Saludos.

Share this post


Link to post
Share on other sites

Hola, despues de la actualizacion a Firefox 8 y la actualizacion de Java de ayer, volvemos al principio, no me deja entrar en ningún sitio, ni vida laboral, puntos, en fin, nada de nada.

 

¿Que os parece, nueva instalación de nuevo, siguiendo la guía.?

Share this post


Link to post
Share on other sites

Hola, despues de la actualizacion a Firefox 8 y la actualizacion de Java de ayer, volvemos al principio, no me deja entrar en ningún sitio, ni vida laboral, puntos, en fin, nada de nada.

 

¿Que os parece, nueva instalación de nuevo, siguiendo la guía.?

Hola Muixarra,

 

¿Cómo?. Ésto no hay quién lo entienda.

 

El hacer un único programa que instale el DNIe en Mac es fácil para un programador pero con cosas como ésta no es viable porque sólo valdría con una versión concreta de OSX, una versión concreta de Firefox, otra de Java y otra de OpenDNie... de locos vamos.

 

No sé que decirte... no tengo Lion pero, antes de saber de quién es la culpa Apple-Mozilla-Oracle, ¿me puedes contestar a una pregunta?:

¿Te ha dejado de funcionar después de actualizar Firefox o Java?.

 

Saludos.

 

P.D.: Yo estoy haciendo pruebas en Snow Leopard y me funciona todo.

Share this post


Link to post
Share on other sites

Yo diría que fue después de actualizar Firefox, pero no estoy seguro.

 

Cuando actualice Java, me dijo que no se podía instalar porque no tenía permisos, después de reiniciar, lo comprobé otra vez y ya estaba la ultima versión de Java instalada, de locos vamos.

 

¿ Que me aconsejas que haga ?

 

 

 

 

 

 

Saludos IPhone4 Tapatalk

Share this post


Link to post
Share on other sites

Yo diría que fue después de actualizar Firefox, pero no estoy seguro.

 

Cuando actualice Java, me dijo que no se podía instalar porque no tenía permisos, después de reiniciar, lo comprobé otra vez y ya estaba la ultima versión de Java instalada, de locos vamos.

 

¿ Que me aconsejas que haga ?

Hola Muixarra,

 

Vamos a intentar acotar el problema. Para ello te diría que desinstalaras Firefox 8 e instalaras desde cero Firefox 7 (vamos, la versión que te funcionaba).

 

Esperemos que sea problema de Firefox porque como sea de Java lo tienes crudo...

 

Saludos.

Share this post


Link to post
Share on other sites

Ostras, pues ahora no se donde buscarlo Firefox 7.

 

En la pagina de la Seguridad Social me da el siguiente error:

 

 

Mensaje de Error

Para acceder a esta página se requiere un certificado de usuario aceptado por la Seguridad Social.

 

 

 

 

 

Me parece, que al final desistiré y solo entrare con Windows, es incomprensible con los adelantos que hay y que no se pueda entrar con OS X y con Windows, si. No lo entiendo.

 

 

 

 

A la tarde, mirare de hacer lo que me dices, pero es que entre tener Firefox 8 o poder entrar con el DNIe, casi me quedo con Firefox 8.

 

 

 

 

Un saludo

 

 

 

Share this post


Link to post
Share on other sites

Ostras, pues ahora no se donde buscarlo Firefox 7.

Mira a ver aquí.

 

 

Me parece, que al final desistiré y solo entrare con Windows, es incomprensible con los adelantos que hay y que no se pueda entrar con OS X y con Windows, si. No lo entiendo.

No hay que generalizar, con OSX se puede sin problemas (SL). Con Lion, visto que mis amigos tienen muchos problemas con software y hardware, no me lo voy a comprar. Esperaré al siguiente sistema operativo (si lo hay). Con SL a mi me funciona todo mi software y hardware (a nivel profesional) y me va fluido y estable. Y también el DNIe.

 

El problema de todo ésto no es del DNIe, ni de OpenDNie, ni de Oracle, ni de Mozilla,... Apple está últimamente haciendo las cosas cada vez peor. Está claro que con lo que gana dinero es con los iPhone/iPad/iPod, pero debería tener más en cuenta la división de informática.

 

 

A la tarde, mirare de hacer lo que me dices, pero es que entre tener Firefox 8 o poder entrar con el DNIe, casi me quedo con Firefox 8.

Lo de Mozilla tiene "bemoles" también, Yo lo vengo usando desde que se creó en Linux pero pasar en unos meses de la versión 4 a la 8... No sé si pensar que son muy buenos o muy malos.

 

Saludos.

Edited by xund

Share this post


Link to post
Share on other sites

De momento, no hay suerte, instale Firefox 7, desde el enlace que pusiste y si quiero entrar a mirar los puntos, me da el siguiente error en la pagina que se abre:

 

Forbidden

You don't have permission to access /WEB_COPACI/certificado/irAntecedentes.faces on this server.

 

Si quiero ver el informe, me sale este otro error:

 

 

Mensaje de Error

La página a la que intenta acceder no se encuentra en nuestro servidor.

 

 

 

Así que voy a mirar de empezar otra vez, con el tutorial, así podre descartar el tema Java.

 

Un saludo

Share this post


Link to post
Share on other sites

Pues que no me deja instalar los drivers del lector

 

ifdokccid_mac_10.6_i386-3.0.2 no puede instalarse en este ordenador.

Y los drivers para 10.7, en la pagina del lector, no hay, acabo de mandarles un correo, a ver que me dicen, pero lo veo raro, con el tiempo que hace que funciona Lion.

 

Lo raro, es que me funcionaba, a ver si es porque hice una instalación limpia de Lion.

 

Voy a dejarlo de momento, a ver si me contestan, lo usare con Windows.

 

Y yo que creía que había drivers para todos los Mac. :wub:

Share this post


Link to post
Share on other sites

Pues que no me deja instalar los drivers del lector

 

ifdokccid_mac_10.6_i386-3.0.2 no puede instalarse en este ordenador.

Y los drivers para 10.7, en la pagina del lector, no hay, acabo de mandarles un correo, a ver que me dicen, pero lo veo raro, con el tiempo que hace que funciona Lion.

Lo mismo hice yo con mi lector, todavía no me han contestado...

 

Lo raro, es que me funcionaba, a ver si es porque hice una instalación limpia de Lion.

Lion es un sistema operativo diferente a Snow Leopard y lo que funciona en SL no tiene porqué funcionar en Lion. Si el lector y el DNIe funciona en Lion, previa actualización de SL, es porque una actualización usa librerías del sistema que actualiza.

 

Todavía OpenDNIe no ha sacado una versión para Lion.

 

Y yo que creía que había drivers para todos los Mac.

Éso es lo que piensa mucha gente. Está acostumbrada a que cualquier dispositivo Apple sea muy sencillo de usar y actualizar, es cierto. Pero ésto sucede si Apple y los fabricantes de hardware hacen bien su trabajo, si no, pasa lo que pasa.

 

De momento, si quieres usar el DNIe en OSX 64bits de manera estable: SNOW LEOPARD.

 

Saludos.

Edited by xund

Share this post


Link to post
Share on other sites

Por lo tanto el fallo es que no reconoce el lector.

 

Pues tendré que arreglármelas con Windows7, por que estos de CHERRY, no creo que contesten.

 

Un saludo

Share this post


Link to post
Share on other sites

Por lo tanto el fallo es que no reconoce el lector.

 

Pues tendré que arreglármelas con Windows7, por que estos de CHERRY, no creo que contesten.

 

Un saludo

Para el tema del lector una solución es comprar uno que lo reconozca Lion sin necesidad de instalar drivers. Éste te podría servir: C3PO LTC31

 

Otra cosa es que consigas hacer funcionar el DNIe en Lion. Mi guía no te funcionará, me temo que tendrás que emplear el truco de Firefox en 32 bits.

 

Saludos.

Share this post


Link to post
Share on other sites

Hola,

 

Nueva actualización de Firefox 8.0.1

 

Saludos.

 

P.D.: Voy a dejar de poner las actualizaciones a Firefox porque a este ritmo van a sacar una a la semana.

Share this post


Link to post
Share on other sites

Hola,

 

Nueva actualización de Firefox 8.0.1

 

Saludos.

 

P.D.: Voy a dejar de poner las actualizaciones a Firefox porque a este ritmo van a sacar una a la semana.

Pues no me sale esta a mi??

 

En cuanto al lector le pregunte al fabricante o representante de aquí y me dijo que lo pondría en conocimiento de las "altas jerarquías", me esperare a ver si sacan los drivers y si no, lo usare solo con Windows.

 

Muchas gracias.

Share this post


Link to post
Share on other sites

Hola a todos,

 

Solo deciros que yo conseguí hacer funcionar el DNIe, pero para que siga medianamente activo, tengo instalada una version de Firefox 3 para usarlo solo con el DNIe. Así lo he conseguido mantener mas o menos.

 

Por ejemplo, me sigue siendo imposible inscribirme en la página de la DGT, no se que personaje lleva esa página, pero menuda M.

 

Por otro lado, si veo los puntos y conseguí hacer cosas en la pagina del Tesoro, vida laboral etc.

 

Considerar una opción mantener otro Firefox, y si alguien logra lo de la DGT....

Share this post


Link to post
Share on other sites

Solo deciros que yo conseguí hacer funcionar el DNIe, pero para que siga medianamente activo, tengo instalada una version de Firefox 3 para usarlo solo con el DNIe. Así lo he conseguido mantener mas o menos.

Hola lisema,

 

Si lees el hilo (no hace falta que te lo leas desde el principio), verás que aquí hace tiempo que nos funciona el DNIe. En un principio con Leopard y más tarde con Snow Leopard en 64 bits y con cualquier versión de Firefox, incluida la última. Si has leído los últimos post verás que los problemas vienen con Lion:

 

  • Actualizando Lion desde Snow Leopard: Funciona pero da problemas con algunas webs por la versión de JAVA.
  • Instalando Lion desde cero: Aquí si no tienes drivers para el lector ya no puedes hacer nada. Y los que lo tienen han sufrido algunos problemas porque no hay versión de OpenDnie para Lion.

No dices que versión de OSX tienes, si tienes Snow Leopard descárgate mi guía y verás cómo puedes hacer trámites como la declaración de la renta, declaración del IVA, altas y bajas en la SS, vida laboral, puntos del carnet de conducir, certificado de nacimiento,... y trámites varios con las entidades bancarias. Sin ningún problema y desde hace meses.

 

Resumiendo: DNIe en Leopard/Snow Leopard funciona sin problemas en 32/64bits. Lion depende...

 

Saludos.

Share this post


Link to post
Share on other sites

Buenas Compis,

 

A mi este tutorial me ha funcionado la mar de bien con Lion, firefox y un LTC31 USB

 

Espero os sirva de ayuda

 

Saludos!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.