Jump to content
Lillibit

[Temas unidos] DNI electrónico en OS X

Recommended Posts

Buenas,

 

Después de realizar durante meses trámites con mi DNIe sin ningún tipo de problema hoy me he encontrado con un error al intentar conectar con la página redabogacia.org

 

 

Renegotiation is not allowed on this SSL socket.

 

(Error code: ssl_error_renegotiation_not_allowed)

 

Creo que este tipo de error era solucionable, ¿cierto xund?

 

Mil gracias de nuevo.

Share this post


Link to post
Share on other sites

Hola a todos. Llevo fuera de esto mucho tiempo y ahora que necesito usar mi DNIe no me funciona, Firefox ni siquiera lo lee.

 

Decir que desde la última vez que lo usé he acualizado a Lion.

 

¿Alguién me podría pasar el enlace a la última versión del tutorial para ver si consigo hacerlo funcionar?.

 

Gracias y saludos.

Share this post


Link to post
Share on other sites

solo me ha funcionado en leopard y en algunas paginas de la seguridad social o empleo y hacienda en otros tramites la pagina te dice que y cual gestión se puede hacer.depende del servidor y pagina

vale lo primero son los certificados raíz se instalan en acceso a llaveros aplicaciones utilidades esto para safari

y después el controlador para el lector usb que tengamos en mi caso bit4id mini lector

el certificado raiz de la pasma es el importante FNMTClase2CA.cer

por lo demás reinicias metes el dni y al entrar en una pagina que te pida el dni elec para realizar la gestión este se activara.

Share this post


Link to post
Share on other sites

¿Alguien me podría pasar el enlace a la última versión del manual para Lion?.

 

Gracias.

Share this post


Link to post
Share on other sites

¿Alguien me podría pasar el enlace a la última versión del manual para Lion?.

Hola,

 

No hay enlace al manual para Lion porque nunca hice el manual para Lion, sólo para Snow Leopard. Para usar el DNIe con Lion debes usar el truco de los 32bits, como bien puso Muixarra.

 

Después de trastear con Lion unas semanas he decidido volver a SL. Me esperaré a que saquen Mountain Lion.

 

Saludos.

Share this post


Link to post
Share on other sites

¿Alguien me podría pasar el enlace a la última versión del manual para Lion?.

Hola,

 

No hay enlace al manual para Lion porque nunca hice el manual para Lion, sólo para Snow Leopard. Para usar el DNIe con Lion debes usar el truco de los 32bits, como bien puso Muixarra.

 

Después de trastear con Lion unas semanas he decidido volver a SL. Me esperaré a que saquen Mountain Lion.

 

Saludos.

 

Gracias xund.

Share this post


Link to post
Share on other sites

¿Y el enlace a la guía de snow Leopard?

 

Encontré uno pero estaba en megaupload. ¿Puedes volver a colgarlo? Muchas gracias

Share this post


Link to post
Share on other sites

¿Y el enlace a la guía de snow Leopard?

 

Encontré uno pero estaba en megaupload. ¿Puedes volver a colgarlo? Muchas gracias

Hola megustamac,

 

Perdona por el retraso pero he estado muy liado con trabajo.

 

Te la puedes bajar de este link.

 

Saludos.

Share this post


Link to post
Share on other sites

Que tal os esta funcionando ahora con Firefox 12, hace días que no lo pruebo.

 

 

 

Saludos iPad2 Tapatalk

Share this post


Link to post
Share on other sites

Que tal os esta funcionando ahora con Firefox 12, hace días que no lo pruebo.

A mi me funciona sin problemas, de hecho he probado con versiones beta 15 y también Ok.

 

Los problemas los tengo con Java...

 

Saludos.

Share this post


Link to post
Share on other sites

Pues ahora, no se desde cuando, no puedo (no la encuentro) entrar en la página de mirar la Vida Laboral con el DNIe, siempre me lleva a la página normal para solicitarla por correo. Me podría pasar alguien el enlace??

 

 

Sent from my iPad using Tapatalk HD

Share this post


Link to post
Share on other sites

Que raro, hoy me puse para ver si volvía a instalarlo todo y resulta que ya vuelve a funcionar todo (excepto el Santander).

 

A ver cuanto dura, por que no entiendo ni veo donde estaba el fallo.

 

Un saludo

 

 

Saludos iPad2 Tapatalk

Share this post


Link to post
Share on other sites

Que tal os esta funcionando ahora con Firefox 12, hace días que no lo pruebo.

A mi me funciona sin problemas, de hecho he probado con versiones beta 15 y también Ok.

 

Los problemas los tengo con Java...

 

Saludos.

 

Hola Xund, has conseguido "lidiar" con java y que te funcione...

a mi me da un error en el applet de firma de java y no encuentro solución en os x 10.7.4 y con las ultimas actualizaciones de java...

voy a tener que reinstar Paralells y Guindows... :angry:

 

El error que me da por si alguien lo ha sufrido es:

 

No se puede verificar el publicador mediante una fuente de confianza. El codigo se tratará como si no estuviera firmado.

"java.security.cert.CertificateException: Unable to evaluate certificates: 80"

 

Gracias de antemano y un saludo.

Share this post


Link to post
Share on other sites

Has activado el applet de java en las preferencias de java? unsure.gif

 

Creo recordar que con la última actualización, quedaba desactivado por defecto....

 

Saludos :)

Share this post


Link to post
Share on other sites

Si, Pepeiko, los active manualmente, me pasa lo mismo con un iMac de 2006 y con un mbp de 2009.

 

En el iMac seguí los pasos de la guia de este hilo y en el mbp los pasos del fabricante del lector, un c3po ltc31, en ambos casos el test de dnielectronico es satisfactorio, pero al intentar firmar una denuncia ante la setsi, se da el problema.

Creo que es algun problema del certificado de la setsi con el almacen de java, intento añadirlo, pero sigue el problema...

 

lo dicho a desempolvar mi viejo Paralells 5.... :(

Share this post


Link to post
Share on other sites

Hola Xund, has conseguido "lidiar" con java y que te funcione...

a mi me da un error en el applet de firma de java y no encuentro solución en os x 10.7.4 y con las ultimas actualizaciones de java...

Hola Benymac,

 

A mi el DNIe me funciona sin problemas. Para todas las gestiones que hago con la Administración, bancos y webs varias sólo tengo un problema con un banco y es debido a un applet Java de programación de la web del banco. Es un mal menor porque puedo acceder perfectamente de la manera tradicional: login y psswd.

 

Yo uso la última versión de Java para OSX, la Update 8. El problema es que las versiones de Java para Mac las supervisa/destroza directamente Apple y pasa lo que pasa...

 

Saludos.

 

P.D.: Como ya he dicho muchas veces yo no uso Lion así que no te puedo decir los errores de Java que son diferentes a los de SL, otra cagada más de Apple.

Share this post


Link to post
Share on other sites

Hola xund, estoy desesperado de intentar hacer funcionar mi DNI y no lo consigo. He seguido todos los pasos de la guía y me pasa siempre lo mismo. Ya llevo unos cuantos intentos. Cada vez que falla desinstalo el opensc ( no desinstalo el lector porque es plug&play y no usa driver ) y hasta desinstalo firefox también por si acaso, y cada vez llego al mismo problema sin hallar solución.

 

A ver si me puedes echar una mano. Voy por partes.

 

Tengo un macbook pro intel con sistema snow leopard 10.6.8 y uso el lector LTC31.

 

Empiezo:

 

Instalo firefox, la última versión que dejo en 64 bits. Lo configuro como navegador por omisión.

Instalo la última versión de OpenSC-DNIe-10.6-r412.49 de jonsito.

Abro el terminal y compruebo que el lector funciona correctamente, y no da warnings ni errores.

Instalo el módulo criptográfco.

 

En la Instalación de los certifcados es donde me sucede algo que no entiendo.

Cuando accedo a la página http://www.dnie.es/certs/ACRaiz.crt directamente se me abre una ventana en la página para validar tres opciones que según la guía (aunque no es exactamente igual a la de la guía) debería salirme después de poner la contraseña del DNI (que en ningún momento me pide) e introducir el archivo ACRaiz.crt . No se si aquí estoy confundido y por si acaso os pongo una foto de la ventana que digo.

 

capturadepantalla201206p.png

 

En dicha ventana marco las tres opciones, clico en OK, se cierra la ventana y se queda la página en blanco. Y no puedo importar el archivo ACRaiz.crt porque o no lo tengo o no se donde se ha descargado porque tras hacer una búsqueda en el finder no me aparece dicho certificado.

 

Como está explicado en la guia debería salirme algo parecido a esto...

 

capturadepantalla201206w.png

 

Y a mi me sale esto...

 

capturadepantalla201206l.png

 

¿Estoy haciendo algo mal? O ¿por que no me funciona? ¿Que puedo hacer? Gracias.

Edited by manolo gonzalez gonzalez

Share this post


Link to post
Share on other sites

Hola xund, estoy desesperado de intentar hacer funcionar mi DNI y no lo consigo. He seguido todos los pasos de la guía y me pasa siempre lo mismo. Ya llevo unos cuantos intentos. Cada vez que falla desinstalo el opensc ( no desinstalo el lector porque es plug&play y no usa driver ) y hasta desinstalo firefox también por si acaso, y cada vez llego al mismo problema sin hallar solución.

 

¿Estoy haciendo algo mal? O ¿por que no me funciona? ¿Que puedo hacer? Gracias.

Hola manolo gonzalez gonzalez,

 

Todo indica a que tienes un problema con tu DNIe físico. Yo que tú me pasaría por una comisaría y comprobaría en un PAD (Punto de Actualización del DNIe) que tuvieras todo correcto: Si no te han caducado los certificados y/o tienes la contraseña bloqueada.

 

Saludos.

Share this post


Link to post
Share on other sites

Hola, ¿que tal os funciona con Firefox 14? Con la del Banco Santander, continuo igual, no hay forma de entrar.

 

Un saludo

Share this post


Link to post
Share on other sites

Hola, ¿que tal os funciona con Firefox 14? Con la del Banco Santander, continuo igual, no hay forma de entrar.

Hola Muixarra,

 

Yo tengo Snow Leopard con JAVA Update 9, sin problemas con Firefox 14 y el Santander. Eso sí, hay que activar la casilla de permitir applets...

 

Saludos.

Share this post


Link to post
Share on other sites

Hola, ¿que tal os funciona con Firefox 14? Con la del Banco Santander, continuo igual, no hay forma de entrar.

Hola Muixarra,

 

Yo tengo Snow Leopard con JAVA Update 9, sin problemas con Firefox 14 y el Santander. Eso sí, hay que activar la casilla de permitir applets...

 

Saludos.

 

Uff, yo ya estoy probando el Mountain Lion!!

 

Preferencias de Java me dice que tengo Nombre JAVA SE 6 Versión 1.6.0_b03-424 para 64 y 32 bits

 

¿ Como era lo de permitir applets ?

Share this post


Link to post
Share on other sites

Uff, yo ya estoy probando el Mountain Lion!!

 

Preferencias de Java me dice que tengo Nombre JAVA SE 6 Versión 1.6.0_b03-424 para 64 y 32 bits

 

¿ Como era lo de permitir applets ?

Hola Muixarra,

 

Es la misma versión que tengo yo. En Aplicaciones > Utilidades > Preferencias de Java > General a mi me aparece la casilla a activar.

 

Saludos.

Share this post


Link to post
Share on other sites

No hay nada a hacer, imposible de abrir el Santander, todo lo demás funciona bien, en fin, con 1Password, también se abre.

Share this post


Link to post
Share on other sites

 

Hola Xund, has conseguido "lidiar" con java y que te funcione...

a mi me da un error en el applet de firma de java y no encuentro solución en os x 10.7.4 y con las ultimas actualizaciones de java...

voy a tener que reinstar Paralells y Guindows... :angry:

 

El error que me da por si alguien lo ha sufrido es:

 

No se puede verificar el publicador mediante una fuente de confianza. El codigo se tratará como si no estuviera firmado.

"java.security.cert.CertificateException: Unable to evaluate certificates: 80"

 

Gracias de antemano y un saludo.

 

Ese error se debe a que no tienes el certificado raíz de la CA que ha emitido el certificado del servidor o de tu propio certificado en el almacén de certificados de Java. (Que es diferente del de Mac OS y del de Firefox).

 

Para añadir del certificado tienes que ejecutar el siguiente comando en el Terminal:

sudo keytool -keystore $JAVA_HOME/lib/security/cacerts -import -file CertificadoRaiz.cer

 

Tener en cuenta que aunque salveis este punto, luego el applet tiene que estar preparado para poder acceder a los certificados en el soporte específico de la tarjeta o en el almacén de Mac OS X, cosa altamente improbable.

 

Un saludo.

Edited by Stipey

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.