Jump to content

[Temas unidos] DNI electrónico en OS X


Recommended Posts

Hola chimai.

 

El lector C3PO LTC31 me ha funcionado correctamente hasta el día de hoy en cualquier versión de leopard (empecé por la 2 con una instalación limpia, y ahora tengo la última, o sea la 6).

 

Probablemente, aunque no estoy seguro, me parece que debes tener un lector defectuoso de fábrica, pues no es normal que no te aparezca en el perfil del sistema. Debería aparecer después de conectarlo. Prueba encender el ordenador con el lector previamente conectado, a ver si así Leopard lo reconoce.

 

Te recomiendo que leas detenidamente mi anterior post en este mismo hilo, ya que los problemas que ahí se mencionan nada tienen que ver con el reconocimiento de los dispositivos lectores (como es tu caso), sino en el propio funcionamiento de los mismos (según menciona el compañero usuario jcdr ) por culpa de los drivers defectuosos de leopard.

 

De todos modos, por si te sirve de algo, te envío por privado la captura de pantalla de perfil del sistema.

 

Saludos.

Link to post
Share on other sites
  • Replies 740
  • Created
  • Last Reply

Top Posters In This Topic

  • 2 weeks later...

Al final he cambiado el lector CTPO LTC31 que me daba problemas y con el nuevo he podido instalar el módulo PKCS#11 y el certificado raiz que aparece en la página de instalación, poniendo el PIN que me dieron.

 

El caso es que voy a la página de comprobación de certificados y me da error ¿alguien sabe cuál puede ser mi problema? ya veo la luz pero todavía me falta un poco ... :lol:

 

Por cierto, a algunos de los que no les funciona la instalación del módulo PKCS#11 les recomiendo que previamente se aseguren al 100% de que el lector funciona correctamente ya que el mío funcionaba de forma intermitente, y cuando no funcionaba siempre estaban las dos luces encendidas de forma permanente. Puede que sea una chorrada pero si puede ayudar a alguien ...

Link to post
Share on other sites
Pues algo en Firefox no debe funcionar. No es normal que no podais instalar el módulo, y no se se me ocurren más cosas. Lo que si sé es que a mi se me instaló a la primera intentona sin problemas. Además, me sale a la izquierda del panel de dispositivos el nombre que le dí: Safesign Identity Client, y en el panel de la derecha ese mismo nombre y la ruta que le di, que es precisamente el nombre del archivo libaetpkss.dylib.

El caso es que ese archivo lo crea el propio firefox como ruta (path), y yo tampoco lo encuentro con el Spotligh, pero me funciona. De hecho ya he podido presentar a Hacienda con el certificado la declaracion trimestral.

 

Saludos

 

Edito: Probad a ver si se carga el módulo teniendo conectado el lector, y si no pues probar con la tarjeta introcucida.

 

Probado con lector conectado con y sin la tarjeta introducida y nada, no se puede instalar el módulo de ninguna de las maneras.

Desde el 19 de julio que no probaba con el DNI, y ahora al leer el tutorial y volver a motivarme. He vuelto a probar y ... CONSEGUIDO!!!!.

 

Primero conecté el lector C3PO, luego introduje el DNIe. Y con todo lo que había intentado hasta ahora, sin tocar nada de como lo dejé el 19 de julio, he abierto el archivo instala_modulo.htm del directorio OpenSC/sare/web con firefox última versión estable y salió el mensaje de Módulo instalado correctamente. NO ME LO PODÍA CREER.

 

Tras mi alegría, fuí a comprobar el DNI en la web oficial www.dnielectronico.es y tanto la autenticacón como la firma funcionan perfectamente.

 

Errores que creo que cometía, por si sirve a alguien.

 

Cuando probé en otras ocasiones, es posible que la conexión usb no hiciera buen contacto. Cuando hoy lo he probado, al enchufar el C3PO, primero se encendieron las luces y al momento se apagaron, cosa que me extrañó y al mover el usb se volvieron a encender. Pienso que antes no me hacía conexión y por eso no funcionaba. Asegurarse que la conexión al usb está correctamente operativa Si no funciona, probad otro puerto USB.

 

Al firmar cualquier texto con el DNIe sale una ventana que te solicita con qué certificado quieres firmar, y abajo del todo pide la contraseña maestra. Al principio puse la que tengo definida en las preferencias de Firefox, NO ES ESA, la que hay poner es la del DNIe. Así firma correctamente.

 

Estos son los dos errores que yo he cometido. Y es que no se puede dar nada por supuesto.

 

Gracias a todos por compartir vuestros comentarios y ayudarnos a conseguir esta difícil tarea de hacer funcionar el DNIe en nuestros Macs. Y suerte y paciencia a los que aún no lo habéis conseguido.

Link to post
Share on other sites

Millones de gracias por el tutorial. Por fin, después de haber dejado pasar 8 meses desde mi último intento (el 19 de julio de 2008) Por fin he conseguido que se instale el puñetero MÓDULO!!!!!!

 

Ahora al leer el tutorial y volver a motivarme. He vuelto a probar y ... CONSEGUIDO!!!!.

 

Sin tocar nada de como lo dejé el 19 de julio, lo último que hice entonces, a parte de sudar la gota gorda por el calor que hacía, fue seguir los pasos que comenta Fai en su mensaje un poco más arriba en el hilo fusionado DNI electrónico en Tiger y Leopard.

Pasos que he realizado:

1º Conectar el lector C3PO al puerto USB del Mac (PowerBook G4 12" con Leopard y Firefox)

2º Introducir el DNIe.

3º Comprobar la conexión USB, pues de repente se apagaron las luces del lector y al mover el conector USB se volvieron al encender. OJO aquí, hay que asegurarse que la conexión al USB está operativa y correctamente establecida.

4º Abrir el archivo instala_modulo.htm del directorio OpenSC/sare/web con firefox y ... NO ME LO PODÍA CREER!!!!!! Por fin salió el mensaje de: Módulo instalado correctamente.

 

Tras mi alegría, fuí a comprobar el DNI en la web oficial www.dnielectronico.es y tanto la autenticacón como la firma funcionan perfectamente.

 

Errores que creo que cometía, por si sirve a alguien.

 

Cuando probé en otras ocasiones, es posible que la conexión usb no hiciera buen contacto. Cuando hoy lo he probado, al enchufar el C3PO, primero se encendieron las luces y al momento se apagaron, cosa que me extrañó y al mover el usb se volvieron a encender. Pienso que antes no me hacía conexión y por eso no funcionaba. Asegurarse que la conexión al usb está correctamente operativa Si no funciona, probad otro puerto USB.

 

Al firmar cualquier texto con el DNIe sale una ventana que te solicita con qué certificado quieres firmar, y abajo del todo pide la contraseña maestra. Al principio puse la que tengo definida en las preferencias de Firefox, NO ES ESA, la que hay poner es la del DNIe. Así firma correctamente.

 

Estos son los dos errores que yo he cometido. Y es que no se puede dar nada por supuesto.

 

Gracias a todos por compartir vuestros comentarios y ayudarnos a conseguir esta difícil tarea de hacer funcionar el DNIe en nuestros Macs. Y suerte y paciencia a los que aún no lo habéis conseguido.

Link to post
Share on other sites
Al final he cambiado el lector CTPO LTC31 que me daba problemas y con el nuevo he podido instalar el módulo PKCS#11 y el certificado raiz que aparece en la página de instalación, poniendo el PIN que me dieron.

 

El caso es que voy a la página de comprobación de certificados y me da error ¿alguien sabe cuál puede ser mi problema? ya veo la luz pero todavía me falta un poco ... :lol:

 

Por cierto, a algunos de los que no les funciona la instalación del módulo PKCS#11 les recomiendo que previamente se aseguren al 100% de que el lector funciona correctamente ya que el mío funcionaba de forma intermitente, y cuando no funcionaba siempre estaban las dos luces encendidas de forma permanente. Puede que sea una chorrada pero si puede ayudar a alguien ...

Te adjunto un fragmento del tutorial de Rafa Lopez al llegar a este paso:

 

8. Por fin hemos terminado todo, pero necesitamos probar que nos ha ido bien. Para ello entraremos en la página de comprobación que proporciona la Fábrica Nacional de Moneda y Timbre. La primera vez posiblemente Firefox te pedirá que aceptes la excepción para poder acceder. Si todo ha ido bien aparecerá un cuadro de diálogo como el de la siguiente imagen, en el que se selecciona qué certificado queremos usar. Recuerda que el DNIE proporciona dos. En esta ocasión usaremos el de autenticación, porque lo que queremos es identificarnos. Lo preguntará dos veces, no pienses que te has equivocado.

 

Yo también tuve problemas en este paso y es que "lo preguntará dos veces" creo que era respecto a aceptar la excepción.

 

Saludos.

Link to post
Share on other sites

A mi me funciona todo correctamente hasta que me conecto para autentificar el DNI y siempre me de le mismo error de autentificación SSL:

 

El otro extremo de la conexión SSL no puede verificar su certificado.

(Código de error: ssl_error_bad_cert_alert)

 

Lo he probado con dos lectores diferentes y en dos ordenadores diferentes.

 

Uno de ellos con una instalación limpia de Leopard.

 

No entiendo nada y no he encontrado información del mencionado error :-(

Link to post
Share on other sites

Para mantener la coherencia y centralizar las consultas e información se han unido los dos temas existentes sobre el DNI electrónico que estaban en Soporte OS X y Actualidad ;)

Link to post
Share on other sites
  • 1 month later...

hola chicos:

 

estoy desperado, no soy capaz de instalar el módulo de seguridad PKCS#11,me pregunta si quiero cargar el módulo y... me dice : ALERTA:No es posible añadir el módulo... he probado con el lector conectado con y sin DNI pero no puedo avanzar de ahí... imposible para un profano como yo...en fin

 

S.O.S. S.O.S. S.O.S. S.O.S.

 

 

:unsure:

Link to post
Share on other sites

Hola a todos,

una pregunta a los que han conseguido instalar el módulo de seguridad PKCS#11. ¿el porocesador es un Intel Core? Yo tengo un Mac PowerPc G5 con 10.5.6 y Firefox última versión.

 

A mí me sale el mensaje de que no puede cargar el módulo.

 

Gracias.

Edited by prethorian
Link to post
Share on other sites

Hola queridos amigos... Que rrollo de verdad con esta instalacion!! la verdad es que estoy algo desesperado, yo no me entero de como hacerlo, el caso es que segui el tutorial y cual fue mi sorpresa que al instalar ellector de tarjeta de la junta de andalucia(un omnikey 3121 ccid) todas la luces se emperazon ailuminar , leia datos del DNIe salio todo perfecto hasta instalo correctamente el famoso archivo opensc-pkcs11.so que tantos problemas he leido que da... me salio perfecto la pagina dando el ok de que habia instalado dicho modulo, en fin todo sin problemas hasta que intento verificar si todo habia ido bien en la pagina av-dni, me senti feliz al ver que me salia el cuadro para poner la contraseña para acceder y............................ puapuapuapuaaaaaaaa nada me lo pide repeticamente y no paso de ahi....(y estoy seguro de saber la contraseña)

 

asi que decidi volverlo a instalar todo.... y peor aun!!!! ya ni reconoce el lector...

alguien podria hecarme una Mano???

como se borra todo lo que he instalado???

me refiero a los drivers del lector,los archivos del dnie el modulo de criptografia(por mucho que lo intento no me deja desintalarlo,incluso con el uninstall.... tambien desinstale todos los certificados que pusieran FNMT y los de la policia..

Necesito un cableeee lo habia dicho yaaaaaa?????

Gracias y perdonar por mi incompetencia e ignorancia

Un Saludo

Link to post
Share on other sites
  • 3 weeks later...

Hola a todos

 

Tengo el lector C3PO LTC31 y ya estoy desesperado. Intento seguir todos los pasos pero cuando instalo el CCID patch me aparece un error y no me deja continuar. ¿Puede ser que sea por tener el 10.5.7? No entiendo como Apple no simplifica las cosas ni como su navegador (Safari) no permite los certificados digitales. Tanto despotricar de Windows y luego resulta que o al menos mantengo un equipo windows en casa o la mitad de las cosas oficiales no puedo realizarlas desde mis macs.

 

Un saludo a todos y gracias por la ayuda con el CCID

Link to post
Share on other sites

Pues yo tengo el mismo lector, MacOSX 10.5.7 y no tengo ningún problema... revisa bien el tutorial que es muy claro y preciso en cada detalle. No se si la culpa es de Apple o de la Autoridad certificadora al crear el certificado, pero Safari si admite certificados digitales, de hecho los admite el sistema y los usa Mail, Safari, etc... los tienes en "Acceso a Llaveros". Desconozco si este de la Dirección General de la Policía se puede instalar ahí (no lo he probado, es cosa de mirarlo...)

Link to post
Share on other sites

Hola a tod@s.

 

Siguiendo el tutorial de Rafa López, he instalado los drivers del DNIe y el módulo PK11 en Firefox 3.0.10 (con el lector C3PO LTC31).

 

Actualmente tengo dos tarjetas que incorporan certificados: el DNIe y otro llamado ACA. He comprobado que los dos funcionan perfectamente, pero hay una cuestión que no termino de entender:

 

Cuando introduzco en el lector la tarjeta DNIe, me aparece en la utilidad llaveros el llavero "DNI electrónico" con el icono de un candado cerrado.

 

Se supone que clicando en el candado, debería aparecer los dos certificados que incorpora el DNIe, pero no es así. No me sale nada, como si estuviera vacío (aunque sé que están, pero lo los muestra).

 

¿Os ocurre lo mismo a vosotros? ¿Os muestra lla utilidad llaveros los certificados del DNIe?

 

La cuestión es que cuando introduzco la otra tarjea ACA, en la utilidad llaveros me aparece el icono de un candado de "ACA", pero si le clico, sí que me aparece mi certificado.

 

A los que también os funcione el DNIe, ¿podéis comprobarlo?

 

Saludos

Link to post
Share on other sites

Buf...

 

Llevo un par de semanas con el tema del DNIe y entre las 4 pinceladas de la web oficial y todo lo que habeis comentado en este hilo finalmente he podido usar el DNIe en Firefox y Thunderbird.

 

El problema es que me ocurre lo mismo que a Fai, cuando intento usar las llaves de certificados en el OS X me muestar la tarjeta vacía ponga o no la contraseña correctamente. Además, no se si será una consecuencia de ello o alo que hacemos mal, pero los dos certificados raiz del DNIe me aparecen con una cruz blanca sobre una redonda azul en vez de aparecer como validados.

 

 

Por favor, si a alguien le ha pasado algo parecido, yo ya no se qué probar!

 

Gracias!

Link to post
Share on other sites

Hola a todos.

 

Me pasa un problema "curioso". Sigo las instrucciones de la Guía de Rafa López, pues tengo el mismo lector y sigo los mismos pasos, pero cuando llego al último paso, no hay manera que acepte la contraseña. Y es curioso, porque la contraseña es correcta, ya que cuando intento acceder a los certificados me la pide y si introduzco otra palabra no me deja.

 

¿Alguna idea?

 

Un saludo y gracias.

Link to post
Share on other sites
Hola a todos.

 

Me pasa un problema "curioso". Sigo las instrucciones de la Guía de Rafa López, pues tengo el mismo lector y sigo los mismos pasos, pero cuando llego al último paso, no hay manera que acepte la contraseña. Y es curioso, porque la contraseña es correcta, ya que cuando intento acceder a los certificados me la pide y si introduzco otra palabra no me deja.

 

¿Alguna idea?

 

Un saludo y gracias.

 

Hay que fijarse en qué certificado está pidiendo que uses, normalmente pide el de identificación y no el de certificación o firma. Aunque es el mismo hay que usar el que pide.

También puede ser que hayas introducido más de 3 veces una clave errónea y se haya bloqueado. Vete a una comisaría y en las máquinas que tienen, cambia la contraseña (te pide la huella digital) e inténtalo de nuevo. Ya os digo que a mi me funciona sin problemas...

Link to post
Share on other sites

No entiendo bien el primer comentario... si me pide la contraseña maestra, o sea, el PIN debo introducir el que he establecido como contraseña. Y puedo asegurarte que es el correcto.

 

El problema es que me pide la contraseña antes de mostrarme la página de la Fábrica Nacional de Moneda y Timbre y por lo tanto, no puede seleccionar el tipo de certificado.

 

¿Cómo es posible? Además, yo no he introducido el DNI hasta ese paso, ya que en ningún momento de la guia se me dice que lo conecte, aunque empiezo a pensar que debería haberlo hecho en el paso 2.

 

¿Alguna idea?

 

Gracias y un saludo.

Link to post
Share on other sites
No entiendo bien el primer comentario... si me pide la contraseña maestra, o sea, el PIN debo introducir el que he establecido como contraseña. Y puedo asegurarte que es el correcto.

 

El problema es que me pide la contraseña antes de mostrarme la página de la Fábrica Nacional de Moneda y Timbre y por lo tanto, no puede seleccionar el tipo de certificado.

 

¿Cómo es posible? Además, yo no he introducido el DNI hasta ese paso, ya que en ningún momento de la guia se me dice que lo conecte, aunque empiezo a pensar que debería haberlo hecho en el paso 2.

 

¿Alguna idea?

 

Gracias y un saludo.

 

Hola Pau (supongo que paisano de la vila)

 

Yo haría una nueva instalación partiendo desde cero siguiendo escrupulosamente el manual de Rafa.

 

Primero lo desinstalas todo: Ves a terminal y ejecuta:

 

sudo /library/OpenSC/bin/opensc-unistall

 

Y luego vuelve a instalar según el manual.

 

Saludos

Link to post
Share on other sites

Hola Fai

 

Nop soy de Alicante capital, pero casi ;)

 

A ver, no puedo ejecutar el comando que me has dejado en el terminal (me pide la contraseña, pero luego no me deja escribirla).

 

Pero independientemente de todo, he seguido escrupulosamente el manuel de Rafa, con copia en papel y todo, y sigo sin entender donde está el "fallo". Creo, como digo en el mensaje anterior, que en el punto 2 no solo se debe conectar el lector sino también introducir el DNI electrónico..

 

Bueno, a ver si consigo desinstalarlo todo y volver a empezar :D

 

Un saludo.

Link to post
Share on other sites
Hola Fai

 

Nop soy de Alicante capital, pero casi ;)

 

A ver, no puedo ejecutar el comando que me has dejado en el terminal (me pide la contraseña, pero luego no me deja escribirla).

 

Pero independientemente de todo, he seguido escrupulosamente el manuel de Rafa, con copia en papel y todo, y sigo sin entender donde está el "fallo". Creo, como digo en el mensaje anterior, que en el punto 2 no solo se debe conectar el lector sino también introducir el DNI electrónico..

 

Bueno, a ver si consigo desinstalarlo todo y volver a empezar :D

 

Un saludo.

 

Bueno, cuando te pide la contraseña, la tecleas, pero creo recordar que no se refleja en la ventana del terminal. Simplemente la introduces y le das a la tecla return o enter.

 

Para completar la desinstalación y empezar de cero, elimina también el módulo de firefox (preferencias/avanzado/cifrado/Disp. de seguridad, seleccionas DNIe en el panel de la izquierda y le das al botón descargar)

 

Lo que comentas del punto 2, no creo que sea necesario que debas tener introducido el DNIe en el lector. Es más, diría que NO debe estar introducido mientras estés instalando el archivo sca 0.2.3pre2.

 

Saludos

Edited by Fai
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.