Jump to content

Problemas con MAMP


Recommended Posts

Hola, desde hace algunas semanas vengo notando una cosa extraña en MAMP.

 

El servidor Apache, según la aplicación, nunca se desactiva. Sólo se desactiva el servidor de mySQL.

Pero a veces incluso la aplicación de MAMP me dice que están activos los servidores pero Apache no está activo y ni siquiera puedo acceder al localhost.

 

Esto, al principio de la instalación me había pasado con el Widget de MAMP: el Widget decía que todo estaba activado y la aplicación decía lo contrario y finalmente todo fallaba. Lo solucioné prescindiendo del Widget.

 

Estoy con Leopard y MAMP 1.7

 

¿A alguien le pasa esto?

 

 

EDITO-----------

 

Por cierto, también me ocurre que el acceso a mi servidor local es lentísimo, el "buscando o esperando a localhost..." se hace eterno.

 

¿.....?

Edited by croma2
Link to post
Share on other sites

En las preferencias del MAMP tengo activado los puertos por defecto,en este caso Apache 8888.

 

Preferencias del MAMP:

 

Iniciar/Detener:

Iniciar servidores al arrancar MAMP(marcado)

Abrir página de inicio al arrancar MAMP (marcado)

Url de la página de inicio:

/index.html

 

Puertos:

Puerto Apache: 8888

Puerto Mysql:8889

 

Para acceder a localhost en la dirección del navegador, localhost:8888

 

Así lo tengo y funciona.

 

 

Los Widgets no los utilizo ,sólo la calculadora.

Edited by mackila
Link to post
Share on other sites

Finalmente paso de MAMP: muuuuuuuy lento, y encima los problemas que explico.

 

He vuelto al Apache/PHP del Leopardo y luego he instalado MySQL a pelo (por cierto, vaya suplicio la instalación de la versión 5.0.51).

 

Salu2

Link to post
Share on other sites
Finalmente paso de MAMP: muuuuuuuy lento, y encima los problemas que explico.

 

he instalado MySQL a pelo (por cierto, vaya suplicio la instalación de la versión 5.0.51).

 

Salu2

 

Dichoso tu que lo has conseguido y te funciona, yo llego mas de dos semanas y no ya no se que hacer. Has encontrado documentación sobre la instalación? Me/Nos puedes guiar un poco?

 

Gracias da antemano

Link to post
Share on other sites

Hola mega,

yo opté por la versión servida con instalador... y menuda castaña!!!!

 

1/ La instalación se arma un lío con los permisos y los propietarios que provoca un problema al arrancar el servidor.

 

2/ Por supuesto, el panel de control no sirve para absolutamente nada: no funciona.

 

3/ Y el instalador del sistema de autoarranque del servidor tampoco funciona...

 

Un verdadero desastre por parte de estos de MySQL porque no es algo que me pase sólo a mí sino que investigando el tema parece que pasa a usuarios con Leopard, al menos.

 

Yo al final lo ha conseguido pero hay que hacer unas cuantas cosas con el terminal arriba y abajo y no estoy seguro de que vaya como debe, aunque funciona rápido de momento:

 

1/ Indicar en el php.ini donde está el socket que crea el servidor de mySQL que es "/tmp/mysql.sock" porque de lo contrario PHP no puede comunicarse con el servidor.

 

2/ Cambiar los permisos del directorio "data" para que todo cristo pueda hacer de todo. Luego arrancas el servidor para instalar las bd básicas del sistema con el script al efecto. Luego apagas el servidor. Vuelves a poner los permisos como estaban.

 

De todos modos yo te recomiendo que te bajes la versión mysql-5.0.51a-osx10.5-x86_64.tar.gz que la descomprimas y sigas las instrucciones de INSTALL-BINARY porque esta instalación a pelo SÍ está bien documentada, aunque creo que falta lo de la conexión con PHP que te comentaba en el punto 1 anterior.

 

Yo voy a intentar hacer esta instalación en cuanto pueda.

Link to post
Share on other sites

Bueno ya lo he intentado... y lo doy por imposible.

 

Estas son los pasos a seguir según las instrucciones:

 

shell> groupadd mysql

shell> useradd -g mysql mysql

shell> cd /usr/local

shell> gunzip < /PATH/TO/MYSQL-VERSION-OS.tar.gz | tar xvf -

shell> ln -s FULL-PATH-TO-MYSQL-VERSION-OS mysql

shell> cd mysql

shell> chown -R mysql .

shell> chgrp -R mysql .

shell> scripts/mysql_install_db --user=mysql

shell> chown -R root .

shell> chown -R mysql data

shell> bin/mysqld_safe --user=mysql &

 

Pues ya la 1ª, 2ª y 4ª no funcionan o sea que apaga y vámonos.

 

Por lo que he podido ver por ahí, Leopard introduce cambios en los comandos de terminal y otros aspectos Unix del sistema para hacerlo merecedor de la certificación Unix no sé qué.

 

La cuestión es que estos cambios hacen que muchos comandos básicos de terminal no funcionan igual que en versiones anteriores del sistema. Por no decir que estos comandos o su uso difieren de un sistema a otro y precisamente las instrucciones me parece que son muy genéricas, vaya que no están pensadas para Leopard o ni siquiera para MacOs X.

 

Además Apple, que yo sepa, no tiene publicado un manual del sistema tipo Manual de FreeBSD

 

En fin, que hacer cualquier pijada en el terminal es un verdadero suplicio cuando todas las instrucciones fallan y las fuentes de información están permanentemente desactualizadas o son inexistentes...

 

Salu2

Link to post
Share on other sites

He insistido algo más y los pasos habría que corregirlos de este modo (entre paréntesis):

 

shell> groupadd mysql (no)

shell> useradd -g mysql mysql (no)

shell> cd /usr/local

shell> gunzip < /PATH/TO/MYSQL-VERSION-OS.tar.gz | tar xvf - (no. Substituir por copiar el directorio ya descomprimido a través del Finder).

shell> ln -s FULL-PATH-TO-MYSQL-VERSION-OS mysql

shell> cd mysql

shell> chown -R mysql .

shell> chgrp -R mysql .

shell> scripts/mysql_install_db --user=mysql

shell> chown -R root .

shell> chown -R mysql data

shell> bin/mysqld_safe --user=mysql & (no. "sudo bin/mysqld_safe --user=root &")

Link to post
Share on other sites
  • 1 year later...

Bueno yo tenia el mismo problema pero lo solucione de esta manera:

 

  • primero de di click en detener servicios en el widget
  • le di en la i de informacion
  • cambie los ajustes de php5->php4
  • reinicie el widget de mamp
  • reinicie los servicios
  • cambie de nuevo los ajustes de php4->php5 en i del widget

bueno esta solucion me sirvio a mi.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.