Jump to content

Directorios de BBDD


Recommended Posts

Hola... bueno, para explicarme bien y no perderme, voy por pasos...

 

- Tengo en mi ftp mi web, y dentro de ella una carpeta llamada "web2" y en ella tengo otra web alojada.

- He creado una base de datos y la he subido mediante el panel de control de mi proveedor al servidor remoto.

- Esta bbdd está asociada a la web que está en la carpeta "web2"

- He modificado el archivo "configuracion.php" con los datos de la base de datos creada anteriormente

- Bien, pues al entrar en el navegador, mediante la url: www.web1.com/web2 --- no se me ve absolutamente nada.

- El mesaje de error que aparece en el navegador es el siguiente:

 

Forbidden

You do not have permission to access this document.

 

Web Server at web1.com

--------------------------

 

Pues ya no sé que hacer, está todo ok. pero no se me ve.... ¿alquién tiene alguna idea del porqué? ¿que fallo he podido cometer y que no veo? ¿ o al crear la bbdd tengo q indicarle algo para decirle que tiene q estar asociada a la carpeta web2? o es en el archivo de configuración.php donde debo indicar algo "extra?

 

Estoy muy perdida, y necesito con urgencia resolverlo... si alguién puede echarme una mano....

 

Mil gracias, desde ya.

Link to post
Share on other sites

Tengo el archivo php que hace la conexion con las contraseñas, con este code:

 

<?php

$link=mysql_connect("localhost","nombreusuario","passw");

mysql_select_db("nombreBBDD",$link);

?>

 

Pero en ningún momento especifico q está todo dentro de una carpeta... ¿donde debería ponerlo? Pq dichos datos sólo los tengo puesto en este php.

 

Espero tu orientación de nuevo, gracias....

Link to post
Share on other sites

Si eso intento , pero no sé como....

 

A ver, yo tengo alojada mi web (web1) en la carpeta httpdocs de mi servidor, con el nombre de index.html, así al entrar en el navegador, se abre la web1, pues bien, denro de aqui, tengo una carpeta llamada web2, y en ella tengo alojada otra web diferente con todos sus archivos de configuarcion y conexion, y en ella la base de datos.

 

Pero claro, la bbdd está creada en phpmyadmin del servidor de la web1, pero lo que quiero es que se conecte a la web2, y lo hace con la web1. Y dentro del phpmyadmin veo que pone "Servidor:localhost:3306" y pincho en él, a ver si puedo poner la carpeta web2, pero no me deja cambiar nada. Y no veo por ningún sitio el poder cambiar estos parámetros desde el phpmyadmin.

 

He probado a quitar la web1, todos sus datos, que están en httpdocs, y poner solo la web2 ahí, pero tampoco funciona.

 

Pienso que para que funcione las carpetas q hay en el inicio del ftp (anon_ftp, bin, cgi-bin, conf, error_docs, httpdocs, httpsdocs, pd, private, statistics, sudomains, vault_scripts, web_users) se deberían quitar y poner todos los archivos de la web2 en su lugar para que funcione?? Que la web2 tiene estas carpetas: acces-logs, etc, mail, public_ftp, public_html, tmp, www.

 

Es éso lo que debo hacer? borrar todo de la web1 y poner todo lo de la web2? no se puede hacer cambiando la ruta del localhost hacia la carpeta web2?

 

Gracias de nuevo

Link to post
Share on other sites
Forbidden

You do not have permission to access this document.

Este error no tiene nada que ver con la base de datos. Te dice que no tienes permiso para acceder al documento (index.php? index.html? quizá el direcotrio web2?) Consulta los permisos del directorio (como los permisos del Mac: rwxrw-r--, etc)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.