Jump to content

Longitud de llave no valida


Recommended Posts

me he leido, os lo juro, las diferentes guias de mantenimiento, y SOLO me queda una duda con Diskwarrior: en la página de compra la version 4 la ultima bajas y compras el DVD, y no me queda claro si puedo usar ambas con el mismo procedimento, es decir, hacer una imagen del diskwarrior en un DVD que me permita arrancar des de él o bien habra que esperar el DVD físico paa realizar la reparación. Será culpa de mi mal inglés pero aqui no lo veo claro

 

un saludo y perdonad las vueltas :rolleyes:

... el DVD de DiskWrrior es bootable,pero puedes tambien iniciar el sistema desde un HD externo ( ... que contenga DW , claro está ) y desde el lanzarlo y reparar tu HD interno.

... en fin,se quieres reparar tu HD interno queda claro que no tiene que estar en uso ( ... DVD de DW bootable u arrancar desde un HD ext. )

Link to post
Share on other sites

gracias a todos

 

he pasado DiskWarrior, pero no me deja la opcion "replace" cuando realiza todo el proceso porque segun dice podria tratarse de un error mecanico. Reptio que estoy trabajando con el equipo y que lo unico que noto es que inicia un poco lento, pero que cuando ha iniciado va correctamente. En fin, no se que mas puedo hacer porque esto lo he hecho dos veces y en ambas no me deja la opcion de reemplazar el directorio. No se si alguien de vosotros esta familiarizado con el diskwarrior y deberís insistir, o que opción me queda.

 

un saludo

Link to post
Share on other sites

se os ocurre alguna cosa ? insisto mas que nada porque si alguien con esta misma experiencia ve que la unica solucion pasa por reinstalar lo voy a hacer. Lo que me da miedo es que sea un tema que me obligue a pasar por SAT a sustituïr el HD.

 

un saludo

Link to post
Share on other sites

lo se, soy un coñazo. He estado mirando y veo que segun el mensaje de DW "the new directory cannot replace the original directory because of a disk malfunction" la cosa no pinta nada bien.

 

Des de mi más profunda ignorancia y mi angustia, ya he bajado esto :huh: por si acaso de un usuario que describe el cambio de un disco duro de un imac (no es mismo que el mio que es el blanco pero bueno,...)

 

Entiendo que disk malfunction se referira a un tema mecànico y por tanto que debe sustituirse, no?

 

venga que alguien me ilumine que me estoy preocupando, ahora si

 

gracias !

Link to post
Share on other sites

Tiene mala pinta, como te está diciendo Diskwarrior ...y lo mejor que puedes hacer desde ahora es hacer una copia de tus datos (utiliza SuperDupper o cualquier software de backups). Y si tienes Applecare, hacer uso de él.

 

Suerte :)

Link to post
Share on other sites
  • 2 weeks later...

buenas !

 

bueno, después de los intentos que habreis leído en el histórico del post, lo que hice fue una reinstalacion del sistema (borrar e instalar, creo que se llama), y en principio parece que el tema está resuelto, con lo que concluyo que el tema no es mecánico, tal y como venía anunciando diskwarrior cuando intentava reparar. ¿ que opináis ?

 

un saludo

Link to post
Share on other sites
  • 2 months later...

Hola amigos,

 

a raíz de notar que mi Imac bajaba mucho el rendimiento y que aparecía constantemente el círculo de colores abrí este post e hice todo lo que recomiendan las guías. Al final, reinstale tiger en modo borrar e instalar con lo que imaginaba que los problemas desaparecerían. Y ya van 2 veces, con resultados similares (se cuelga bastante y tarda en gestionar las aplicaciones como iphoto, mail, neooffice y poca cosa más). He revisado la memoria ram quedándome solamente con un módulo de 2 gb por si era este el problema (lo he cambiado de zócalo y he comprado un módulo nuevo, hay un post hablando de este tema) y pasa incluso con tiger recién instalado e actualizado. Me pasa con aplicaciones que antes movía con total soltura y agilidad. Bien, a diferencia de los problemas que comento en el otro post, ahora no detecto problemas relacionados con el disco, y Onyx no me da error.

 

Por tanto os pregunto, ¿ cual puede ser la razón para un rendimiento tan deficiente en un Intel Core 2 Duo ,2.16 GHz con 2 gb de ram del 2007 ?

 

Tengo ya en mis manos un nuevo Hd pero me gustaría saber que puedo hacer y/o que comprobaciones puedo realizar antes de abrir mi imac y "intentar" cambiar el disco duro (por si fuera esta la razón).

 

gracias de antemano y perdonad el tochón !

Link to post
Share on other sites

Le he unido al inicial, pues es mejor tener todos los datos para poder ayudarte ;)

 

En principio, y ya que has reinstalado y formateado en dos ocasiones con resultados fallidos, lo que cabe pensar es que tengas un problema de hardware. Yo probaría, no obstante, a formatear de nuevo, desconectando todos los periféricos y únicamente con las actualizaciones necesarias del sistema, y ver si funciona así con normalidad ...no vaya a ser que un software de terceros sea el culpable. Pásale un hardware test y también el Memtest para comprobar el estado de la Ram. Una pasada con Diskwarrior tampoco haría daño.

 

Saludos :)

Link to post
Share on other sites

Ei, gracias por una rápida respuesta. Estoy decidido a probar con un cambio del disco duro, a ver si por casualidad es esto, ya que originalmente parecía que el tema iba por ahí. Por supuesto vuelvo a postear con los resultados, por si algun usuario tiene/ha tenido el mismo problema.

 

un saludo

Link to post
Share on other sites

Bueno, pues al final he decidido sustituir el HD interno por uno nuevo como se comenta aqui (un seagate de 500 gb) y he notado en seguida la mejora. Nada mas instalar de nuevo las aplicaciones, actualizaciones y cópias de seguridad he notado que se mueve con total soltura y en fin, de momento como nuevo. Lo unico extraño en todo esto es que no sabía que un disco podía dar este tipo de fallos y pensaba (por ignorancia) que "se morían" súbitamente y sin avisar.

 

un saludo y gracias por vuestras aportaciones

Link to post
Share on other sites
  • 7 months later...

Hola tengo una eMag sitema 10.4 estoy teniendo problemas ya que al ir la directorio y poner /sbin/fsck -f me marca error de key, antes no lo hjacia y la reparaba sinproblemas pero de un derrrepente lo hizo y no he podido reparar el disco, enciende normal y trabaja mas o menos ya que se alenta o se queda leyendo mucho tiempo. Solicito su ayuda para saber como reparar el directorio de mi mac. Gracias

Link to post
Share on other sites
Hola tengo una eMag sitema 10.4 estoy teniendo problemas ya que al ir la directorio y poner /sbin/fsck -f me marca error de key, antes no lo hjacia y la reparaba sinproblemas pero de un derrrepente lo hizo y no he podido reparar el disco, enciende normal y trabaja mas o menos ya que se alenta o se queda leyendo mucho tiempo. Solicito su ayuda para saber como reparar el directorio de mi mac. Gracias

 

Tema unido. Vete leyendo por aquí ...y recuerda usar búsquedas antes de abrir un tema ;)

 

Saludos :)

Link to post
Share on other sites

Aunque he hecho búsquedas no me aclaro, y no quiero meter la pata.

 

Ayer me decidía a instalar el Leopard en el Macpro. Saque el HD de sistema y meti uno nuevo e instalé el Leopard. Todo como la seda.

 

Hoy he tenido que recuperar unos archivos del HD Sistema Tiger. Así que he quitado de la bahía el HD LEOPARD y he vuelto a poner el HD TIGER.

Hasta aquí todo bien. Como soy un patán no me di cuenta al hacer el cambio de que el MACPRO estaba en reposo y no apagado.

 

El caso es que ahora el HD Tiger no funciona.

 

Lo pincho desde una caja externa USB y al pasar utilidades de Disco y verificar me dice el siguiente error:

 

Error leyendo Disc2s2

"Longitud de llave no valida"

 

Que puedo hacer para recuperar este disco de arranque Tiger con todos sus datos?? Lo puedo hacer con DIskwarrior desde el sistema Leopard??

 

 

*(Quizá otra posible causa que ha podido dañar la estructura del HD es que creo que sin darme cuenta he actualizado el Firmware del Macpro.)

 

MUCHISIMAS GRACIAS A TODOS!!

Link to post
Share on other sites

Me auto respondo por si la experiencia sirve para otros.

He pinchado HD dañado en otra bahia y he arrancado con leopard.

Con diskwarrior le he dado a recuperar. Tras 4 horas ha montado el HD en el escritorio y ha mostrado un informe diciendo que hay archivos gravemente dañados. Al menos voy recuperar casi toda la información.... bye bye sistema Tiger

Link to post
Share on other sites

Pues siguen los problemas...

 

Tras copiar archivos a otro HD. Le dí a rebuilt desde diskwarrior.

 

El caso es que lleva así 5 horas ya ... cada 60" monta el HD en el escritorio durante 2" y vuleve a desaparecer... :

 

warrior.jpg

 

 

Que hago?? cancelo ?? cuelgo diskwarrior ?? reinicio?? espero 2 días así a ver que sucede???

 

Gracias

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.