Jump to content

Acceso a localhost prohibido


Recommended Posts

Hola,

 

Quiero acceder a través del navegador a http://192.168.2.5/~minombre/, pero me sale el mensaje:

 

Forbidden

 

You don't have permission to access /~minombre/ on this server.

 

A http://192.168.2.5/ sí puedo acceder, y me sale la página de Apache.

 

Tengo activado "Compartir web", y mi carpeta Web tiene permisos de lectura y escritura, pero no me funciona. ¿Qué debo hacer?

 

Gracias.

Link to post
Share on other sites

Eso me pasa a mi cuando toco algo en la configuracion del apache, reviza si tienes dentro de tu carpeta de usuario alguna que se llame Web en el finder y por terminal Sites si no es asi, la tienes que crear y pruebas de nuevo

Link to post
Share on other sites

Entiendo que la dirección http://192.168.2.5/~minombre/, es la que te aparece en la ventana de Preferencias/Compartir.

 

En mi carpeta de usuario a mi me aparece con el nombre de "Web" en lugar de "Sites", supongo que en el tuyo también, a no ser que tengas el sistema en inglés.

Edited by mackila
Link to post
Share on other sites
Sí, es la dirección que me aparece en Preferencias, y sí, la carpeta se llama Sites porque tengo el sistema en inglés.

 

Revisa los permisos con cmd+i tanto de tu carpeta de usuario (la del icono de la "casita") como la de sites.

 

Deberian estar asi

 

Me: Read & Write

Staff: Read &Write

everyone: Read only

 

Si eso no funciona...es por este otro motivo...

 

Abre la carpeta /private/etc/apache2/users

 

crea un fichero de texto simple con textedit mismo llamado minombre.conf donde "minombre" es el nombre de tu usuario como tu has puesto en el ejemplo

 

y al fichero le añadimos esto

#
# Allow access to this user's Sites directory for web clients.
#
<Directory "/Users/minombre/Sites/">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

 

Recuerda sustituir donde pone minombre por el nombre corto de tu usuario.

Link to post
Share on other sites
  • 4 months later...

Miguej, muchísimas gracias por el consejo: a mí sí me ha resuelto el problema, que era idéntico al de Zubrik. Ahora bien, he seguido además estos pasos:

 

1) Después de crear y guardar el fichero Minombre.conf he reiniciado el MAC. Si sólo se reinicia el Servidor, introduciendo en el terminal el comando sudo /usr/sbin/apachectl restart. (extraído de IDG ) sigue sin funcionar, hay que reiniciar el ordenador.

 

2) Antes de intentar abrir nuevamente la página de prueba he vaciado la caché de Safari, que era el navegador que estaba usando.

 

Sin embargo, siguiendo los pasos que tú describías me encontré con algo desconocido. En la información de mi carpeta de usuario, los parámetros no están como deberían:

Yo = leer y escribir

Desconocido = leer solo (no puedo cambiar esta configuración, por supuesto abro el candado)

Everyone = leer solo

 

No tengo ni idea de cómo se ha creado esa cuenta DESCONOCIDO ni cómo cambiar la configuración. En Preferencias /Cuentas sólo tengo la del Administrador y un Invitado que está desactivado. Quizás también puedas ayudarme. Gracias en cualquier caso. Saludos :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.