Jump to content
Granjero Moe

Bash: ejecutar comando con argumentos

Recommended Posts

Me he hecho un pequeño script bash para ejecutar una sentencia mysql y no me funciona.

El problema es que no me admite los argumentos de mysql.

 

Éste es el script que me falla:

 

 

#!/bin/bash
#
MYSQL="/Applications/MAMP/Library/bin/mysql"
MYSQL_ARGS="-u root baseDatos"
${MSYQL} ${MYSQL_ARGS}

 

 

 

Me dice "-u: command not found"

 

 

¿Cómo puedo entonces pasarle argumentos a Mysql?

Share this post


Link to post
Share on other sites

¿Y no te pica la curiosidad?

Eso se debe poder hacer, ¿Cómo?

 

Si no hubieras dicho nada... Aunque alguien muy sabio dijo aquello de que "si algo funciona, no lo toques" :lol:

 

Aunque no veo una utilidad a corto plazo de lo que comentas. Para un solo comando no le veo el sentido practico, la verdad...

Share this post


Link to post
Share on other sites

Pero hombre, está claro que hacer un script para un solo comando no tiene sentido. Mi script es más largo pero lo que falla es el trozo que he sacado.

 

Y el querer saber cómo hacer esto es por éste script y para cuando se me presente el mismo problema en otros futuros scripts.

 

¿Alguien sabe cómo solucionar esto?

Share this post


Link to post
Share on other sites

Prueba a escribir bien el nombre de las variables :lol:

 

${MYSQL} ${MYSQL_ARGS}

 

Te puede interesar conocer el comando eval (de man bash)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.