Jump to content

La App Store permite descargar versiones aplicaciones antiguas


Recommended Posts

Estuve el otro día configurándole :rolleyes: el iPad 1 con la 5.1.1que había vendido a módico precio a un familiar y tenía sin usar y casi todas las apps que le recomendé – por ejemplo, Dropbox o Evernote– y que yo tengo en mi iPad 1 no le instalaban por ser para ios 6 o 7. ¿Ya no funciona lo que se comenta en este hilo o depende de cada desarroillador? Porque si no puede hacer nada me siento fatal y estoy por devolverle el dinero y comérmelo con patatas...

Saludos

 

Pero el iPad 1 no es compatible con iOS 6?blink.gif

Link to post
Share on other sites
  • Replies 50
  • Created
  • Last Reply

Top Posters In This Topic

No, 5.1.1.

Porque les da la gana, porque un iPhone 4 tiene el mismo hardware y corre la 7. Y vamos , que dejar obsoleto completamente (porque no hablamos de correr el último juego sino aplicaciones básicas) un producto que tiene poco más de tres años...

Lo suyo sería que , al menos, y como creí que ocurriría, pudiera seguir instal´ando las versiones compatibles. Es que me va a tocar, por honestidad y aunque no me lo haya dicho, devolverle el dinero o ponerlo con mi id de Apple y meterle la copia de seguridad de lo que tenía antes de restaurarlo. Caray, que se ha quedado en un ladrillo para navegar y poco más.

Edited by Miguimau
Link to post
Share on other sites

Jope, yo imaginaba que sería perfectamente compatible, porque como tú bien dices, el hardware es más que suficiente... Un iphone todavía sigue teniendo el uso de teléfono, pero un ipad sin aplicaciones de productividad pierde todo el sentidosad.gif

Link to post
Share on other sites

No, 5.1.1.

Porque les da la gana, porque un iPhone 4 tiene el mismo hardware y corre la 7. Y vamos , que dejar obsoleto completamente (porque no hablamos de correr el último juego sino aplicaciones básicas) un producto que tiene poco más de tres años...

Lo suyo sería que , al menos, y como creí que ocurriría, pudiera seguir instal´ando las versiones compatibles. Es que me va a tocar, por honestidad y aunque no me lo haya dicho, devolverle el dinero o ponerlo con mi id de Apple y meterle la copia de seguridad de lo que tenía antes de restaurarlo. Caray, que se ha quedado en un ladrillo para navegar y poco más.

 

Miguimau, acabo de probarlo y no hay problema con ninguna de las aplicaciones que comentas (Dropbox y Evernote), te deja instalarlas sin problemas, eso sí, la versión antigua.

 

De hecho yo el mío lo restauré hace poco y no he tenido ningún problema de aplicaciones que no se puedan instalar. Eso sí, no va muy fino, pero tiene ya tres años.

Edited by Andropov
Link to post
Share on other sites

De hecho, estaban en el iPad antes de restaurarlo, claro. ¿Tú las tenías ya adquiridas o de nuevas? ¿Desde el Mac o desde el iPad?

 

Probaré de nuevo pero con todas esas y otras me salía que era para iOS 6 o superior. Lo hice desde el iPad. A ver si desde App store en su Mac es otra cosa.

Gracias. :)

Edited by Miguimau
Link to post
Share on other sites

Desde itunes en mac sólo se va a poder descargar la última versión que haya de la aplicación, tiene que hacerlo desde el propio dispositivo

 

Aunque depende de los desarrolladores que se puedan o no descargar versiones anteriores, acabo de comprobar que puedes descargarla siempre que la tuvieras comprada, en caso contrario te dice que actualices la versión de iOS, no sé si en todas, pero en concreto con dropbox he podido descargarla en un iphone con la 4.2.1, con la id con la que la compré, pero no me ha dejado hacerlo con otra id

Link to post
Share on other sites

No, 5.1.1.

Porque les da la gana, porque un iPhone 4 tiene el mismo hardware y corre la 7. Y vamos , que dejar obsoleto completamente (porque no hablamos de correr el último juego sino aplicaciones básicas) un producto que tiene poco más de tres años...

 

En realidad este iPad a efectos de comparar sistemas habría que hacerlo con el iPhone 3GS. Es cierto que el iPhone 4 tiene el mismo procesador pero las diferencias a este respecto con el iPhone 3GS son de unos MHz y un "rebrandering". En cambio donde si hay diferencia es en la cantidad de memoria, 512 MB en el iPhone 4 y 256 MB en el iPad original e iPhone 3GS y esto si que se nota. Supongo que también será el motivo por el que el iPhone 3GS se ha quedado fuera del iOS 7. Aún así el iPad original no debería tener ningún problema en correr el iOS 6, una versión más que la que oficialmente Apple permite mad.gif.

Edited by Xtampida
Link to post
Share on other sites

Pues es como dice Albarre, imagino. Pero no tengo el iPad para probarlo.

Obviamente con lo que tienes comprado no es el problema. Ya digo que todo eso y mucho más lo tenía funcionando sin problemas y lo sigo teniendo en los otros ipads de casa.

Link to post
Share on other sites

Y yo me pregunto, si la compras en la iTunes Store (en el Mac/PC), ¿luego te deja instalarla en el iPad? ¿O había que haberla comprado cuando la aplicación aún funcionaba sobre esa versión?

 

Buena pregunta, no se me había ocurrido, pero acabo de comprobar lo que dices, primero comprarla desde itunes en el mac o en windows, la versión actual que es la única que se puede adquirir, y después descargarla desde iOS, y ahora sí te permite instalar la versión anterior :)

Edited by Albarre
Link to post
Share on other sites

Sí, depende de los desarrolladores y de que haya versión compatible con esa versión de iOS, porque la otra que comentabas, Evernote, no deja instalarla en la 4.2.1, pero sí en el ipad con la 5.1.1, seguramente no hubo versión para esa actualización

Link to post
Share on other sites
  • 2 weeks later...

Uy, me he confundido.. esto es la App Store para iOS.. Yo pregunta por la App Store de MacOS X... Borro esto, y pongo mi pregunta en el post de MacOS X Mavericks... Pues no encuentro post adecuado sobre la App Store..

 

Disculpen.

Edited by Planta-Vit
Link to post
Share on other sites

No, 5.1.1.

Porque les da la gana, porque un iPhone 4 tiene el mismo hardware y corre la 7. Y vamos , que dejar obsoleto completamente (porque no hablamos de correr el último juego sino aplicaciones básicas) un producto que tiene poco más de tres años…

No tienen el mismo hardware ni de coña. La diferencia brutal es la cantidad de memoria RAM. 256 MB en el iPad, y 512 MB en el iPhone 4.

 

Jope, yo imaginaba que sería perfectamente compatible, porque como tú bien dices, el hardware es más que suficiente... Un iphone todavía sigue teniendo el uso de teléfono, pero un ipad sin aplicaciones de productividad pierde todo el sentidosad.gif

La memoria es la diferencia clave. A partir de iOS 6 aumentó la complejidad del sistema y sus requisitos de memoria. Lo metieron con calzador en el iPhone 3GS y eso quitando bastantes cosas.

Link to post
Share on other sites

No, 5.1.1.

Porque les da la gana, porque un iPhone 4 tiene el mismo hardware y corre la 7. Y vamos , que dejar obsoleto completamente (porque no hablamos de correr el último juego sino aplicaciones básicas) un producto que tiene poco más de tres años…

No tienen el mismo hardware ni de coña. La diferencia brutal es la cantidad de memoria RAM. 256 MB en el iPad, y 512 MB en el iPhone 4.

 

Lo esencial que planteaba es que hay multitud de aplicaciones que no funcionan en un iPad 1 (o un iPhone 3G) no porque el hardware no lo permita sino por cortes o decisiones arbitrarias.

Link to post
Share on other sites

No, 5.1.1.

Porque les da la gana, porque un iPhone 4 tiene el mismo hardware y corre la 7. Y vamos , que dejar obsoleto completamente (porque no hablamos de correr el último juego sino aplicaciones básicas) un producto que tiene poco más de tres años…

No tienen el mismo hardware ni de coña. La diferencia brutal es la cantidad de memoria RAM. 256 MB en el iPad, y 512 MB en el iPhone 4.

 

Lo esencial que planteaba es que hay multitud de aplicaciones que no funcionan en un iPad 1 (o un iPhone 3G) no porque el hardware no lo permita sino por cortes o decisiones arbitrarias.

Hombre, hay multitud de casos, debidos a su vez a multitud de razones.

 

En primer lugar, en el caso del iPad es la memoria la que limita el que iOS pueda correr con pinzas o no. Con la diferencia de que en un iPad es mucho màs crítico que iOS funcione muy bien. Porque un teléfono al fin y al cabo te sirve para llamar y lo otro puede ser secundario. No así en un iPad.

 

Así que no creo que es "arbitraria" ni "capatoria" la decisión de no soportar iOS6 y superiores en el iPad primigenio.

 

Por otro lado, cada revisión mayor del sistema incluye nuevos servicios y funcionalidades. Los fabricantes de software se enfrentan entonces a la decisión de soportar las novedades, en general mejorando la aplicación o, por el contrario, no soportar novedad alguna y que todo siga como siempre.

 

Uno de los ejemplos fue Whatsapp, pero no se decirte si se debió a alguna incompatibilidad esencial o a que los de Whatsapp pasaron del tema.

 

Y, finalmente, Apple aceptó dejar que se descargaran versiones antiguas de la App Store, aunque esto también tiene su miga. Porque puede haber versiones de aplicaciones antiguas compatibles con iOS6 que quizás tengan agujeros de seguridad (u otro tipo de problemas) y debido a eso aceptaron también que el desarrollador pudiera oponerse a la descarga por los problemas citados.

 

En fin, no es que me parezca la mejor de las soluciones, pero es una consecuencia inevitable del ritmo de mejoras en todo lo que tiene que ver con la informática. ¿Quizás se podría pedir a los fabricantes que pararan y prohibirles sacar novedades en menos de 5 años? Por lo demás, poca opción hay.

Link to post
Share on other sites

Bueno, la principal causa para que haya aplicaciones que no funcionan en un iPad 1 es que éste se quedó en iOS 5.1.1. Lo cual, por cierto, sí que en su momento me pareció un tanto arbitrario, puesto que Apple logró meter (con calzador) iOS 6 en el iPhone 3GS, que sí que tenía un hardware inferior al del iPad 1 (y la misma cantidad de RAM).

Link to post
Share on other sites

Bueno, la principal causa para que haya aplicaciones que no funcionan en un iPad 1 es que éste se quedó en iOS 5.1.1. Lo cual, por cierto, sí que en su momento me pareció un tanto arbitrario, puesto que Apple logró meter (con calzador) iOS 6 en el iPhone 3GS, que sí que tenía un hardware inferior al del iPad 1 (y la misma cantidad de RAM).

Pues eso es la otra parte de lo que decía . Que hacer el corte del iPad 1 es arbitrario. Y el ejemplo del iPhone 3Gs con respecto al iPad 1 sí que es bueno.
Link to post
Share on other sites

Pero aunque hubiesen metido con calzador iOS 6 en el iPad 1, iOS 7 no le hubiese entrado ni a martillazos con 256 MB de RAM. El problema de aplicaciones incompatibles sólo se habría retrasado unos meses.

Link to post
Share on other sites

Uno de los ejemplos fue Whatsapp, pero no se decirte si se debió a alguna incompatibilidad esencial o a que los de Whatsapp pasaron del tema.

 

Básicamente los de Whatsapp cambiaron la comunicación de sockets entre el server y la app. Mantuvieron el sistema antiguo de sockets durante un tiempo (Aquí estuvo el error) y actualizaron su app, todavía funcionando en los 3G.

 

¿Que sucedió entonces? Pues que Apple sacó un nuevo Xcode que era incompatible con versiones anteriores a la 4.3 (los 3G se quedaron en la 4.2.1), este Xcode daba soporte a la nueva pantalla de iPhone 5 que acababa de salir, entonces tenías 2 salidas, o desarrollabas para que se viera bien en el 5 y te cargabas la compatibilidad o mantenía la compatibilidad y pasabas del 5 (Realmente con un poco de esfuerzo podías hacer que se viera bien en el iPhone 5 usando un Xcode anterior), los de whatsapp eligieron adaptarse al iPhone 5.

 

Poco después chaparon el sistema antiguo de comunicación vía server, entonces los que tenían la versión ultima que funcionaba en los 3G podían acceder, los que tenían versiones antiguas, eran incapaces de acceder a esa versión, ya que Apple solo permitía descargar la ultima versión, que no era compatible con versiones anteriores al 4.3

 

Es decir, no fue un problema de incompatibilidad o apis, el problema fue que precisamente no existía algo como lo que se discute en esta noticia.

Edited by Juan_Garcia
Link to post
Share on other sites
  • 3 years later...

Hola, tengo un micro externo que se conecta al iphone 4 para tener mejor entrada de audio y ahora resulta que han quitado de la store la app que lo activaba y que una vez puesta te dejaba usarlo con cualquier app

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.