Jump to content

Trim en High Sierra MacBook Pro


Recommended Posts

Hola,

Lo primero de todo me gustaría saber si este tema se ha tratado ya. Tal vez haya un hilo ya abierto... he echando un vistazo en el foro pero no encontré nada.

Acabo de instalar en MacBook Pro 2011 un SSD de Kingston 480 GB y activado TRIM por terminal. Mi sorpresa me la he llevado después de reiniciar el equipo para activar TRIM.. ¡El Mac iba mucho más lento! Ha tardado mucho más tiempo en reiniciar y apagar con TRIM activado. He reiniciado varias veces pero con el mismo resultado. Incluso las aplicaciones me tardaban más en ejecutar, safari mucho más lento también, en general todo ralentizado... Ahora tengo TRIM desactivado otra vez y todo perfecto.

¿Qué puede estar pasando? ¿No se supone que TRIM está pensado para optimizar el SDD entre otras cosas?

Link to post
Share on other sites
Hace 56 minutos, APB dijo:

¿Has mirado si tu disco es compatible con TRIM?

Míralo en Acerca de este Mac>Informe del sistema>SATA o el interface donde encuentres el disco

Hola, tendría que ser compatible, no? Cómo puedo hacer esa comprobación? A que tendría que referirse?

Este es el modelo, recien comprado hace menos de un mes...

https://www.kingston.com/ES/ssd/consumer/sa400s37

Link to post
Share on other sites
Hace 3 horas, fakoly dijo:

Cómo puedo hacer esa comprobación?

¿Donde te has perdido en esta dirección?

Hace 4 horas, APB dijo:

Míralo en Acerca de este Mac>Informe del sistema>SATA o el interface donde encuentres el disco

Como no tengo ningún SSD no lo puedo asegurar pero, por lo leído, ha de aparecerte un apartado donde ponga Compatible con TRIM: Si ó No.

Link to post
Share on other sites
Hace 2 horas, APB dijo:

Como no tengo ningún SSD no lo puedo asegurar pero, por lo leído, ha de aparecerte un apartado donde ponga Compatible con TRIM: Si ó No.

Confirmo lo que dices. Al menos con mi SSD de serie de Apple sí sale lo siguiente en Informe del sistema-SATA:

 

APPLE SSD SD0128F:

  Capacidad:    121,33 GB (121.332.826.112 bytes)
  Modelo:    APPLE SSD SD0128F                       
  Revisión:    A222821
  Número de serie:    1333A2404676
  Native Command Queuing:    Sí
  Profundidad de la cola:    32
  Soporte extraíble:    No
  Unidad extraíble:    No
  Nombre BSD:    disk0
  Tipo de soporte:    Estado sólido
  Compatibilidad con TRIM:    Sí
  Tipo de mapa de particiones:    GPT (Tabla de particiones GUID)
  Estado S.M.A.R.T.:    Verificado

Link to post
Share on other sites

Matizar que todo depende del S.O.

En el caso del compañero @fakoly , con High Sierra en un soporte SSD , el instalador convierte automáticamente en el nuevo formato APFS

En mi caso ( iMac 2017 con SSD de serie ) no aparece la compatibilidad TRIM por lo que deduzco ( que alguien me corrija ) que en APFS ya no necesita TRIM

  • Me gusta 1
Link to post
Share on other sites

Lo normal es que utilicen trim incluso con APFS. 

Los que no lo véis, ¿dónde lo estáis mirando? No es lo mismo mirar por volúmenes que por dispositivos físicos.

Para los discos SATA mirad en Acerca de este Mac -> Perfil del sistema -> SATA o en NVMEXpress.

NO MIRÉIS EN LA PARTE DE "ALMACENAMIENTO".

  • Me gusta 1
Link to post
Share on other sites

fakoly, por si te sientes solo he encontrado un hilo en Macrumors en el que hablan de casos parecidos al tuyo, ssd’s que se vuelven lentos al ínstalar HS. Tiene muchas páginas por lo que ido picoteando algunos mensajes pero las soluciones encontradas pasaban por desactivar TRIM o restaurar Nvram, o ninguna de las anteriores.

Como no lo he leído completo ignoro si encontraron un final feliz para todos, si quieres entretenerte lo encontraras fácilmente si buscas por apfs trim SSD.

Edited by APB
Link to post
Share on other sites

Hace un par de años tuve problemas con unos NVMe de Intel que casi se congelaban con el trim. Modelos gordos para servidores, no de portátil.

Con una actualización de firmware hubo un cambio de prestaciones radical.

Podría ser algo parecido pero conviene recopilar bien los datos. 

Por otro lado, recordad una cosa, la pongo en negrita.

Con los SSD para los que Apple no activa el trim por defecto la instalación se hace sin trim. Cuando activamos el trim en realidad es posible que haya muchos bloques de disco que no se han liberado correctamente. Una buena cura para esto es, una vez activado el trim, crear un archivo enorme y después borrarlo. Al hacer esto forzamos a que al menos los bloques de disco ocupados por dicho archivo gordo se marquen correctamente como libres y el controlador de flash les del el calambrazo.

 

Link to post
Share on other sites

Aunque no lo termino de entender, según leo en varios sitios, en el apartado Compatibilidad con TRIM: se indica si TRIM está activado en lugar de si tu SSD es compatible con esa función aunque por el título lo parezca.

O todas las webs han bebido de la misma fuente errónea o el funcionamiento de TRIM, que desconozco completamente, hace que tenga sentido hablar de Compatibilidad con TRIM: en lugar de TRIM activado:. Tal vez cuando no sale este apartado es que en ese disco no se puede activar ¿¿¿???.

Edited by APB
Link to post
Share on other sites

Gracias a todos por vuestras respuestas...

En Perfil de Sistema me aparece “TRIM : No” Pero porque no está activado y es cuando lo activo cuando aparecen los problemas... Claro, después de activarlo me aparece “TRIM: SI”

Tengo un Mac Pro del 2010 con Leopard Snow dos SSD Vertex y activado TRIM, y van como la seda...

En caso del MacBook Pro con High Sierra y el SSD de Kingston480GB recién instalado, no sé qué puede pasar... Por lo que sé, TRIM hace que no se degrade tanto el SSD, y es el motivo por el que me gustaría tenerlo activado, pero claro, no a costa de parecerse a un disco rígido en cuanto a su velocidad de trabajo... Es más, por momentos parece que el equipo se va a quedar colgado con TRIM activado...😓😡

Link to post
Share on other sites
Hace 44 minutos, fakoly dijo:

En Perfil de Sistema me aparece “TRIM : No

¿Te aparece solo TRIM o Compatibilidad con TRIM? Si es lo segundo confirmas la información de las webs que comentaba antes.

Link to post
Share on other sites
Hace 8 horas, danilob dijo:

Matizar que todo depende del S.O.

En el caso del compañero @fakoly , con High Sierra en un soporte SSD , el instalador convierte automáticamente en el nuevo formato APFS

En mi caso ( iMac 2017 con SSD de serie ) no aparece la compatibilidad TRIM por lo que deduzco ( que alguien me corrija ) que en APFS ya no necesita TRIM

Me corrijo solo y con la indicación de @borjam en NVMExpress encuentro el " dichoso " TRIM.

Lo que desconozco es si esta activado ( solo se menciona la compatibilidad )

Captura de pantalla 2018-12-17 a las 18.53.20.png

Link to post
Share on other sites
Hace 29 minutos, danilob dijo:

Lo que desconozco es si esta activado ( solo se menciona la compatibilidad )

Si lees mis mensajes anteriores te sorprenderá saber que, por lo que parece, Compatibilidad con TRIM significa TRIM activado. Dicho de otro modo, como te aparece un SI es que lo tienes activado.

Edited by APB
  • Me gusta 1
Link to post
Share on other sites

Hola, no estoy seguro de cuál sea el problema pero yo tengo unas máquinas muy similares a la tuya.

Son dos MacBook Pro Late 2011 de 17", uno con Lion y el otro con High Sierra (los compré con una configuración personalizada por lo que tal vez no son exactamente iguales).

Hace unos meses reemplacé los discos originales HD de 750 GB por SSD de 1TB (además de incrementar la RAM a 16GB, aunque Apple dice que solo soportan 8GB), en ambos habilité el soporte TRIM por medio de la Terminal (tanto en Lion como en High Sierra), y la verdad es que ambos van muy bien, incluso superaron mis expectativas, la máquina que tiene Lion enciende en menos de cinco segundos, la que tiene High Sierra tarda un poco más pero es realmente rápida.

En cuanto al trabajo, pues no tengo problemas. Todo funciona muy bien y puedo abrir cuantas cosas desee sin que tenga problemas de lentitud o congelamiento (algo que sí pasaba en la que tiene High Sierra antes de actualizarlas).

 

Dejo un par de capturas en caso de que te pueda servir de algo.

1785778820_ScreenShot2018-12-17at17_17_45.png.76126c21471462733730191cc4142843.png1736646641_ScreenShot2018-12-17at17_10_10.png.117d834d238a08ba112dd4a2488e9dc2.png

Saludos

Link to post
Share on other sites

Gracias a todos por vuestras respuestas...

En Perfil de Sistema me aparece “TRIM : No” Pero porque no está activado y es cuando lo activo cuando aparecen los problemas... Claro, después de activarlo me aparece “TRIM: SI”

Tengo un Mac Pro del 2010 con Leopard Snow dos SSD Vertex y activado TRIM, y van como la seda...

En caso del MacBook Pro con High Sierra y el SSD de Kingston480GB recién instalado, no sé qué puede pasar... Por lo que sé, TRIM hace que no se degrade tanto el SSD, y es el motivo por el que me gustaría tenerlo activado, pero claro, no a costa de parecerse a un disco rígido en cuanto a su velocidad de trabajo... Es más, por momentos parece que el equipo se va a quedar colgado con TRIM activado...😓😡

Link to post
Share on other sites

Tengo alguna novedad que quisiera compartir. Se me ocurrió ponerme en contacto con el servicio técnico de Kingston, a ver si ellos podían ser más concluyentes con lo que me estaba pasando con el disco recién adquirido en el Black Friday del 2018 en Media Market... Y sí, fueron muy concluyentes... me dijeron que la unidad estaba defectuosa y que me mandarían otra! Lo cierto es que me ha sorprendido que fueran así de claros y no me preguntaran nada...

  • Me gusta 2
Link to post
Share on other sites
  • 1 year later...

Hola,

Lo primero de todo pedir disculpas por no continuar con el hilo y no seguir reportando información sobre este caso. Metido en la vorágine de mi día a día al final lo dejé estar. También sobre todo porque no encontré un final al problema. Quiero retomar el asunto para concluirlo a la vista de que no doy con la solución...

Me quedé cuando contacté con el servicio técnico de Kingston para comentarles sobre el asunto. Me dijeron que el disco estaba defectuoso y que me madarían otro. Finalmente recibí el nuevo disco y al instalarlo seguía teniendo el mismo problema (cuando activaba TRIM, el equipo tardaba mucho en arrancar y notaba el Mac algo más lento). Desde entonces hasta hoy tengo en TRIM desactivado y todo bien.

Hace muy poco tiempo he decidido cambiar el Kingston por un Vertex 3 de 120G, y usar el primero como secundario para almacenamiento. Puestos a cambios y nueva instalación de softwares, he probado a activar de nuevo el TRIM en el Vertex. Pues bien, el mismo problema con el Vertex, cuando activo TRIM, todo muy lento.

Definitivamente, dejaré el TRIM desactivado en detrimento de la degradación del disco, que tengo entendido que es una de las funciones que hace el TRIM sobre los SSD.

En cualquier caso, si alguno de vosotros teneis nueva info sobre este asunto será como siempre bienvenida.

Muchas gracias por todos vuestros mensaje.

Link to post
Share on other sites

Primero yo agradezco que nos des los pormenores de la situación.

Lo que no entiendo es por qué te sucede pero espero que eso de la degradación de los SSD no te afecte (honestamente no recuerdo que le sucede al SSD).

Saludos y gracias

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.