Jump to content
Hacedor

ssd m.2 Mac Pro 2009

Recommended Posts

Os cuento a continuación mis experiencias por si a alguno le viene bien,

Mac Pro 2009 subido a 2010.

Tarjeta PCIe M.2 NGFF SSD Adapter LyCOM DT-120 + Samsung SM951 512GB M.2 Solid State Drive ( Ya no se vende nuevo )

https://www.amazon.es/LyCOM-DT-120-Interno-Adaptador-Interfaz/dp/B00MYCQP38

IMG-0173.jpg

Se instala sin necesidad de actualizar ni meter ningún Driver adicional Tanto en un Mac Pro 3.1 como en un 4.1 ( subido ó sin subir a 5.1 ) funcionando como disco de arranque dando unas velocidades de lectura/escritura muy buenas,

m2-512.png

Si utilizamos hardware de hoy, como pueden ser los ssd m.2, ya que los Samsung SM951 ya no se venden nuevos, podemos adquirir los Samsung 970 EVO - Disco Duro sólido de 1 TB por ejemplo, acompañado de un Angel Bird Wings PX1 SSD adaptador [PCI-e x4 - M 2. | NVME/compatible AHCE] - WPX1-FWKF,

https://www.amazon.es/gp/product/B01BLGO6N8/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

https://www.amazon.es/gp/product/B07CGJNLBB/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1

IMG-0172.jpg

Con los cuales mejoraremos algo la velocidad de lectura/escritura

m2-970-evo.png

En este caso la instalación es la misma, sin necesidad de instalar ningún tipo de Driver.

Espero sea de ayuda,

 

Un saludo.

 

 

  • Gracias 2

Share this post


Link to post
Share on other sites
El 28/12/2018 a las 16:06, Hacedor dijo:

Os cuento a continuación mis experiencias por si a alguno le viene bien,

Mac Pro 2009 subido a 2010.

Tarjeta PCIe M.2 NGFF SSD Adapter LyCOM DT-120 + Samsung SM951 512GB M.2 Solid State Drive ( Ya no se vende nuevo )

https://www.amazon.es/LyCOM-DT-120-Interno-Adaptador-Interfaz/dp/B00MYCQP38

IMG-0173.jpg

Se instala sin necesidad de actualizar ni meter ningún Driver adicional Tanto en un Mac Pro 3.1 como en un 4.1 ( subido ó sin subir a 5.1 ) funcionando como disco de arranque dando unas velocidades de lectura/escritura muy buenas,

m2-512.png

Si utilizamos hardware de hoy, como pueden ser los ssd m.2, ya que los Samsung SM951 ya no se venden nuevos, podemos adquirir los Samsung 970 EVO - Disco Duro sólido de 1 TB por ejemplo, acompañado de un Angel Bird Wings PX1 SSD adaptador [PCI-e x4 - M 2. | NVME/compatible AHCE] - WPX1-FWKF,

https://www.amazon.es/gp/product/B01BLGO6N8/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

https://www.amazon.es/gp/product/B07CGJNLBB/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1

IMG-0172.jpg

Con los cuales mejoraremos algo la velocidad de lectura/escritura

m2-970-evo.png

En este caso la instalación es la misma, sin necesidad de instalar ningún tipo de Driver.

Espero sea de ayuda,

 

Un saludo.

 

 

Buenas Hacedor,

supongo que habrás pasado por todo esto ya y te agradecería me dieras un poco el norte porque me encanta esta máquina...tengo un problema con mi Mac Pro (ppios 2009) y es la actualización de Firmware EFI, que es una paso que tengo que dar para llegar a las actualizaciones más recientes. Actualmente lo tengo con Capitan. El error que me da es que dice que el esquema debe ser de GUID, lo compruebo en la SSD que me metieron y efectivamente es GUID. ¿Sabes que puede estar pasando? Te adjunto fotos del problema y las condiciones de las que aprto. MUCHISIMAS GRACIAS DE ANTEMANO.

Captura de pantalla 2019-01-08 a las 13.30.32.png

Captura de pantalla 2019-01-08 a las 13.20.36.png

Captura de pantalla 2019-01-08 a las 13.19.30.png

Captura de pantalla 2019-01-08 a las 13.07.16.png

Share this post


Link to post
Share on other sites

Buenas Manu, no te preocupes, no es perder el tiempo si con ello logras actualizar la EFI que es lo que estas intentando hacer, me equivoco?

Abre el que te mando, solo abrir no ejecutar, y una vez abierto ejecutas el Mac Pro 2009-2010 Firmware Tool.app, de esta manera no te dará fallo, cuando termines haz lo que procede, que si no recuerdo mal era apagar y mantener presionado encendido hasta que pite, no lo recuerdo muy bien ya que hace al menos tres años que lo hice, pero si que guardo los archivos, te los mando a continuación, y luego deja que termine el proceso de actualización de la EFI.

Captura-de-pantalla-2019-01-08-a-las-19-

Después de esto , yo actualizaría el sistema ya existente, El Capitán que veo que tienes, porque te volverá a actualizar la EFI de nuevo, desconozco si te dejara actualizar de golpe a Mojave o tenderas que hacerlo primero a High Sierra y luego a Mojave, como te digo van casi a actualización de EFI X actualización de sistema, increíble pero cierto.

Recuerdo que en algún momento intente hacer instalacion de cero con alguna de las actualizaciones y no me dejo porque no te hace la actualización del EFI de esta manera, con lo cual te toca volver a instalar el anterior y actualizar la EFI para luego volver a instalar de cero, manias mías jajajajajaajajajaja,

 

Ya me cuentas como lo llevas,

 

Un saludo

 

Los archivos, https://www58.zippyshare.com/v/WdsSyPth/file.html

 

PD: Te mando dos EFI, empieza por el MacProEFIUpdate1.5.dmg, si no te funciona sigo con el otro, creo que lo conseguí con el que te comento, como te digo hace mucho tiempo de ello.

Edited by Hacedor
  • Gracias 1

Share this post


Link to post
Share on other sites

Otro punto del que me acabo de acordar, nunca lo conseguí hacer desde El Capitán, desde Yosemite sin problema. 

 

Un saludo. 

Share this post


Link to post
Share on other sites

Wauuuu!!!! 

Desconocía estos foros, ¡que buen rollo! Muchísimas gracias, en serio. Al menos uno no se siente tan sólo en esto cuando todo el mundo se ríe que quieres seguir trabajando, en mi caso profesionalmente como fotógrafo, con una torre de estas. Yo no las cambiaba por nada.

He intentado lo que me dices, pero...mi gozo en un pozo...el Mac Pro 2009-2010 Firmware Tool.app dice que no puede abrirlo. A ver si puedo mandarte captura de pantalla.

Gracias,

Manu

p.d.: ¿como podría conseguir un instalador de Yosemite? No lo tienen en app store 😞

  • Me gusta 1

Share this post


Link to post
Share on other sites

¿¡Madre mia como lo has conseguido?! Ahí mismo he estado buscando yo. Voy a hacerme un pen y lo intento instalar. ¿sabrías porque cuando intento formatear la ssd no me deja ? me da un error, de hecho cuando hay que elegir los sitios de instalación no me aparece el disco ssd.

Share this post


Link to post
Share on other sites

Buenas Hacedor, estoy intentando hacer un usb boot (creo se dice asi) con el dmg del Yosemite del enlace que me has pasado, el problema es cuando le doy al arranque no me reconoce el pen y solo me salen los otros discos....

Share this post


Link to post
Share on other sites
Hace 4 horas, manupillo dijo:

Buenas Hacedor, estoy intentando hacer un usb boot (creo se dice asi) con el dmg del Yosemite del enlace que me has pasado, el problema es cuando le doy al arranque no me reconoce el pen y solo me salen los otros discos....

Utiliza el DiskMaker, la version que preceda, buscalo en google.

 

Un saludo.

Edited by Hacedor

Share this post


Link to post
Share on other sites
Hace 10 horas, manupillo dijo:

¿¡Madre mia como lo has conseguido?! Ahí mismo he estado buscando yo. Voy a hacerme un pen y lo intento instalar. ¿sabrías porque cuando intento formatear la ssd no me deja ? me da un error, de hecho cuando hay que elegir los sitios de instalación no me aparece el disco ssd.

Ni idea, como no des mas datos, ssd ó ssd m.2?

 

Un saludo.

 

PD: Aunque deveria dar igual el tipo de disco.

Share this post


Link to post
Share on other sites

Hola tengo un Mac Pro de 2009 4.1 a 5.1 dos procesadores con 6 nucleos a 3,33 ghz 64 de ram, soy músico y trabajo con el sistema os x capitan sobre todo porque mi tarjeta de audio no es compatible ya con sierra. Despues de leer estos mensajes me gustaria saber si me puedes ayudar a poner en mi equipo un sistema de almacenamiento ssd mvne m2, mi idea es despues de leer la descripcion de lo compatible comprar esta configuración:

Adaptador PCI    https://www.amazon.es/gp/product/B01FU9JS94/ref=crt_ewc_title_dp_2?ie=UTF8&psc=1&smid=A1AT7YVPFBWXBL    Un poco mas barato

 

SSD NVMe M2     https://www.amazon.es/gp/product/B07CGGP7SV/ref=ox_sc_act_title_1?smid=AYBQWG8LPKYUA&psc=1                               Menos capacidad y mas barato.

 

El adaptador no es el mismo y el disco es de 500 gb, te agradezco de antemano tu opinión y comentario y si no funcionara esta configuración me puedes asegurar que con mi equipo podria poner la opcion segunda? es decir samsung evo 970 con la tarjeta Angel Bird? recuerda que tengo capitan de osx y si podria arrancar sistema desde el nvme?. 

 

Muchas gracias

Share this post


Link to post
Share on other sites

Con esa tarjeta PCI no creo que tengas problemas, en el caso de que los tuvieras,  ya sabes que Amazon te deja devolverla por no compatibilidad, de todas formas yo compraría la Angel Bird, mas que nada porque es de fabricación nueva, rinde algo mas que las demás y alguna que otra compatibilidad, y esto te lo digo por experiencia propia.

Respecto al ssd m.2 970 EVO tampoco tendrás problema, lo único que debes tener en cuenta es que tengas la Versión de ROM de arranque 127.0.0.0.0, porque de lo contrario no podrás usar el 970 EVO como HDD de arranque, y que me corrija alguien si me equivoco, para ello tendrás que actualizar a Mojave si no recuerdo mal, para después volver a instalar El Capitan.

 

Un saludo.

 

PD: Si tienes alguna duda mas, ya sabes.

Edited by Hacedor
  • Me gusta 2

Share this post


Link to post
Share on other sites

Vaya que suerte tener alguien como tu por aqui, me estan liando queriendome vender un toshiba xg5 con una tarjeta pcie concretamente esta:

https://www.amazon.com/PCI-Express-NVME-Riser-Adapter/dp/B07GSVXFGQ que opinas? funcionaria? pero me fio mas de tu opinion solo me gustaria saber si podria utilizar la samsumg con el angel bird para solo almacenamiento aunque tambien creo que si utilizara la opcion de arranque ganaria velocidad en el sistema no?, mi gran dilema es utilizar el nvme de sistema? o de almacenamiento? tu que opinas? con cual te quedarias? seria muy dificil cambiar mi version de arranque? ya que no coincide y sin perder mis aplicaciones etc? (te adjunto foto del sistema) Vaya creo que estoy abusando de ti, es todo un interrogatorio.......jajajaja. Creo que la gente solo quiere vender y no le importa como te vaya luego, en tu caso se que me vas a aconsejar lo mejor para mi y para que mi sistema rinda mas y mejor, gracias amigo. Un millon de gracias Hacedor.

INFO HARDWARE.jpg

Share this post


Link to post
Share on other sites

Bajo mi punto de vista, si no utilizas la m2 para algo que no sea arranque, no tiene mucho sentido, no crees? Arriba tienes capturas mías con las velocidades de lectura escritura, la m2 es para trabajar, que lo quieres utilizar para almacenamiento? tu mismo, es una gran perdida de recursos jajasajajajajajaja.

Para actualizar tu version de ROM de arranque es sencillo, actualizas primero a Mojave y luego vuelves a El Capitan, como te indico mas arriba, la ROM de arranque no te va a incidir en los programas que utilizas ahora, utilizando El Capitan claro, recuerdo que comentaste que tales programas ya no corrían en Mojave, y la ROM de arranque es la que te va a dejar utilizar el 970 EVO para iniciar el OS.

 

Un saludo.

 

PD: Yo utilizaría la Angel Bird junto con el 970 EVO Para arranque.

Edited by Hacedor

Share this post


Link to post
Share on other sites

Muchas gracias Hacedor seguiré tus consejos para sacarle el máximo partido al Mac Pro. Bueno parece que ya voy por buen camino, o eso creo, ya he actualizado a Mojave y se ha actualizado la EFI, he instalado desde Capitán a sierra, a High Sierra y finalmente a Mojave que precisamente justo antes de instalarlo da unas indicaciones para llevar a cabo la actualización,  (solo mantener pulsado el botón de encendido hasta oír el pitido) y ya se actualiza e instala Mojave, una pregunta, debia ser exactamente 127.0.0.0.0 la version de arranque? porque a mi me sale 140.0.0, (adjunto foto) he visto varias versiones de Mojave pero algunas no descomprimían  bien los archivos y esta iba bien, si debe ser la 127.0.0.0.0 como saber la versión exacta de Mojave? en cuanto sepa esto hago el pedido. Gracias de nuevo.

 

 

2143486643_VersiondelaROMdearranque2.jpg.dfe2b26f05823e6b0bb4791d4cb0914b.jpg

Share this post


Link to post
Share on other sites

Entiendo que la version de Mojave la tienes actualizada a 10.14.3, pues no entiendo muy bien porque te da esa ROM, si hay alguien mas que nos lee y quiere iluminarnos, tanto en mi ex como en el nuevo tengo la 127.0.0.0.0

Captura-de-pantalla-2019-02-26-a-las-12-

 

Entiendo que no deverias tener problemas.

 

Un saludo.

Share this post


Link to post
Share on other sites

La actualización que he hecho a Mojave es la 10.14.2 no la 10.14.3 quizás sea ese el problema?, si hubiera sabido la versión exacta.......lo raro es que cuando instelé Mojave salia 140.0.0.0.0 y al poner Capitán sale 140.0.0 le quita dos ceros, puedo intentar buscar la 10.4.3 y actualizar pero entiendo que 140.0.0.0.0 es mayor digito que 127.0.0.0.0 no se que hacer pero como dices no debería fallar no?

Share this post


Link to post
Share on other sites

No entiendo porque tienes que buscar en la red cuando puedes hacer la descarga des la App Store, descárgate la oficial de la propia tienda y luego le das a que busque actualización.

 

Un saludo.

Share this post


Link to post
Share on other sites

Hola, he estado liadillo pero te cuento, una vez instalada la versión high sierra 10.3.6 de la app store y teniéndola instalada no me deja instalar después mojave 10.14.3 dice que tengo que tener instalada la version 10.14 pero no la encuentro en la app store, he intentado con otras versiones como 10.14 1b etc de mojave pero me dice que no se puede instalar en mi equipo, no se que hacer para conseguirlo le he echado mucho tiempo he probado de todo y nada y el caso es que una vez lo hice, eso si llegué hasta la 10.14.2 pero al reiniciar desde el disco con Capitan ya no se mostraba el disco con Mojave y no podia arrancar puesto que en disco de arranque desde preferencias del sistema no existia con lo cual tuve que borrarlo desde utilidad de discos y volverlo a formatear, (borrar). Mi propósito para el disco nvme es leer librerias de sonido muy pesadas por eso te decia que lo queria para almacenamiento, osea cargar y leer samples de audio de orquestaciones y baterias con muchas capas de muestras por eso necesito una lectura rápida para trabajar porque se me cuelgan a veces los programas. En fin te agradezco no obstante tu ayuda.

 

Saludos

Share this post


Link to post
Share on other sites

Hola,

Respecto a la versión de la BootROM de nuestros cMP 5,1 y la compatibilidad con el arranque desde unidades NVMe, según este hilo de MacRumors, es a partir de la versión 140.0.0.0.0.0 cuando es posible arrancar desde unidades NVMe. Con versiones anteriores no es posible.

El autor del hilo indica que esta versión de la BootROM se liberó con Mac OS X 10.14.1 y se mantiene con las actualizaciones 10.14.2 y 10.14.3. También indica que los cMP 5,1 no instalan firmware automaticamente como otros Mac ("but remember that Mac Pro 5,1 don't install firmwares automatically with updates like every other Mac") aunque en mi caso la actualización a Mac OS X 10.14.1 si actualizó la BootROM a la versión 140.0.0.0.0.0

Voy a ver cómo están los precios para instalar una unidad NVMe de arranque 😁

Saludos.

Alberto

Edited by horkonpon

Share this post


Link to post
Share on other sites

Parece q la angel bird esta descatalogada. Alguna sustituta actual??


Enviado desde mi iPhone utilizando Tapatalk

Share this post


Link to post
Share on other sites

Hola a todos,

Por añadir información al tema  a partir de mi experiencia.

Encargué en Amazon la tarjeta Lycom DT-120 y el NVMe Samsung 970 EVO PRO. Abro el Mac Pro 4,1 (subido a 5,1 con Mac OS X Mojave y BootRoom 140.0.0.0,0) e instalo la tarjeta con el NVMe y empiezan los problemas nada más inicializar el disco. Es incapaz de inicializarlo (en ningún formato), comienza todo el proceso pero no lo acaba ni en 5 minutos, ni en 10, ... ni en 25 minutos. Se queda bloqueado. Vale, cierro la utilidad de discos y apago el Mac Pro ... ¡y no se apaga! se queda bloqueado y he de apagarlo manteniendo pulsado el botón de encendido.

¡Venga! ¡Que no cunda el pánico! Reinicializo la PRAM y la NVRAM y vuelvo a empezar. Lo mismo, Utilidad de discos no es capaz de acabar la inicialización de la unidad NVMe y no puedo apagar ni reiniciar el Mac Pro por si solo sin apretar durante unos segundos el botón de encendido para apagarlo.

Sigo con las pruebas. Arranco con la unidad Bootcamp (Windows 7) y ahora si funciona. Puedo iniciar el disco, formatearlo y acceder a él. apago el sistema y sin problemas. Inicio en Mac OS X y vuelta a las andadas, no puedo formatear, borrar o inicializar el disco NVMe y no puedo apagar o reiniciar el Mac Pro porque se queda bloqueado.

Decido eliminar la tarjeta de vídeo (AMD Radeon R280X flasheada) y volver a la tarjeta de vídeo original y elimino la tarjeta PCIe para los discos SSD (Highpoint Rocket 640L) y se repite el mismo comportamiento, con Windows funciona correctamente (con velocidades de lectura/escritura rondando los 1.500 Mb) pero con Mac OS X no funciona y bloquea el apagado/reinicio del Mac Pro.

Devolví la tarjeta y el disco y me quedé con las ganas de arrancar mi Mac Pro a toda pastilla.

Se agradecerá cualquier sugerencia o información que permita instalar y funcionar con un NVMe en mi Mac Pro.

Saludos

Alberto

Edited by horkonpon

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.