Jump to content
Sign in to follow this  
felipus

Problema curioso con SSD en macbook pro 2012

Recommended Posts

TL;DR Macbook pro 2012 no reconoce discos duros sólidos internos pero si por USB.

Hola! Primero la historia.

Hace 7 meses le instalamos a una macbook pro 2012 (la ultima con DVD) un disco solido WD Blue de 500 GB. Y hace un par de meses instalamos windows 10 con bootcamp. Hace 3 dias usando photoshop en Mac OS Mojave (actualizado al dia) cerraron el monitor para continuar después y al abrirlo aparecía un mensaje de windows que decía que no había disco de sistema y presionar ctrl+alr+supr. Al momento de arrancar y presionar alt para seleccionar SO no aparecía nada. Solo el lugar donde se selecciona red.

Intente reparar el disco desde una memoria usb con la instalación de mojave. Error.  Intente leer el disco desde otra macbook y la del problema con un cable thunderbolt y el modo target. Nada.

La abro y saco el disco. Lo pongo en una carcasa usb, lo conecto a la segunda macbook pro, arranco con alt, y aparece, lo selecciono y funciona a la perfección. Hago respaldo, y lo clono con super duper a otro SSD.

Formateo en windows el SSD de la macbook 2012. lo conecto y lo reconoce la utilidad de discos como NTFS o exFAT. Particiono y me dice que solo como APFS, lo hago y todo parece correcto. Al momento de instalar MacOS se apaga al faltar 2 minutos. Lo intento 2 o 3 veces.

Pienso que el disco esta mal e intento instalar MacOS con otro disco SSD marca Adata. Lo mismo... Se apaga al faltar 2 minutos. Lo mismo con high sierra.

Entonces, encontramos el disco duro original que le sacamos hace 7 meses. Lo instalo en la mac, la encendemos y arranca como si nada.
Para este momento está como venia de fabrica. Nada de SSD.
Hago un respaldo de time machine. Lo clono de nuevo con superduper, al SSD sin problemas, cambio discos y la maquina simplemente no ve el SSD como booteable. Lo saco de nuevo, lo pongo en la carcasa usb y con alt aparece como si nada, y arranca incluso mas rapido que el disco interno.

Intente restaurar lo que tenia de time machine con el SSD instalado y error.

Entonces estoy asi: La macbook del 2012 simplemente no ve los discos SSD después de formatearlos y particionarlos como APFS desde la utilidad de discos, Si es un clon del disco interno si los ve y arrancan a la perfeccion por USB.

Que pasa? APFS no era especialmente hecho para discos sólidos? NO deberia arrancar como si nada si he clonado el disco?

Porque los sólidos no los "ve" si están instalados internamente pero si los ve su están por USB?

Por que el disco viejo normal lo encuentra sin problemas y arranca?

Lo unico que alcance a ver era un error que decia que el volumen APFS no se puede convertir a APFS o algo asi. Tambien intente borrando PRAM,  usar el modo single user, y un monton de cosas mas. Estoy harto!!

Alguna idea? Gracias

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.