Jump to content
marccfit

Macbook pro se reinicia solo

Recommended Posts

Posted (edited)

Hola buenas a todos, me presento soy Marc.

Antes de postear, he utilizado el buscador pero o bien no he sabido buscar o el tema no está.

Tengo un macbook pro de 2017 2,3ghz core i5, 8gb ram con Sierra 10.12.6

Hasta ahora el ordenador iba muy bien, pero de repente se paga y reinicia automáticamente, y cuando vuelve a arrancar sale la famosa pantalla en negro que se ha reiniciado o apagado a causa de un problema. He buscado información, y en apple he encontrado que podría ser debido a "fallo de kernel", pero no tengo ni idea de que puede ser, ni que está fallando ni nada.

Como navegador utilizo opera, y tampoco tengo programas instalados que pudieran dar problemas.

Si algún compañero puede ayudarme para saber qué pasa, o si tengo que ir al servicio de apple, lo agradecería mucho.

 

Un saludo!

Edited by Josemy

Share this post


Link to post
Share on other sites

Después de un reinicio de esos, abre Terminal y escribe (o copia y pega) esto:

log show --predicate 'eventMessage contains "Previous shutdown cause"' --last 1h

...a ver si nos da información relevante. Aquí, por ejemplo, tienes el significado de los códigos que pueden salir como respuesta.

Share this post


Link to post
Share on other sites
Hace 4 minutos, mock turtle dijo:

Después de un reinicio de esos, abre Terminal y escribe (o copia y pega) esto:


log show --predicate 'eventMessage contains "Previous shutdown cause"' --last 1h

...a ver si nos da información relevante. Aquí, por ejemplo, tienes el significado de los códigos que pueden salir como respuesta.

Muchísimas gracias de verdad  mock turtle 

He hecho lo que me has dicho, y me aparece esto:

MBP-de-Marcus:~ marcferrergomez$ log show --predicate 'eventMessage contains "Previous shutdown cause"' --last 1h

Skipping info and debug messages, pass --info and/or --debug to include.

Filtering the log data using "eventMessage CONTAINS "Previous shutdown cause""

 

Timestamp                       Thread     Type        Activity             PID    

2019-08-05 14:29:50.844762+0200 0x3ba      Default     0x0                  0      kernel: (AppleSMC) Previous shutdown cause: 5

2019-08-05 14:49:42.418393+0200 0x31e      Default     0x0                  0      kernel: (AppleSMC) Previous shutdown cause: 5

 --------------------------------------------------------------------------------------------------------------------

Log      - Default:          2, Info:                0, Debug:             0, Error:          0, Fault:          0

Activity - Create:           0, Transition:          0, Actions:           0

MBP-de-Marcus:~ marcferrergomez$ 

MBP-de-Marcus:~ marcferrergomez$ 

Share this post


Link to post
Share on other sites

Justo ahora mismo se ha vuelto a reiniciar, y sale esto:

Last login: Mon Aug  5 17:06:56 on ttys000

MBP-de-Marcus:~ marcferrergomez$ log show --predicate 'eventMessage contains "Previous shutdown cause"' --last 1h

Skipping info and debug messages, pass --info and/or --debug to include.

Filtering the log data using "eventMessage CONTAINS "Previous shutdown cause""

Timestamp                       Thread     Type        Activity             PID    

2019-08-05 16:55:14.611063+0200 0x302      Default     0x0                  0      kernel: (AppleSMC) Previous shutdown cause: 5

2019-08-05 17:05:50.959225+0200 0x34d      Default     0x0                  0      kernel: (AppleSMC) Previous shutdown cause: 5

 --------------------------------------------------------------------------------------------------------------------

Log      - Default:          2, Info:                0, Debug:             0, Error:          0, Fault:          0

Activity - Create:           0, Transition:          0, Actions:           0

MBP-de-Marcus:~ marcferrergomez$ 

MBP-de-Marcus:~ marcferrergomez$ 

 

Share this post


Link to post
Share on other sites
Posted (edited)
Hace 16 horas, mock turtle dijo:

Nos quedamos como estábamos: el sistema no reconoce ningún suceso anómalo. Prueba con un reset de SMC: https://support.apple.com/es-es/HT201295

¿Te ocurre lo mismo con el Mac conectado a la corriente o tirando de batería?

 

Buenos días mock turtle, una vez más muchísimas gracias por tu ayuda, no sabes cuanto te lo agradezco.

 

Acabo de hacer el reset de SMC tal como explica el link que me has dado. A ver si tengo suerte y no vuelve a reiniciarse. Tanto si se me reinicia o no, te vuelvo escribir para contarte las novedades.

Creo que solo me ha pasado cuando ha estado solo con la batería.

Aprovechando la ocasión, el macbook pro lo llevo con Sierra, y por aquello de no querer actualizar a otro OS, hace mucho tiempo que me salía la opción de subir a macOS High Sierra, de hecho tengo el instalador en aplicaciones. Me recomiendas quedarme como estoy con Sierra, o hacer upgrade a High Sierra u otro, teniendo en cuenta que mi macbook pro es súper básico (2017,  2,3ghz core i5, 8gb ram 120gb flash con Sierra 10.12.6)

Muchas gracias de nuevo compañero!!

 

Edited by marccfit

Share this post


Link to post
Share on other sites

al menos que uses algún programa que nos sea compatible podrías subir a Mojave directamente

Share this post


Link to post
Share on other sites
Posted (edited)

Por descartar otras causas ¿Tienes conectado algún periférico a tu macbook pro?

Coincide el reinicio con alguna aplicación no nativa abierta?

 

Edited by lofercan

Share this post


Link to post
Share on other sites

Si no hay nada significativo a destacar conviene realizar un arranque seguro, que en muchos casos logra resolver el problema. Para hacerlo tan solo hay que apagar el Mac (si es necesario, forzándolo), y volver a encenderlo manteniendo pulsada la tecla Mayúscula. Esto permite cargar los requerimientos básicos del sistema seguir comprobando

Share this post


Link to post
Share on other sites
Hace 13 horas, lofercan dijo:

Por descartar otras causas ¿Tienes conectado algún periférico a tu macbook pro?

Coincide el reinicio con alguna aplicación no nativa abierta?

 

Hola @lofercan, muchas gracias por tu ayuda.

No tengo conectado nada, y la única aplicación no nativa que utilizo es el navegador Opera.

He probado de encenderlo como indicas, manteniendo la tecla mayúscula, y cuando ya he iniciado me daba como pantallazos, como si la pantalla tuviera interferencias, he apagado y vuelto a arrancar.

Creo que coincide los reinicios cuando estoy tirando con la batería y no lo tengo conectado a la red.

 

Muchas gracias por tu ayuda, un saludo!

Share this post


Link to post
Share on other sites

Hola... 🙂

 

¿Has probado a pasar alguna utilidad de comprobación del estado de tu batería?

Prueba por ejemplo con "CoconutBattery", a ver si te dice algo clarificador.

 

Saludos,

Manolo

Share this post


Link to post
Share on other sites
Hace 7 minutos, Manolitto dijo:

Hola... 🙂

 

¿Has probado a pasar alguna utilidad de comprobación del estado de tu batería?

Prueba por ejemplo con "CoconutBattery", a ver si te dice algo clarificador.

 

Saludos,

Manolo

Hola @Manolitto, muchas gracias por tu ayuda.

Acabo de probar lo de la batería y he hecho una captura.

Muchas gracias, un saludo!

Captura de pantalla 2019-08-07 a las 10.56.43.png

Share this post


Link to post
Share on other sites

Hola... 🙂

 

Se lo he pasado a mi MBPro de 2012 y la única cosa en la que difieren claramente es en la tasa de descarga. El tuyo marca 8,04W mientras que el mío marca 26,05W. A ver si es que está descargando poco por alguna causa interna y por eso se te apaga. No digo que sea esa la causa, pero habría que valorarlo comparando con otros equipos además del mío.

1968493722_Capturadepantalla2019-08-07alas11_19_47.png.4e415df66b924ff69e8d71451d32842b.png

¿Algún voluntario con MBPro para poder comparar?

 

Saludos,

Manolo

Share this post


Link to post
Share on other sites

@Manolitto Tenias muchas aplicaciones abiertas o periféricos conectados al ejecutarlo?

Ignoro los valores “buenos” pero en las imágenes que aparecen al buscar resultados, entre las que aparece este dato y no son de iPhones predominan los valores sobre los 10W, creo que el más alto estaba en 16W. Si los damos por buenos sus 8W parecen normales y tus 26W excesivos.

  • Me gusta 1

Share this post


Link to post
Share on other sites
Posted (edited)
Hace 9 horas, Manolitto dijo:

¿Algún voluntario con MBPro para poder comparar?

Ahí van mis datos en un equipo igual que el de Marc. No creo que el problema sea la tasa de descarga pues ya veis el mío la que tiene y va como la seda

1435732351_Capturadepantalla2019-08-07alas20_38_14.thumb.png.1e6a0b9197079732402619b6e03825f9.png

 

Habrá que seguir investigando otra causa. También te comento que no entiendo qué ocurre al iniciar en modo seguro pues no debería dar esas "interferencias" de las que hablas. ¿No te da ningún mensaje?

Edited by lofercan
  • Me gusta 1

Share this post


Link to post
Share on other sites

Por cierto ¿Tienes el disco duro encriptado con FileVault?

  • Me gusta 1

Share this post


Link to post
Share on other sites

Por seguir descartando cosas, no sé si sabes que hay un plan de reemplazo de baterías para algunos de estos equipo por venir defectuosas. Te pongo el enlace y podrás comprobar si tu serial está dentro de los posibles equipos afectados

 

  • Me gusta 1

Share this post


Link to post
Share on other sites
Hace 14 horas, lofercan dijo:

Ahí van mis datos en un equipo igual que el de Marc. No creo que el problema sea la tasa de descarga pues ya veis el mío la que tiene y va como la seda

1435732351_Capturadepantalla2019-08-07alas20_38_14.thumb.png.1e6a0b9197079732402619b6e03825f9.png

 

Habrá que seguir investigando otra causa. También te comento que no entiendo qué ocurre al iniciar en modo seguro pues no debería dar esas "interferencias" de las que hablas. ¿No te da ningún mensaje?

Hola @lofercan, buenos días y muchas gracias por tu ayuda. Cuando inicie en modo seguro me daba esos "pantallazos e interferencias", además me cambió el color de la interfaz del dock, así que apagué el equipo, volví a encender y ya no tenía nada de eso, la verdad que todo muy raro

Hace 13 horas, lofercan dijo:

Por cierto ¿Tienes el disco duro encriptado con FileVault?

Ostras, ahí me pierdo, no tengo ni idea. Creo que no.

Hace 13 horas, lofercan dijo:

Por seguir descartando cosas, no sé si sabes que hay un plan de reemplazo de baterías para algunos de estos equipo por venir defectuosas. Te pongo el enlace y podrás comprobar si tu serial está dentro de los posibles equipos afectados

 

Acabo de probar, pero mi serial no es válido.

La verdad es que no tengo ni idea de por qué ahora de repente me pasa esto de los reinicios. De hecho el uso que le doy es muy muy básico y nada de cosas extrañas, si que es cierto que alguna vez  si que he notado que el ordenador se calentaba y los ventiladores se encendían y volvía a temperatura normal. El único programa que utilizo es para navegar el Opera, y alguna vez el rekodbox que es de pioneer, pero hace mucho que ni lo abro. Aunque esto posiblemente sea lo de menos.

Y por último si que me ha pasado que dos veces que he tenido reinicios, al apretar para encender no arrancaba y he tenido que mantener el botón de encendido presionado 10 segundos y luego volver a apretarlo para que arranque.

 

Agradezco muchísimo toda la ayuda que me estáis dando compañeros, no sabéis cuanto lo agradezco.

  • Me gusta 1

Share this post


Link to post
Share on other sites
Hace una hora, marccfit dijo:

Ostras, ahí me pierdo, no tengo ni idea. Creo que no.

Preferencias del Sistema>Seguridad y privacidad>Filevault

 

Los pantallazos al iniciar el modo seguro ¿no serian reinicios constantes?

En  https://support.apple.com/es-es/HT201262  :

Citar

Si el Mac se reinicia constantemente o se apaga mientras está en modo seguro, ponte en contacto con el Soporte técnico de Apple, o consulta con un Proveedor de servicios autorizado Apple o un Apple Store para recibir ayuda.

 

Share this post


Link to post
Share on other sites
Hace 1 minuto, APB dijo:

Preferencias del Sistema>Seguridad y privacidad>Filevault

 

Los pantallazos al iniciar el modo seguro ¿no serian reinicios constantes?

En  https://support.apple.com/es-es/HT201262  :

 

Hola @APB, muchas gracias por tu respuesta y ayuda.

Pues me dice que FileVault está activado para el disco "Macintosh HD"

Hace 1 minuto, APB dijo:

Preferencias del Sistema>Seguridad y privacidad>Filevault

 

Los pantallazos al iniciar el modo seguro ¿no serian reinicios constantes?

En  https://support.apple.com/es-es/HT201262  :

 

Me temo que al final tendré que ir a pedir cita a apple. Mi mayor temor es que vaya y acaben por la rápido, que formateen, me cambien el Sierra por el Mojave y luego que vuelva a tener estos reinicios. 

Muchas gracias por tu ayuda compañero. 

Un saludo!

Share this post


Link to post
Share on other sites

He leído que en algún momento del arranque seguro pueden producirse "pantallazos", supongo que no deben ser muchos, por lo que mejor asegúrate si son reinicios o son esos posibles "pantallazos" antes de pasar por el SAT.

¿Fueron muchos o muy seguidos o al segundo o tercero te asustaste y apagaste el Mac? Las pocas veces que lo he hecho no recuerdo que el mío me haya flasheado.

  • Me gusta 1

Share this post


Link to post
Share on other sites
Hace 2 horas, marccfit dijo:

Cuando inicie en modo seguro me daba esos "pantallazos e interferencias", además me cambió el color de la interfaz del dock, así que apagué el equipo, volví a encender y ya no tenía nada de eso, la verdad que todo muy raro

Tienes que intentar arrancar en modo seguro y si arrancas y siguen los reinicios me temo que deberás ponerte en contacto con Apple Support por si te indican alguna sugerencia que no te hayamos indicado.

El tema de la encriptación por File Vault es que se han dado algunos casos, hace poco en el foro, que esta fórmula para proteger los datos del disco duro tiene su incidencia si hay algún sector del disco dañado pues, resumiendo,  no le deja arrancar, pero sería la última opción ya que tardarías una eternidad en desencriptarlo.

Respecto alelan de sustitución de batería no entiendo porqué te dice que el serial no es válido. Te indicará algo más no?, que no está dentro del rango de los posibles equipos dañados, que ya se ha cambiado... no sé alguna información te debería dar.

Tú estás arrancando en modo seguro siguiendo las instrucciones no? Arrancar con tecla mayúscula pulsada y una vez que sale manzana, soltar dicha tecla.

  • Me gusta 1

Share this post


Link to post
Share on other sites
Hace 18 minutos, APB dijo:

He leído que en algún momento del arranque seguro pueden producirse "pantallazos", supongo que no deben ser muchos, por lo que mejor asegúrate si son reinicios o son esos posibles "pantallazos" antes de pasar por el SAT.

¿Fueron muchos o muy seguidos o al segundo o tercero te asustaste y apagaste el Mac? Las pocas veces que lo he hecho no recuerdo que el mío me haya flasheado.

Muchas gracias @APB, pues te cuento. Cuando arrancó hizo como extraños, y luego daba esos "pantallazos" de forma aleatoria, además de que estuve un rato, abrí el navegador y seguían y luego me di cuenta que la apariencia del dock y la del navegador eran diferentes. Habían cambiado los colores. Entonces ya apagué de forma segura y volví a encenderlo.

Hace 6 minutos, lofercan dijo:

Tienes que intentar arrancar en modo seguro y si arrancas y siguen los reinicios me temo que deberás ponerte en contacto con Apple Support por si te indican alguna sugerencia que no te hayamos indicado.

El tema de la encriptación por File Vault es que se han dado algunos casos, hace poco en el foro, que esta fórmula para proteger los datos del disco duro tiene su incidencia si hay algún sector del disco dañado pues, resumiendo,  no le deja arrancar, pero sería la última opción ya que tardarías una eternidad en desencriptarlo.

Respecto alelan de sustitución de batería no entiendo porqué te dice que el serial no es válido. Te indicará algo más no?, que no está dentro del rango de los posibles equipos dañados, que ya se ha cambiado... no sé alguna información te debería dar.

Tú estás arrancando en modo seguro siguiendo las instrucciones no? Arrancar con tecla mayúscula pulsada y una vez que sale manzana, soltar dicha tecla.

Muchas gracias @lofercan. He probado de ponerme en contacto con apple vía chat y telefónica, pero no me entra ya ése servicio.

Con la batería me dice lo siguiente:

 El número de serie introducido no es apto para este programa por uno de estos motivos:
- No se encuentra entre los números de serie afectados.
- Nuestros registros indican que la batería ya se ha reemplazado.
- Nuestros registros indican que ya no es apto para un reemplazo gratuito en este programa. Si tienes alguna pregunta, ponte en contacto con Apple.

 

Al final tendré que pedir cita a apple, pero no me da mucha confianza, puesto que con un imac tuve un problema y se limitaron a actualizar el macOS y tengo miedo a que ahora me ocurra lo mismo, que lo formateen, suban a Mojave y me digan que está bien y me vuelva a pasar. Igual es manía mía y no debería se así.

 

Una vez muchas gracias por todo vuestro tiempo y ayuda compañeros qué grandes sois!!

Un saludo!

  • Me gusta 1

Share this post


Link to post
Share on other sites
Posted (edited)

Si te pasaba mientras lo usabas en modo seguro, no mientras arrancaba, y todo seguía igual después del pantallazo no era ningún reinicio “camuflado” por lo que esa recomendación de la web de Apple no te afecta.

Aunque si nadie da con la “tecla” igualmente deberás acudir a un SAT. ¿Tienes una AppleStore cerca o acudes a un centro autorizado? Como tienes tan poca confianza en ellos tal vez sea mejor cambiar de SAT.

Edited by APB

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.