Jump to content
Cylon

¿Cuanto me durará un Mac Mini del 2014 a nivel actualizaciones del SO?

Recommended Posts

Estimados foreros, necesito vuestro consejo.

Soy programador desde hace 20 años, en los últimos años trabajo bastante desarrollando para Android, y tengo ganas de aprender desarrollo nativo de iOS.

Asi que me veo en la tesitura de tener que comprar un Mac, ya que al contrario que Android, solo puedes desarrollar para iOS si tienes un Mac.

Mi presupuesto no da para comprarme un Mac nuevo ni de coña. Bueno podría permitirme comprarme uno nuevo, pero solo voy a desarrollar para aprender, y tardaré un par de años en sacarle rendimiento económico a las apps que desarrolle, así que en mi forma de contemplar las cosas, no me voy a gastar el dinero que cuesta un mac nuevo, para algo a lo que no le sacaré rendimiento a medio plazo.

Asi como estan las cosas, me podria permitir un Mac Mini del año 2014. He estado trasteando con los que tienen los desarrolladores iOS en la oficina, y aunque los hay muy modernos, me apaño bastante bien con un Mac Mini con 16Gb de ram, 256ssd e I7 2,6Ghz. Todo lo que tenga esas caracteristicas, o superiores me vale. Aunque desconozco si un I5 es muchiiiisimo mas lento que un i7, pero igual tambien podria valer.

Tambien entra en el rango de precio de lo que me quiero gastar, buscando uno de segunda mano (unos 550-700€ maximo).

Lo unico que me preocupa, es cuanto tiempo los mac mini 2014 seran capaces de recibir  actualizaciones del sistema operativo, y aqui es donde necesito vuestro consejo. Para desarrollar apps para las ultimas versiones de smartphones iOS, hay que tener siempre la ultima version de Xcode, y para este, la ultima version del sistema operativo macOs.  Ahora mismo con este mac del 2014 todo funciona aceptablemente, pero me preocupa que a lo mejor no sea capaz de recibir la actualizacion del año que viene, o la de dentro de dos años. La de dentro de tres años me preocupa menos. Si dentro de tres años sigo programando para iOS, entonces ya me compraré un equipo decente/actual.

 

He preguntado a los compañeros de la oficina, pero todos me proponen que me compre equipos de 2000-3000€, y vaya hombre, solo quiero desarrollar unas apps en mi tiempo libre para familiarizarme con el entorno. No son capaces de ponerse en mi lugar.

Agradezco vuestras opiniones, y si alguno quiere vender un equipo de estas características, podemos hablarlo.

 

Saludos,

 

Cylon.

Share this post


Link to post
Share on other sites

Este año veremos si los mac del 2012 queda afuera o no, por lo que tu Mac mini mínimo debería quedarle 3 o 4 años mas de actualizaciones del macOS.

Share this post


Link to post
Share on other sites
Hace 52 minutos, Cylon dijo:

Cuando se sabe eso seguro?

Cuando Apple presente su nuevo MacOS e incluya tu modelo entre los no actualizables. Seguro que no es lo que querías oír pero es lo que hay.

Como te comenta richy85, este año aún no se sabe si los del 2012 quedarán fuera, se sabrá en junio en la WWDC 2020 cuando presenten la nueva versión que saldrá en octubre. Habitualmente cada año avanzan la incompatibilidad del MacOS un año pero no siempre es así. El año pasado dejaron fuera a los del 2011: https://support.apple.com/es-es/HT210222

Con HS se pudo actualizar Xcode hasta que salió Catalina. Entre HS y Catalina está Mojave. Si siempre fuera así podrías seguir programando con la última versión de Xcode un año más.

Share this post


Link to post
Share on other sites
Hace 5 horas, Cylon dijo:

me apaño bastante bien con un Mac Mini con 16Gb de ram, 256ssd e I7 2,6Ghz. Todo lo que tenga esas caracteristicas, o superiores me vale. Aunque desconozco si un I5 es muchiiiisimo mas lento que un i7, pero igual tambien podria valer.

Yo me muevo con un mini 2014 con el i5 2.6, 16Gb y 256 de SSD más otro disco SSD que le puse en el hueco.

No creo que te varíe mucho del i5 mío al i7 dentro de los de esa serie, el que montaban en 2014 era el i7-4578U a 3.0Ghz de doble núcleo y 4 hilos y el de 2012 el i7-3720QM a 2,6Ghz de 4 núcleos y 8 hilos

Yo sigo contento con el cacharro pero claro, no es el uso que le vas a dar tú.

Lo que viendo el precio que puedes pillar uno como el mío de segunda mano, no se si convendría buscar uno de 2018 con el i3 8100, que siendo de 4 núcleos lo mismo hasta se mueve mejor que el antiguo i7

Saludos!!

Share this post


Link to post
Share on other sites
Hace 8 horas, APB dijo:

Como te comenta richy85, este año aún no se sabe si los del 2012 quedarán fuera, se sabrá en junio en la WWDC 2020 cuando presenten la nueva versión que saldrá en octubre. Habitualmente cada año avanzan la incompatibilidad del MacOS un año pero no siempre es así. El año pasado dejaron fuera a los del 2011: https://support.apple.com/es-es/HT210222

Con HS se pudo actualizar Xcode hasta que salió Catalina. Entre HS y Catalina está Mojave. Si siempre fuera así podrías seguir programando con la última versión de Xcode un año más.

Si no me equivoco, el salto lo están haciendo cada 2 años, es decir cada 2 años dejan afuera un año. Por ejemplo High sierra puede actualizar lo mismo que el predecesor Sierra. y en Catalina puede actualizar lo mismo que había hecho Mojave

A menos que lo cambien, este año veríamos afuera 2012 (ojalá que no ya que tengo una)

Share this post


Link to post
Share on other sites
Hace una hora, richy85 dijo:

Si no me equivoco, el salto lo están haciendo cada 2 años, es decir cada 2 años dejan afuera un año. Por ejemplo High sierra puede actualizar lo mismo que el predecesor Sierra. y en Catalina puede actualizar lo mismo que había hecho Mojave

Tienes razón en los saltos bianuales pero como en cada salto dejan fuera a más de un año (en HS los iMac cortan en 2009 y en Mojave en 2012; los mini del 2010 al 2012) el resultado final termina siendo el mismo.
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.