Jump to content
iLike

Necesito obtener High Sierra para actualizar desde Sierra [SOLUCIONADO]

Recommended Posts

Posted (edited)

Buenos días, tengo el Mac Mini de la firma, con Mac OS Sierra 10.12.6

 

Necesito actualizar a High Sierra, que es el último SO que permite mi máquina y desde hace tiempo Apple no da soporte a Sierra.

Cuando salió High Sierra me descargué la imagen dmg oficial de High Sierra (tal como hice en otras ocasiones de la App Store y me guardé el instalador) y estaba correcta cuando la descargué, ya que comprobé que iniciaba correctamente. No obstante, hoy me he decidido a instalar High Sierra desde Sierre, y al abrir el dmg de High Sierra comenta que está "dañada" y que no es posible utilizarla.

 

- He buscado en la web de Apple y lo que hay son las actualizaciones (incluso combinadas) de High Sierra, pero no he logrado encontrar el DMG completo de High Sierra.

- El artículo de Apple Cómo actualizar a macOS High Sierra, indica la posibilidad de descargarlo desde la App Store (apartado 4), pero al darle al link éste no hace nada.

He dejado pasar un rato y he vuelto a probar a obtener High Sierra (apartado 4 --> "Si todavía necesitas macOS High Sierra, usa este enlace a App Store: Obtener macOS High Sierra."), y ahora me abre itunes dando un mensaje informativo comentando que "El artículo que has solicitado no está disponible en este momento en la tienda española."

 

He seguido también indicaciones de los foros de discusión de Apple, y me da el mismo error esta vez en la App Store, Can I update from Sierra 10.12.6 to High Sierra 10.13?, abriendo el link de descarga desde Chrome, el cual me abre la App Store en la página de High Sierra, me da opción a Abrir, y al darle al botón me da el error "Esta copia de la aplicación instalar macOS High Sierra está dañada, por lo que no puede usarse para instalar macOS"

¿Dónde podría descargar el instalador oficial de High Sierra?. ¿Conocéis el motivo por el que no me permite instalar High Sierra desde la App Store?

 

Un saludo y gracias de antemano.

Edited by iLike
aportación de más datos

Share this post


Link to post
Share on other sites

La solución la encontré en How to Fix “application is damaged, can’t be used to install macOS” Errors

 

La imágen que ya tenía descargada de High Sierra no estaba corrupta. Según se puede leer en el link, extraigo lo siguiente:

Citar

“This copy of the Install macOS Sierra.app application is damaged, and can’t be used to install macOS.”

If you want to see specifics and the expired certificate itself, you can investigate .pkg components of the MacOS Installer with tools like Suspicious Package and pkgutil, which can show the expired certificate that causes the error message:

Me ha funcionado el método 2 Method 2: Modifying the Application Installer to Fix “Install MacOS Application is Damaged” Errors, eliminando del instalador el archivo "InstallInfo.plist", y volviendo a abrirlo, ya me lo acepta y he podido instalar High Sierra.

 

Share this post


Link to post
Share on other sites
Hace 3 horas, Albarre dijo:

Mira este otro hilo: 

 

No me funcionó el enlace de descarga de ese hilo, que a fin de cuentas me abría el App Store reportando el mismo error para High Sierra de que estaba "dañado"

El problema según leí en el link que os pasé, es que los instaladores de versiones antiguas hacen una comprobación de certificado (estaba cadudado), y no es que estén "dañados", sino que los certifcados de esos instaladores caducaron.

Share this post


Link to post
Share on other sites

Gracias a ambos por las respuestas.

Sí mock turtle, como comenté anteriormente, ya lo solucioné (en mi caso sí estaba conectado a internet).

Lo que viene en el hilo que indicas, según leí, al cambiar la fecha haría que no fallase la validación del certificado.

Saludos.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.