Jump to content

Mac Mini no reconoce lector interno de tarjeta de memoria


Recommended Posts

Buenos días,

- estando en Mac OS Sierra el lector interno de tarjeta de memoria (SdCard) del Mac de la firma funcionaba correctamente.

- Actualicé hace un mes a High Sierra

- He ido a probar el lector y no me lo reconoce como hardware 😕, por lo que ni siquiera aparece en utilidad de discos. En información del sistema -> lector de tarjetas me sale el mensaje:

Este ordenador no contiene ningún lector interno de tarjetas de memoria de Apple.

- He probado las tarjetas SD en otros ordenadores y funcionan correctamente.

- He reproducido el error de no renocer el lector desde otro usuarios del Mac Mini de la firma.

 

Estuve leyendo el siguiente link (How to Fix SD Card not Reading or Recognized on Mac?) y lo único que hice fue seguir parte del paso 5 del apartado "SD card is not recognized/detected by Mac Disk Utility" y resetear PRAM, sin que haya obtenido resultado.

Nuevos datos y pruebas:

- Me ha salido una actualización de seguridad que he instalado (> de 2GB).
- Al reiniciar seguía el error. Volví a resetear la PRAM con el mismo resultado.
- Reseteo SMC y ahora sí me detecta el hardware:

Lector de tarjetas SD integrado:

  ID del fabricante:    0x14e4
  ID del dispositivo:    0x16bc
  ID del fabricante del subsistema:    0x14e4
  ID del subsistema:    0x0000
  Revisión:    0x0000
  Anchura del enlace:    x1
  Velocidad del enlace:    2.5 GT/s

- Una vez detectado el hardware (tras el reseteo SMC), le vuelvo a meter una tarjeta SD y sigue sin detectarla Utilidad de discos ni Finder.

 

Edited by iLike
aportar más datos
Link to post
Share on other sites

Lo he intentado limpiar con un secador en frío a buena potencia redireccionando el aire a la ranura, y nada.

Creo que tiene que ver con la actualización del sistema operativo y el hardware.
Si reseteo PRAM no me detecta el lector de tarjetas.
Cuando reseteo SMC sí me reconoce el lector, pero sigue sin reconocerme las tarjetas SD.

Algo raro pasa ahí desde la actualización del SO.

Edited by iLike
Link to post
Share on other sites

1-¿Hasta actualizado High Sierra hasta la ultima version del mismo?

2-Si apagas, metes la tarjeta y enciendes...¿aparece al inicio?

3-En que formato están las tarjetas a mi me dan porsaco a veces la que están en exfat...porque a veces las considera que no se han expulsado bien (por lo que sea) y ni las monta porque macOS no las puede reparar o algo asi

Link to post
Share on other sites

A ver: yo tengo un iMac del 2009 y desde no sé qué versión el lector de tarjetas SD se perdió. En alguna ocasión pareció funcionar, pero desde hace años ya nada.

Yo apostaría a que es un problema de software. Tengo el VirtualBox y creo que podría estar relacionado. Es una corazonada y podría estar muy equivocado, pero me da por pensar que por ahí van los tiros.


Saludos,

Link to post
Share on other sites
El 14/8/2020 a las 21:12, miguej dijo:

1-¿Hasta actualizado High Sierra hasta la ultima version del mismo?

2-Si apagas, metes la tarjeta y enciendes...¿aparece al inicio?

3-En que formato están las tarjetas a mi me dan porsaco a veces la que están en exfat...porque a veces las considera que no se han expulsado bien (por lo que sea) y ni las monta porque macOS no las puede reparar o algo asi

1.- Sí
2.- No. De hecho vuelve a no reconocer tras el reinicio el lector de tarjetas, y haría falta nuevamente un reseteo SMC para que reconociera el hardware
3.- Ahora no recuerdo ni tengo ordenador a mano para comprobarlo (utilizo otros ordenadores para poder descargar las fotos y pasarlas al Mac mediante pendrive)
No es posible que sea problema de tarjeta ni formato pues van bien en todos los ordenadores que he probado (Mac, Windows, Linux)

 

El 15/8/2020 a las 22:45, MacArron dijo:

A ver: yo tengo un iMac del 2009 y desde no sé qué versión el lector de tarjetas SD se perdió. En alguna ocasión pareció funcionar, pero desde hace años ya nada.

Yo apostaría a que es un problema de software. Tengo el VirtualBox y creo que podría estar relacionado. Es una corazonada y podría estar muy equivocado, pero me da por pensar que por ahí van los tiros.


Saludos,

Es posible y probable que tras los años, el hardware no esté bien y a lo mejor ha coincidido con la actualilzación a High Sierra.
No tengo Virtualbox instalado.

Edited by iLike
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.