Jump to content

Pifiada al instalar Windows 10


Recommended Posts

Hola a todos, creo que este sería el sitio para la pregunta. Pues he intentado instalar windows 10 en Catalina. Mi Macbook pro de 2012 le ha pasado algo muy raro, al menos para mi.

Tenía la partición encriptada que creo que de ahí el problema. Pues el bootcamp no me dejaba instalar, no salía automáticamente para descargar windows 10 desde la página oficial. Pues todo aventurado creo una partición del principal, no de la de datos. De las dos que salen, no la de datos. Creo 200 Gigas ya que tengo 1 TB de memoria. Introduzco un usb para la instalación del windows (pagina oficial), y se me crea correctamente.

Bueno, , estando todo normal en el macbook , veo mis archivos, todo correcto. Reinicio el mac para instalar desde el USB con windows. Pues se reinicia con UBUNTU. Ya solo me sale la partición con Ubuntu. No veo la otra partición ios. SI consigo ver que está aparte cómo bacia. Pero al pulsar ALT solo me aparece un disco el de los 200GB. He probado con todo y ya no se que hacer. Es que cuando lo reinicie solo y se me instaló el usb con windows con bootcamp (pagina oficial windows), estaba el Mac perfecto, y reinicio cómo siempre de rapido, no le dio tiempo a instalar UBUNTU. No se lo que pinta UBUNTU ni de dónde sale. En el macbook nunca he tenido unbuntu, en el USB no estaba ubuntu, y pagina de descarga del windows es la oficial. Bueno que aburro....... Alguien me puede dar pista. Gracias de antemano

Link to post
Share on other sites
Posted (edited)

Desde recuperación, aun a riesgo de perder los datos, me sale que puedo reinstalar macOS Catalina, pero me pregunta en que disco lo quiero instalar y no aparece ninguno. Por si ayuda

IMG_5946.thumb.jpg.c2321a5b97822d2b68b68d90b8c7d855.jpg

Edited by deprado
Link to post
Share on other sites

Por lo que he encontrado de este comando diria que los números de las EFI empiezan siempre del 0 (0000 en notación hexadecimal correcta, que es el tipo de número que ese comando requiere) y en este disco solo hay una.

Tu estás mirando el orden de las particiones no el de las EFI disponibles. Si ejecutas el comando sin opciones (efibootmgr) verás las especificaciones actuales.

Como seguramente ya has visto en el segundo comando (sudo efiboottmgr -ó 1) has puesto una “t” de más. Con orden no encontrada se refiere al comando mal escrito y no al orden de arranque de las EFI.

Link to post
Share on other sites
Posted (edited)

En primer lugar agradecerte que dediques tiempo a mi problema.  Ejecutaré el efibootmgr. A ver qué me dice. La verdad que no se ni lo que hago, pero antes de molestar intento todo lo que leo en foros. Saludos

Edited by deprado
Link to post
Share on other sites
Posted (edited)

Creia que sabías y por eso usabas esas instrucciones. 

Ahora no puedo enlazarte las webs pero en el apartado de soporte de Apple explican como formatear e instalar el MacOS de cero sin necesidad de usar comandos. 

Cuando tenga más tiempo, si no lo solucionas antes, me releo tu mensaje y te enlazo posibles soluciones. 

Edited by APB
Link to post
Share on other sites
Hace 18 horas, APB dijo:

Creia que sabías y por eso usabas esas instrucciones. 

Ahora no puedo enlazarte las webs pero en el apartado de soporte de Apple explican como formatear e instalar el MacOS de cero sin necesidad de usar comandos. 

Cuando tenga más tiempo, si no lo solucionas antes, me releo tu mensaje y te enlazo posibles soluciones. 

Buenas , ayer intenté poner los comandos para mirar el EFI. Cómo lo copié de otro sitio se ve que no di con la tecla. Pongo otra captura a ver si os da pista. Creo que mi archivos y el iOS Catalina está en los 690.9 Gigas. Ya que la pifiada fue al intentar hacer una partición ( creo que la hice en un lugar equivocado). Intenté hacer una partición de 200 gigas. ¿ entiendo que perderé todos mis datos y la única solución es instalación de 0?. Es que cuando hice la partición y se instaló el usb con Windows, todo estaba correcto. Y al reiniciar el macbook sin el usb, se inicia con Ubuntu. Un misterio para mi, nunca instalé  Ubuntu.

gracias por la ayuda que con 50 tacos ya esto es de nivel….

Link to post
Share on other sites

Si nunca instalaste, tu u otra persona, Ubuntu en este Mac y ahora aparece es que ese USB que creías que contenía Windows contiene Ubuntu. O te has equivocado de USB o esa pagina oficial no lo era tanto.

Con sudo efibootmgr -v deberías ver que ajustes de arranque tienes y los números de cada EFI para así poder establecer el orden con las instrucciones que usaste al principio. Más opciones de este comando: https://linux.die.net/man/8/efibootmgr

 

En el peor de los casos, si nada funciona, puedes volver a arrancar en modo recuperación y, antes de instalar nada, usar la Utilidad de Discos para formatear todo el disco. Así perderás todos los datos pero, una vez instalado el MacOS, el Mac volverá a funcionar correctamente. https://support.apple.com/es-es/HT204904

 

PD: El nombre del sistema operativo de los ordenadores Apple es MacOS (anteriormente OSX). iOS es el nombre del S.O. de los iPhone.

Link to post
Share on other sites
Hace 7 horas, APB dijo:

Si nunca instalaste, tu u otra persona, Ubuntu en este Mac y ahora aparece es que ese USB que creías que contenía Windows contiene Ubuntu. O te has equivocado de USB o esa pagina oficial no lo era tanto.

Con sudo efibootmgr -v deberías ver que ajustes de arranque tienes y los números de cada EFI para así poder establecer el orden con las instrucciones que usaste al principio. Más opciones de este comando: https://linux.die.net/man/8/efibootmgr

 

En el peor de los casos, si nada funciona, puedes volver a arrancar en modo recuperación y, antes de instalar nada, usar la Utilidad de Discos para formatear todo el disco. Así perderás todos los datos pero, una vez instalado el MacOS, el Mac volverá a funcionar correctamente. https://support.apple.com/es-es/HT204904

 

PD: El nombre del sistema operativo de los ordenadores Apple es MacOS (anteriormente OSX). iOS es el nombre del S.O. de los iPhone.

Joder que fallo 🤦🏻‍♂️. Bueno en Ubuntu he puesto lo que me indicas, a ver si da una pista

CD917A53-0662-4701-B2FE-95EB90579217.jpeg

Link to post
Share on other sites
Posted (edited)

Si te fijas en el orden de arranque primero está la EFI 0000 (Ubuntu) y luego la 0080 (diría que es la MacOS). Cambia el orden de arranque:

sudo efibootmgr -o 0080,0000

sudo efibootmgr -n 0080

Espero que te funcione.

Edited by APB
Link to post
Share on other sites
Posted (edited)

Hazlo desde Ubuntu.

Mi Terminal (High Sierra) no lo reconoce por lo que debe ser un comando Linux.

Edited by APB
Link to post
Share on other sites
El 11/5/2021 a las 23:00, APB dijo:

Hazlo desde Ubuntu.

Mi Terminal (High Sierra) no lo reconoce por lo que debe ser un comando Linux.

APB, mis más sincero agradecimiento por las molestias. Eres el único que te has apiadado de mi, y es de agradecer. Intente lo último que me dijiste y no veía color. Opté por tu opción de borrar disco e instalación limpia.

Pensaba que con un código en el terminal volvía a dar permiso para usar la partición del OS X, algo con menos complicaciones. Bueno doy por terminado el hilo. Gracias por la ayuda APB, eres buena gente. Saludos

Link to post
Share on other sites

Lastima que no funcionara y tuvieras que formatearlo todo. Espero que lo hayas recuperado todo de la copia de seguridad, antes de empezar a particionar e instalar un nuevo SO en un ordenador debería ser obligatorio hacerla de todo el contenido del disco. Como has demostrado nunca se sabe que puede ocurrir.

Hace 3 horas, deprado dijo:

APB, mis más sincero agradecimiento por las molestias. Eres el único que te has apiadado de mi…

De nada. Supongo que los que pululamos por aquí no somos muy linuxeros, para eso usamos MacOS. Y los que lo son no deben haber entrado en el hilo ya que en el título citas al Windows y no a Ubuntu.

 

PD: Por curiosidad, ¿ya sabes que ha ocurrido con ese Windows que se transformó en Ubuntu? ¿Te equivocaste de USB, bajaste un Windows pirateado, tenías instalado Ubuntu antes y no te acordabas, …?

Link to post
Share on other sites

Voto por la pagina pirata. Yo no soy muy ducho en informática. Pero se lo que hago. Primero formatee el pen. Hice una partición de 200 gigas, ya que no podía hacerlo por bootcam al tener el disco encriptado.

Luego desde la web de Windows, eligiendo Windows 10 lo baje al escritorio. Bootcam encuentra la descarga Windows 10 y al pen…. Veo que desaparece pen y luego aparece  con usb instalable. “ reinicio” para instalar y al reiniciar súper rápido, “ sin ni siquiera instalar el usb” inicia en Ubuntu.

El Macbook es de Segunda mano, lo compré hace dos años. Y por ello lo formatee el máximo nivel militar creo. Ahora deduzcamos que pasó…. Pen formateado, en otro ordenador ( un Mac). Macbook, que no lo uso apenas y nunca descargó nada que no se de la app de Mac, tampoco. 
pues solo se me ocurre que la web no era de Windows. 
Aunque todo indicaba que si. Pero la informática es matemática. 
Así que NPI

Link to post
Share on other sites
Posted (edited)

Leyendo lo que explicas apostaría que Ubuntu estaba instalado cuando lo compraste y al formatearlo la primera vez solo debiste borrar la partición principal y no toda la unidad.

Nunca he instalado Ubuntu, creo ni lo he tocado, pero lo de:

Hace 8 horas, deprado dijo:

… reiniciar súper rápido, “ sin ni siquiera instalar el usb” ….

No me cuadra con una instalación de un SO, sea el que sea.

Edited by APB
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.