Jump to content

La aplicación smpt intenta conectarse con un


Sangrantana
 Share

Recommended Posts

Hola, borjam.

Gracias por tu interés.

Estaré encantado de enviarte el archivo main.cf en cuanto sepa como localizarlo. He mirado el man de postfix y me sale esto:

 

The following options are implemented:

 

       -c config_dir

              Read the main.cf and master.cf configuration files in the  named

              directory  instead  of the default configuration directory.  Use

              this to distinguish between multiple Postfix  instances  on  the

              same host.

 

Y esto también:

 

FILES

       $config_directory/postfix-script, administrative commands

       $config_directory/main.cf, configuration parameters

       $config_directory/master.cf, Postfix daemon processes

 

Pero, aunque lo he intentado no sé como localizar ese archivo y mi manualito de unix no me saca del apuro :( Me siento tan zompo como cuando empecé a usar ordenadores con aquellos amstrad de hace mil años :blink:

 

O sea, que pido una ayuda.

 

Edito para hacer notar que la hora de macuarium no ha cambiado y que sigue en invierno, y que es más tarde de lo que parece.

Edited by Sangrantana
Link to comment
Share on other sites

la ruta para el "main.cf" es esta /private/etc/postfix

 

Solo tienes que darle a comando+G en el finder y escribir esa ruta, pero INSISTO, instala webmin es facilito de usar, todo via web con el safari y para nada es para montar un "superservidor" (aunque también lo puedes hacer), es igual de eficaz para montar uno "mini" como el que tengo yo, con web, correo y punto.

 

Ya nos contarás :)

Link to comment
Share on other sites

  • 3 weeks later...

Subo este hilo para informar de las últimas novedades.

Como sale más arriba, borjam, se ha repasado amable y pacientemente el main.cf –gracias a azazels, que me indicó la ruta– y la salida postconf -d de mi Postfix y, además, me ha ayudado a comprobar que Postfix rechazaba el relay desde su máquina.

El indicio que ha encontrado para explicar el asunto es que Postfix tiene, por defecto, el parámetro

 

mynetworks_style=subnet

 

lo que convierte en "fiables" todo un rango de IP dentro de la subred de ONO en la que estoy. Esto mismo creo que ya lo había sugerido Juanjo.

A indicación suya, he modificado este parámetro por

 

mynetworks_style=host

 

en el main.cf, que hace que sólo la máquina local sea un cliente "fiable".

Es decir, que sólo se puede enviar correo desde esta máquina, sin posibilidad alguna de relay.

Por otra parte, el atacante parece que está en Corea.

Por lo que llego a entender, parece que así se subsana el peligro, y el servidor es ahora seguro. :)

Gracias otra vez a todos por vuestra atención y paciencia.

Link to comment
Share on other sites

Gracias a todos. He seguido este interesante hilo atentamente aunque de momento no tengo Panther, cosa que cambiará en breve, Nos será muy útil a la hora de configurar Postfix para los que nos vayamos a lanzar a esa aventura.

 

Muchas gracias de nuevo. ;)

Link to comment
Share on other sites

  • 4 weeks later...

He vuelto :P . Ya con Panther instalado, PostFix activado y Relay imposibilitado.

 

Muchísimas gracias a todos de nuevo, y en especial a Santagrana por su tenacidad. ;)

 

Da gusto pasarse por Macuariun. :rolleyes:

Link to comment
Share on other sites

  • 4 months later...

Bueno, pues vuelvo a subir esto porque, después de la última actualización de seguridad (Security Update 2004-09-30) que modificaba algunos parámetros de Postfix, temía que mi main.cf volviera a permitir por defecto el dichoso relay. Cuál ha sido mi sorpresa al abrir con Vim el susodicho, que me encuentro con esto al final:

 

# THE FOLLOWING DEFAULTS ARE SET BY APPLE

#

# bind to localhost only

#

inet_interfaces = localhost

 

# turn off relaying for local subnet

#

mynetworks_style = host

 

# mydomain_fallback: optional domain to use if mydomain is not set and

# myhostname is not fully qualified.  It is ignored if neither are true.

#

mydomain_fallback = localhost

 

No sé seguro desde cuándo está eso ahí, pero supongo que lo está desde esta última actualización. Borjam dijo que había comentado esto a los de Postfix: quizá haya surtido efecto.

 

Saludos ;)

Link to comment
Share on other sites

  • 6 months later...
  • 2 years later...

Me acabo de dar cuenta de que esto iba mejor en redes e internet...lo siento :)

 

He probado una solución que encontré allí para Tiger:

 

sudo launchctl load -w /System/Library/LaunchDaemons/org.postfix.master.plist

sudo launchctl start org.postfix.master

 

No funciona...dice que el puerto 25 no está por la labor :D

 

De todas formas el problema que tenía lo he resuelto de otra forma. El caso es que desde una de las cuentas de correo que uso, no había forma de que funcionase el smtp (por eso quería activar postfix). Esa cuenta la añadí a otra que tengo de gmail (en la web de gmail configuración/cuentas) para que me permitiese enviar correo desde otra dirección distinta a la de gmail. Pensé que sólo funcionaba usando el correo web, pero en mail ahora puedo poner como smtp el de gmail para la cuenta problemática y lo envía perfectamente.

 

Aun así, seguiría estando bien saber cómo activar el postfix en Leopard ;)

 

Un saludo :)

Edited by bart
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.