Jump to content

Instalar X11 y KDE


jose_felix
 Share

Recommended Posts

Quiero instalar el KDE sobre Mac OSX, usando Fink y X11. He seguido los pasos de la guía de Urcindalo, pero parece que hago algo mal, porque no lo consigo. He recordado que en Mac OS X 10.3 cambia el shell, creo. Puede ocurrir que la guía no es válida para Mac OS X 10.3 y solo vale para Mac OS X 10.2?

Link to comment
Share on other sites

He instalado X11/KDE/Gnome en varias máquinas desde tiempos de "Jaguar" (10.2.x) y ahora con "Panther" (10.3.x), y a través de las distintas versiones de XDarwin y de la implementación de X11 de Apple, y creo que el proceso se ha"simplificado" bastante.

 

Fundamentalmente los pasos son los siguientes:

 

1. Instala las Development Tools de Apple. (O baja Xcode Tools 1.5.)

2. Instala la implementación de X11 de Apple.

3. Instala el SDK de las X11 de Apple.

4. Instala Fink. (fink.sourceforge.net)

5. Instalar KDE. Puedes instalar la versión ya compilada (3.1.4-21):

 

$ sudo apt-get install bundle-kde-ssl

 

O compilar e instalar la más reciente versión:

 

$ fink install bundle-kde-ssl

 

Dependiendo de la configuración de preferencias de X11 de Apple, puedes tener el entorno KDE en pantalla completa o mezclando las ventanas del OSX con las de KDE.

 

También lo puedes usar en una máquina remota y "traer" las ventanas de las aplicaciones X11/KDE a tu máquina local (o el entorno completo si estás en modo "Full screen").

 

Suerte.

 

(Escrito usando KDE Konqueror. B) )

Edited by Raul
Link to comment
Share on other sites

  • 2 weeks later...

He seguido los pasos que indicas en tu respuesta con algunas matizaciones:

 

1.He instalado las Development que vienen en el CD Xcode Tools de Panther (no se si hay una versión posterior). De este CD he hecho una instalacion personalizada y he instalado las X11 SDK, BSDSDK, y Development Tools. No he instalado ejemplos, documentación, etc.

 

2.Para instalar KDE he utilizado fink comander, procediendo a una instalacion de los binariios del paquete bundle-kde. (no el bundle-kde-ssl)

 

Una vez terminada la instalación, he arrancado KDE desde el terminal de las X11 con el siguiente comando: sw/bin/startkde.

 

Aparece la ventana de configuracion de KDE y selecciono todas las opciones por defecto.

 

Todo va aparentemente perfecto, hasta que aparece el fondo de pantalla de KDE y las Ktips. En ese momento, cuando hago click con el raton sobre la ventana de las Ktips, esta se desactiva y no puedo seleccionarla, ni por supuesto, pinchar dentro de sus funciones (Cancel, Ok, etc..).

 

El resto de ventanas de X11 (en este caso el terminal de X11, tambien se desactivan). Solo puedo lanzar un nuevo xterm desde el menu, que al aparecer en pantalla se desactiva en cuanto hago clic sobre el.

 

No se que puedo haber hecho mal

 

Tengo instalada la ultima version del sistema operqativo actualizado.

 

He realizado la instalacion del Mac OS X en un disco limpio, instalando primero el Panter desde los CDs de instalacion, actualizandolo luego a la ultiuma actualizacion, y posteriormente instalando el rsto de herramientas que indicas en tu carta.

 

No se que hacer... :-(

Link to comment
Share on other sites

Hola, no sé qué te está sucediendo mal. Veamos, si no tienes un archivo .xinitrc, (el el directorio raíz) crea uno conteniendo lo siguiente:

 

source /sw/bin/init.sh
export KDEWM=kwin
exec /sw/bin/startkde >/tmp/kde.log 2>&1

 

Si bien a mi me funciona tanto como en Full Screen como si no, prefiero el primer modo para una "experiencia KDE" total, sin embargo funciona también de la otra manera (aunque con el menú Apple en la parte superior).

 

También, una vez instalado KDE, puedo correr aplicaciones como Konqueror o Kate, etc directamente sobre el Mac OS X, en medio de ventanas Aqua al lanzar esos programas desde Terminal (tanto si están en mi máquina local como desde una remota :) ).

Edited by Raul
Link to comment
Share on other sites

- Mensaje enviado desde Konqueror, sobre KDE a "full screen mode" :D-

Felicidades, qué bueno lo lograste tan rápido. Ahora bien, para el acceso remoto de aplicaciones X11 (KDE o no) necesitas ajustar ciertas cosas en tu máquina remota:

 

1. Establece una conexión ssh a la máquina remota.

2. Edita los archivos /etc/ssh_config y /etc/sshd_config:

 

sudo pico /etc/ssh_config

sudo pico /etc/sshd_config

 

Y modifica del primero la línea donde dice:

 

 #ForwardX11 no

a:

 ForwardX11 yes

 

Del segundo:

 

 #X11Forwarding no

a:

 X11Forwarding yes

 

3. Reinicia sshd:

 

sudo killall -HUP xinetd

 

4. Desconéctate de la máquina remota.

 

5. Conéctate de nuevo, pero ahora empleando además la opción -X:

 

ssh -X usuario@servidor

 

6. Prueba con algo sencillo:

 

 xclock &

ó

 xlogo &

 

Si todo sucede adecuadamente, intenta llamar una aplicación más grande. Para utilizar aplicaciones KDE, estas necesitan estar instaladas en la máquina remota. Si ya las instalaste, prueba con Konqueror, por ejemplo:

 

/sw/bin/konqueror > /dev/null 2>&1 &

 

Si todo va bien, intenta:

 

/sw/bin/startkde > /dev/null 2>&1 &

 

 

Creo que eso es todo, espero no haber olvidado nada. Avísame si tienes problemas.

 

Suerte.

Link to comment
Share on other sites

En bash, para fin de prueba, escribe en Terminal lo siguiente:

 

 export DISPLAY=:0.0

 

E intenta conectar con el servidor remoto.

 

Para que esto quede ya definido en tu sistema, edita el archivo .bashrc para que contenga lo siguiente:

 

 if [[ -z $DISPLAY ]]
 then
 export DISPLAY=:0.0
fi

Edited by Raul
Link to comment
Share on other sites

¿Tienes corriendo las X11 en tu máquina local (no en la remota) cuando intentas conectarte con ssh? Porque si no, no se puede y reporta el siguiente error (que creo es el que te aparece):

 

Warning: No xauth data; using fake authentication data for X11 forwarding.
connect /tmp/.X11-unix/X0: No such file or directory

 

A ver si ahora sí.

Edited by Raul
Link to comment
Share on other sites

Sigue sin funcionar.

 

Voy a explicar como lo estoy haciendo, a ver si localizamos el fallo.

 

1. Maquina remota: Es el servidor al que me conecto

2. Maquina local: El Mac donde quiero ejecutar las aplicaciones del servidor.

 

He modificado en la máqúina remota los ficheros etc/ssh_config y etc/sshd_config.

 

He escrito en bash (en la terminal local) "export DISPLAY=:0.0 y he editado en local el fichero .bashrc (en el directorio de mi usuario) como indicas.

 

He lanzado X11 en el ordenador local

 

Desde el Terminal conecto con ssh -X usario@servidor

 

Cuando envio dedes el terminal el comando xclock & la respuesta sigue siendo "Can't open display:0.0"

 

Espero que podamos localizar el error.

Link to comment
Share on other sites

Estoy teniendo un problema desde que conseguí ejecutar las aplicaciones en remoto.

 

Si ejecuto konqueror, kmail, keyes, etc, van perfectamente, corriendo dentro de una ventana típica de MacOS X, con su "semáforo" en la parte superior izquierda.

 

Pero, al lanzar KDE, me pasa lo mismoen la máquina remota que me ocurría cuando instalé KDE en el "servidor".

 

Aparece un conflicto entre los Window Managers (creo que ese es el problema) y cuando va terminando la instalacion de KDE, en lugar de aparecer las ventanas con la interfaz KDE, aparecen con la del MacOS X, y al intentar pinchar sobre ellas, se bloquean, impidiendo poder acceder a ellas (incluso la ventana del xterm).

 

Llevo dos dias tratando de resolverlo, pero ya me he dado por vencido.

 

Repito, es el mismo problema que se solucionó en la maquina servidor creando un fichero .xinitrc con el código:

 

source /sw/bin/init.sh

export KDEWM=kwin

exec /sw/bin/startkde >/tmp/kde.log 2>&1

 

 

Alguna idea?

Link to comment
Share on other sites

  • 8 months later...

Buenaaaassss, reabro el tema si me lo permiten, porque acabo de instalar el kde 3.4 bajo las x11 de apple y en tiger, y a la hora de arrancarlo ni un problema, a pantalla completa sin errores....... pero no tengo fuentes de letra, solo aparecen cuadraditos.

Alguna idea ??

 

Instale el kdebase3 desde consola con el fink, con el modulo de español, y tambien configuré el .xinitrc.

 

Supongo tendré que configurar algún archivo para decirle donde se encuentran las fuentes de letra, pero cual?

 

Se os ocurre algo ??

 

SaludOSX

Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.