Jump to content

Se puede instalar OS 9.2 en Powerbook G3


Recommended Posts

Estamos tratando de instalar en un Powerbook G3 series que tenía originalmente OS 8.6

un OS 9.2, pero no nos lo acepta. Hemos visto en la página de compatibilidades que ese modelo aceptaría incluso hasta Jaguar. Pero a la hora de instalar el 9.2 no lo permite.

 

¿Hay alguna manera de hacerlo? En las busquedas he visto que se puede usar Xpostgfacto o incluso OS9 helper, pero no me queda claro y parece que ambos podrían dar algún tipo de problema.

 

¿Alguien nos puede aclarar algo?

Link to post
Share on other sites

Nos dice que el equipo no lo soporta.

 

Ahora mismo, le hemos vuelto a instalar otro OS, tenía originalmente el OS8.6, ahora está con el OS 8.5, no teniamos copia del 8.6.

 

Necesitariamos instalarle el 9.2 que es el que tenemos. ¿Se podría hacer, con el OS 9 helper?

Link to post
Share on other sites

Estamos contemplando la posibilidad de que el problema para instalar sea del disco duro. Es un Ata de 20 gigas. ¿Alguien sabe si es posible que sea esto lo que nos impide instalar el sistema operativo?

Link to post
Share on other sites

Durante un tiempo, creo que ya no lo hace, Apple suministraba los discos del OS personalizados para el modelo de ordenador con el que se vendía. Si intentas utilizar esos discos con otro modelo te dice que no lo soporta (o algo parecido). ¿No será este el problema?

 

El Xpostfacto, (sin la g), sirve para instalar el OS X en equipos que no lo soportan.

El OS9 helper sirve para instalar las versiones 9.2 y superiores en equipos que no las soportan, aunque dices que tu equipo sí lo hace.

Link to post
Share on other sites

Hemos intentado el OS9 helper pero no nos deja instalar el OS9.2, dice que necesitamos el OS9.1

 

Si intentamos instalar el Jaguar, nos pide el OS 9.1 o superior, pero si lo intentamos con el OS 9 nos dice que no se puede isntalar

Link to post
Share on other sites

Si, aunque no creo que aún se vendan.

 

Parece ser que estás intentando instalar el OS 9 en el PowerBook usando un CD que venía con un equipo más moderno, y estos creo que solo valen para los equipos con los que venian.

 

Si puedes, hazte con un CD de instalación de OS 9 "universal" (de los que se compraban como paquete de software aparte) y luego aplica los parches hasta la 9.2.2.

Link to post
Share on other sites

Es el que te dan cuando compras solamente el OS.

 

 

O sea, el que no trae ordenador de regalo. :D :D

 

 

 

 

 

 

Editado: Se me han adelantado. :o

Edited by APB
Link to post
Share on other sites

¿Y arrancando desde el CD de instalación del 9.2?

 

 

Y, si eres valiente y con tiempo libre, prueba a copiar directamente el OS 9.2 que tienes instalado en los otros ordenadores, reinicia y, si funciona, actualízate a la 9.2.1 y a la 9.2.2.

Es muy probable que no funcione o, si lo hace, te dé problemas.

 

Y, sobre todo, TEN UN CD DE ARRAQUE A MANO que funcione con este ordenador.

 

Yo lo he hecho con ordenadores de diferentes modelos y ha funcionado sin problemas. Pero nunca con un portátil.

Edited by APB
Link to post
Share on other sites

APB: Disculpa el corte del hilo, intentaremos hacer lo que propones. Aclararte que el portatil nos lo vende otro amigo, porque quiso probar con un apple pero no se hizo a el.

Tal y como venía con el 8.6, nos pareció que estaba un poco cojo, por lo que intentamos al menos que funcionase bajo un 9x. La sorpresa vino cuando no nos lo acepta, y tampoco un Jaguar. En las páginas de Apple vemos que si es posible. En los foros tambien hay usuarios que dicen que es posible. Pero los mensajes de error son contundentes. Seguiremos intentandolo. Gracias.

Link to post
Share on other sites

El Instalador del Mac OS no es más que un programa que ejecuta un listado de documentos (scripts). Tiene una lista, una ruta de acceso para encontrarlos y debe ejecutarlos en el orden preestablecido. Al igual que hay un script de que te da la bienvenida hay otro que comprueba la incompatibilidad con el hardware. No distingue si ejecuta 10 veces el mismo script con diferentes nombres.

Link to post
Share on other sites

Si tiene un 8.6, puede ser un problema de firmware, ya has mirado cual tienes y cual hay en apple? , las maquinads con 8.x requerian de un update de firmware pa pasar al 9.x, al menos el iMac Blue Bondi o los ordenadores de la epoca, seguro que ese PowerBook tambien lo necesita ;)

Link to post
Share on other sites

Bueno te cuento .

1......si tienes el 9.2.2 es una actualizacion y as de instalar como minimo el 9.2.1 y despues actualizar.

 

2.....comprueba en el perfil del sistema que el disco duro este formateado como hfs+ si es hfs no podras instalar.

 

3......comprueba que la version del firmware que tienes sea la correcta.

Link to post
Share on other sites

A noz le debe haber funcionado bien LA SOLUCIÓN que le envié en privado porque no ha vuelto a preguntar.

 

Mi anterior post era para que en futuras búsquedas los foreros puedan deducirla :rolleyes: y ahorrarme los privados.

Link to post
Share on other sites

Gracias a todos por vuestras sugerencias y perdón de nuevo por el silencio de estos días.

 

La solución al imposible vino de la siguiente manera:

 

Instalación en disco duro de otro G3 del sistema OS9.0.2, desde este, actualización vía página web de apple a OS9.1.0, y nueva actualización vía dísco a OS9.2.1. Copia de todas las carpetas creadas a un CD.

 

Con este CD copia a una partición del portátil, y arranque desde esa partición.

 

OS9.2.1, funcionando a toda pastilla.

 

Rebuscado, pero fué la única manera, no había forma de hacerlo funcionar más allá del OS8.6

 

Gracias de nuevo.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.